Jump to content

Are you tired of all this laggin and crashing


Sarienna1
 Share

You are about to reply to a thread that has been inactive for 305 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

On 10/21/2020 at 9:54 PM, Fritigern Gothly said:

Did you live under a rock these past few years? LL is migrating to new servers. They are in the middle of that process!

I just gotta ask this question after reading your response. lol And what exactly was their excuse before this? lol They ain't been migrating the entire 15+ years. lol That'd be one heck of a migration mate. Lmao!!!! :D

I mean seriously what was the point of that smart ass response other then to be a butt hole to the OP?🤦‍♂️

  • Like 1
Link to comment
Share on other sites

On 10/23/2020 at 2:23 PM, Cindy Evanier said:

You mean like this she just posted .  Blog posts are featured right top and centre of everyones dashboard.  It's not the lindens fault if people don't bother to look.

 

Just a point of fact. Most noobs wouldn't even know where to look for that at unless someone told them about it and most do not even log in to their dashboard much if at all. I hardly ever do. I mean heck I didn't even hear about the migration until a few days ago and it was because of a Google search I did. It wasn't from the web site or any blog. All I am saying is some type of ingame notices wouldn't be an entirely bad idea mate. I think @H8actually did make some very valid points. It's not like SL came with an instruction manual when we all first started. Most of us just had to figure things out for ourselves. I personally don't care about it anymore as much myself because I am not on here like that anymore, but I can see how it could get on some people nerves. lol :D

Edited by Velk Kerang
Corrections.
  • Like 2
Link to comment
Share on other sites

On 10/21/2020 at 6:54 PM, Fritigern Gothly said:

Did you live under a rock these past few years? LL is migrating to new servers. They are in the middle of that process!

That's using up all the developer time, but it's not the cause of teleport and region crossing problems. Those suck about the same no matter which data center is running the sim.

  • Like 1
Link to comment
Share on other sites

10 minutes ago, animats said:

That's using up all the developer time, but it's not the cause of teleport and region crossing problems. Those suck about the same no matter which data center is running the sim.

First, the rough spots:

  • Region Crossings
    One of the first troubles we found was that region crossings were significantly worse between a cloud region and a datacenter region. We did a deep dive into the code for objects (boats, cars, planes, etc) and produced an improvement that made them significantly faster and more reliable even within the datacenter. This has been applied to all regions already and was a good step forward.
  • Increased Teleport Failures
    We have seen a slight increase in the frequency of teleport failures. I know that if it's happened to you it probably doesn't feel like a "slight" problem, especially since it appears to be true that if it's happened to someone once, it tends to keep happening for a while. Measured over the entire grid, it's just under two percentage points, but even that is unacceptable. We're less sure of the specific causes for this (including whether or not it's Uplift related), but are improving our ability to collect data on it and are very much focused on finding and fixing the problem whatever it is.
  • So yeah, it might be or might not be according to LL.
  • Like 1
Link to comment
Share on other sites

8 minutes ago, RowanMinx said:

One of the first troubles we found was that region crossings were significantly worse between a cloud region and a datacenter region. We did a deep dive into the code for objects (boats, cars, planes, etc) and produced an improvement that made them significantly faster and more reliable even within the datacenter. This has been applied to all regions already and was a good step forward.

That was good, and it helped, especially for large, complex vehicles, mostly boats. The remaining problems are on the avatar side. Most region crossing fails  have the vehicle crossing OK with the avatars Left Behind. Teleports, of course, are avatar-only.

There's also some problem connecting to new regions. I've been posting pictures where I've reached the edge of a region and the next region takes 10-20 seconds to appear. That got worse in the last two months. It's usually at the same sims, too. That might be related to the teleport problem, which, of course, involves connecting to a new region.

It's discouraging that this isn't fixed yet. It is encouraging, though, that it's starting to look like a small number of very specific problems.

  • Like 1
Link to comment
Share on other sites

FFS give the Lindens a break, why don't you @H8.  For once they ARE telling us what is going on!  The fact that you cannot be bothered to find the info when it is under your nose does not  make LL the ones at fault.

Yes, this is me defendinging the Lindens... oo'd a thowt it!  I give credit where it's due and it is due to Oz and April, this time.

  • Like 3
Link to comment
Share on other sites

12 hours ago, Aishagain said:

FFS give the Lindens a break, why don't you @H8.  For once they ARE telling us what is going on!  The fact that you cannot be bothered to find the info when it is under your nose does not  make LL the ones at fault.

Yes, this is me defendinging the Lindens... oo'd a thowt it!  I give credit where it's due and it is due to Oz and April, this time.

In vague terms they might be telling us what is going on but not in the specifics. The jira raised with the partial unsit problem on region crossings, that has broken a lot of vehicles got hidden. We can hope they are aware and working on it, but some public acknowledgement of the problem would be nice. 

Edited by Aethelwine
Link to comment
Share on other sites

On 10/25/2020 at 7:05 PM, animats said:

That was good, and it helped, especially for large, complex vehicles, mostly boats. The remaining problems are on the avatar side. Most region crossing fails  have the vehicle crossing OK with the avatars Left Behind. Teleports, of course, are avatar-only.

There's also some problem connecting to new regions. I've been posting pictures where I've reached the edge of a region and the next region takes 10-20 seconds to appear. That got worse in the last two months. It's usually at the same sims, too. That might be related to the teleport problem, which, of course, involves connecting to a new region.

It's discouraging that this isn't fixed yet. It is encouraging, though, that it's starting to look like a small number of very specific problems.

The main problem I am aware of is the sort order of sitters on a region crossing being broken, breaking a lot of vehicles especially with a passenger.  Hiking on boats breaks after a few crossings,  or the vehicle just comes to a stop because even though sat on it, the script has lost them. 

Link to comment
Share on other sites

4 hours ago, Aethelwine said:

The main problem I am aware of is the sort order of sitters on a region crossing being broken, breaking a lot of vehicles especially with a passenger.  Hiking on boats breaks after a few crossings,  or the vehicle just comes to a stop because even though sat on it, the script has lost them. 

After a region crossing, a vehicle has to re-establish all animations, controls, and sounds. Scripts must wait until all avatars are fully re-seated (avatar parent is the vehicle) and then do it. It's a pain, but a necessary workaround. Also, if a vehicle loses its driver, it should stop until the avatar catches up and re-seats.

If you do that, region crossings are either OK or hard fail. Hard fail is the avatar totally separated from the vehicle. That's the major sim-side bug LL has been unable to fix for years.

Most of the better vehicle builders do this by now.

Link to comment
Share on other sites

2 hours ago, animats said:

After a region crossing, a vehicle has to re-establish all animations, controls, and sounds. Scripts must wait until all avatars are fully re-seated (avatar parent is the vehicle) and then do it. It's a pain, but a necessary workaround. Also, if a vehicle loses its driver, it should stop until the avatar catches up and re-seats.

If you do that, region crossings are either OK or hard fail. Hard fail is the avatar totally separated from the vehicle. That's the major sim-side bug LL has been unable to fix for years.

Most of the better vehicle builders do this by now.

The technicalities are beyond me but what is happening is new. I have been running cruises weekly for 5 years, and there is something new in the last month with regular fails on crossings.

Motorloon's boats that have been at the peak of reliability for years are since the last month failing on crossings 9stopping dead with the skipper still sat on the boat, enough that they are frustrating to sail. Bandit Ifs, Star Classes, are all l getting stuck in partial unsits with hiking broken until the skipper resits. Trudeaus with relatively primitive sit scripts work fine with one person on board, but add a passenger and the same symptoms arise. I am told from a friend doing testing with scripts it is all to do with the sit order being broken on crossings where they weren't before the changes introduced a month ago. Rattletrap are in the same situation they were if I recall correctly contributing in the Jira that got hidden soon after I started contributing.

It is the major builders vehicles that are failing, in the sailing community and I am told (as not really involved with) in the flying community to.

At the moment to sail for any length of time it is best to take a Trudeau a B22 or a Launch and don't take a passenger. Lots of people are complaining of partial unsits every 20 minutes or so on other boats.

Edited by Aethelwine
Link to comment
Share on other sites

  • 4 weeks later...
On 10/21/2020 at 10:25 PM, Solar Legion said:

The permanent solution to "lag" issues: Remove all user created content, replace with generic MMO Schlock Assets.

What's that? That would destroy Second Life? You don't say?!

Also the software/product is Second Life and the company is Linden Lab.

 Simply getting content creators to optimize their work goes a long way towards solving lag and crashing issues. This has been tested and proven effective in SL frequently over the years.

On 10/21/2020 at 10:38 PM, RowanMinx said:

Don't forget staying away from large groups of people.  Best to stay home by yourself if you can't deal with the lag.

If there were reasonable caps on avatar complexity and VRAM use then this wouldn't be much of an issue. Of course, when that suggestion is brought up some people get scared that such caps would hurt creativity or force people to have less interesting/appealing avatars, but it really wouldn't. It would simply force content creators to better optimize their work. If they have the skills to create content, then it's fairly easy to learn how to optimize. And a lot of optimization can be done without sacrificing visuals.

 This really does come down to LL failing to understand that SL content creators aren't simply going to pursue best content creation practices on their own. Most simply do not understand how 3D rendering works and why optimization is important. Once they settle into bad habits it becomes difficult to make content creators understand how their bad practices are affecting performance.

 Of course, the cat has been out of the bag for ages now and it's not something that can be easily fixed at this point. It would take a long term plan on the part of LL, involving new tools and features, better communication with the userbase with regards to how content affects performance, and slowly reigning in badly made content over a period of years to avoid excessively disrupting the user experience.

  • Like 2
Link to comment
Share on other sites

On 10/23/2020 at 3:50 PM, RowanMinx said:

Is it sock puppet Friday again?

I'm not lagging out as much as I am getting tired of the World Map not working. I have to log out and log in again by typing the name of the sim where I am going. Landmarks sometimes work -- often not. Sir Crashalot in that regard.

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 305 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...