• Announcements

    • Xiola Linden

      The New Community Platform   03/21/2017

      We are still working on making adjustments and changes to the new platform. Thanks  to everyone who has been sending in feedback and filing any bugs you've encountered! 

Aquila Kytori

Resident
  • Content count

    586
  • Joined

  • Last visited

Community Reputation

171 Excellent

About Aquila Kytori

  • Rank
    Advanced Member

Recent Profile Visitors

40 profile views
  1. You need to look more closely Drongle *https://community.secondlife.com/image_extract/169928iDFFA72B9FE0F80EC.jpg It seems the older the post the more chance images will still be intact. I expect its just a matter of time untill they sort out a similar system as before where images can be uploaded directly from hardrive. I hope there will be the option to search through pages of past images that had been used in ealier threads. I found that very usefull in the old forums to find older posts again that I wanted to link to. Just to note: looking through some of my previous posts I found an error in one where the image that was being used in my post was not the image I had originally used. Not one of my images at all If someone is missing "pink shoes" image from their post let me know and I will tell you where you can find it A spell checker would be nice ..............
  2. By default Blender uses “Blender units” 1 blender unit = a meter. Most, a lot, some people, (but not Chic) set units to Metric in Blender : 1 meter in Blender = exactly 1 meter in Second Life. There is one thing you should be are aware of,. Scaling, Rotating and or moving a mesh in Object mode is not the same as scaling etc in Edit mode. If you have to Scale in Object mode you should Apply those functions before UV unwrapping etc and or exporting to Collada ( .dae ) format for uploading to SL. Before uploading its best to have Scale = 1 and Rotation = 0 in all 3 axis. In the example below, in Object mode, I scaled the default cube ( 2 x 2 x 2 meters) along the X axis by 1.25, then change to Edit mode. Notice how the length of the edges along the X still indicate 2 meters. To show the correct length: return to Object mode and Apply the Scale: Now in Edit mode the correct length is indicated: As a general rule Add your starting mesh Primitive in Object mode and do all the rest of the mesh work in Edit mode. You may find the Mesureit addon usefull:
  3. You are going to have to start at the beginning. :smileywink:
  4. Why are you blaming that red and white circle thing for not being able to "move or rotate anything" ? http://blendersushi.blogspot.fr/2011/07/ui-that-pesky-3d-cursor.html
  5. ........... and thankyou Hans Rosling.
  6. Not sure ifthis is going to be of any help to you or not but the following explains how to import and join all the parts into a single Object in blender: Blender > File > Import > select the stage1.dae With everything selected ( A key toggles select everything or nothing) : Ctrl + A > Apply Rotation and Scale Still with everythinbg selected : Ctrl + J will join all the parts into a single Object. Next you can delete that camara thing: Now that all the parts are joined to be a single mesh Object it has 9 materials. You really don't want to be uploading mesh objects with more than 8 materials otherwise bad things will happen: I know its easy for me to suggest that you move to Blener but if you can do this and put up with the pain, after a few weeks you will realise how much more Blender has to offer when it comes to creating low poly models for use in SL.
  7. If in doubt use the official SL viewer I uploaded your .dae file and used the high lod mesh for Physics and then Analyzed the physics mesh. When rezzed I set the Physics shape Type to prim. Surprisingly the physics seemed to be working fine ! The number one problem I found was that it was being uploaded as a linkset of 20 objects. I coloured each one a different colour for you to see better : and an exploded view : I suggest you find out why this "single " object is getting split into 20 objects when you export as Collada and fix that. You are not the first person to have this happen when using sketchup and not going to like this but ........ I suggest you learn a little Blender :smileysurprised: I'm going to try opening your .dae in Blender to see how it looks there ............
  8. WhiteRock Darkstone wrote: Aquila, it's one single mesh. Do you think I should make it into two separate ones? Maybe I should make the roof a separate mesh? No. I think you should post your Sketchup and or .dae file so that we can take alook at it
  9. Hi When creating, uploading and assigning a physics mesh for a model that needs accurate collision surfaces there are a couple of basic rules that have to be complied with. Can you confirm that you have followed Rule 1? Rule 1 : Each visual mesh object has to have its own physics mesh. When rezzed in world is your mesh building a single mesh object or a linkset of 2 or more separate objects ?
  10. Drongle wrote Also, when you have multiple materials, the UV mapping of each can ovelap. They don't interfere because each becomes a "face" in SL, with a different texture applied. So the UV map of each material can fill the whole UV unit square. That means you can have more texture pixels per unit of surface area, improving the texture resolution over what you can achieve if you cram all the surface into one UV map. Just to try and illustrate what Drongle said: and next with each material using the full UV space:
  11. Hi I am not a Maya user but as you seem a bit desperate (2 posts asking the same question ) and untill a Maya user comes along ............. I think you need to use the Maya FBX Converter which you can download from here, http://usa.autodesk.com/adsk/servlet/pc/item?siteID=123112&id=22694909 And check out this youtube video on how to use it , Edited to add: I also seem to remember something about "Freezing Transformations" and or "Deleting History" before exporting. If that makes sence to you then try that ..............can't find the forum posts which mentions those
  12. What Drongle is describing only happens if the the Uploader is creating the “secret” additional materials and the origin of the mesh is outside the bounding box. Edit after reading Drongles explanation: OOOOps, Edited again: From Drongles explanation, the offset physics would be less noticeable if you moved the origin to the center of the bounding box. Move it up a little in the Z axis.
  13. This is what happens when I create a cube in Blender and subdivide it so that it has 24,500 vertices (no materials assigned).Then in edit mode move the cube away from its origin. This is how it appears in the Uploader (using the official SL viewer) with a simple cube used for Physics: and when rezzed inworld: If before exporting I Set Origin to Geometry at step 4 (first image) then the cube (and Physics) work as expected. Repeating steps 1 to 6 for a cube which has only been subdevided 5 times (6,146 vertices) then it uploads as expected
  14. Hi Chic You could check the Bounding Box opton in Blender then compare it with the the bounding box when rezzed inworld with Develop > Render Metadata > Bounding Boxes enabled.
  15. yes probably. But there are a couple of rules you need to comply with 1: If your mesh is a single mesh object then the Physics mesh must also be a single mesh object. (and visa versa). 2: The bounding box of your physics mesh has to be the same size (in the X, Y And Z axis) as the bounding box of the visual mesh. 3: Avoid any small or thin triangles in the Physics mesh. You don't need alot of details in the physics mesh , just enough collision surfaces for the avatar to collide with. Stairs can be a ramp. Windows can be filled in etc. Export your Physics mesh as a separate .dae file When uploading your skybox open the Physics tab of the mesh Uploader and in Step 1 choose the From File option and upload the physics .dae file there. Don't touch anything else in the Physics tab. Calculate weights and fees as usual then when you have your skybox rezzed inworld edit it. In Edit panel open the Features tab. There change the Physics Shape Type option from the default Convex Hull to Prim. Now you should be able to walk around inside the skybox.