Jump to content
Matty Luminos

Disappearing tattoo (mesh body)

Recommended Posts

Posted (edited)

Yesterday I wore a full-body tattoo on my Signature Geralt body, and I noticed that when I changed the camera position (zooming in or out) the entire tattoo would flicker and disappear, only to re-appear as I got closer or further away.  There was a small portion of it around an alpha-cut on my body (done with the hud) that remained invisible no matter what; as though the tattoo layer was cut away on more sections than the body underneath.

I am wearing no other layers, the tattoo is on blended mode (changing to masked is not an option for this tattoo, it looked horrible).  I also tried toggling between advanced lighting and not, with no difference.

Is there a fix for this? And would other people see it disappearing too?

Edited by Matty Luminos

Share this post


Link to post
Share on other sites

I don't use signature, but on maitreya I usually put tattoos on my underwear layer as it tends to disappear depending on the camera position when it's on tattoo layer for some reason.

  • Thanks 1

Share this post


Link to post
Share on other sites
4 hours ago, Matty Luminos said:

Is there a fix for this? And would other people see it disappearing too?

Try upping your Graphics setting  and nope ot won't affect how others percieve it if it was that.

Share this post


Link to post
Share on other sites
5 hours ago, Matty Luminos said:

Yesterday I wore a full-body tattoo on my Signature Geralt body, and I noticed that when I changed the camera position (zooming in or out) the entire tattoo would flicker and disappear, only to re-appear as I got closer or further away.  There was a small portion of it around an alpha-cut on my body (done with the hud) that remained invisible no matter what; as though the tattoo layer was cut away on more sections than the body underneath.

I am wearing no other layers, the tattoo is on blended mode (changing to masked is not an option for this tattoo, it looked horrible).  I also tried toggling between advanced lighting and not, with no difference.

Is there a fix for this? And would other people see it disappearing too?

A couple things to try: check to be sure you LOD is set no less than 2.0, also check altitude. At high altitude you can get prim shift that can affect how layers appear. So if you're at a high altitude, like in a skybox, check at ground level to see if it's still happening.

  • Thanks 1

Share this post


Link to post
Share on other sites

It's a long shot, but try putting the tattoo on the underwear layer, then setting both the tattoo and clothing layers to mask. Failing that, try a redelivery of the body and seeing if it works on a fresh copy. It is possible for a body to become permanently glitched due to an applier (I have one Omega skin applier that ruins the torso of my Slink body, making the underlying layer semi-transparent as soon as I apply any other skin after I wear it, so I keep one copy of the body in the skin folder with that Omega skin applier permanently on). If the issue happens on a fresh body, and with the mask/blend/mask options set on tattoo/underwear/clothing, then it's time to check other tattoos. Same problem? Time to check settings, GPU driver, etc.

  • Thanks 1

Share this post


Link to post
Share on other sites

The same is happening to me on Maitreya, it started couple of days ago. Only a part of tattoo is disappearing (on my belly), the other part (on the leg) is always visible. Matty, if anything from proposed solutions / workarounds works for you, please don't forget to mention it :)

Share this post


Link to post
Share on other sites

As other said, try a different layer on your body.

And ensure the following is checked:

In Firestorm, go to Preference->Graphics->Rendering

Alpha Mask Rendering:

Render alpha masks when "Advanced Lighting Model" is not enabled
Render alpha masks when "Advanced Lighting Model" is enabled

 

Share this post


Link to post
Share on other sites

all the options are OK. As I said, I started to notice this couple of days ago and I didn't change any options at that time or just before. This is also not the issue of high altitude because it happens also at ground level. I am trying now the easiest solution to check it on a fresh copy of the body. Maybe it was just a glitch as Skell suggested.

Share this post


Link to post
Share on other sites

Ok so here are a few more details.

  • It happens at ground level
  • It happens with other tattoos and with a fresh body.
  • It happens with LOD set at 4 (or 3, or 2, or 1)
  • It happens on "Ultra" graphics with absolutely everything set to maximum. It equally happens on the lowest possible settings as well.
  • It does not happen when the tattoo is worn on the underwear layer.
Quote

Alpha Mask Rendering:

Render alpha masks when "Advanced Lighting Model" is not enabled
Render alpha masks when "Advanced Lighting Model" is enabled

Both enabled.

I saw Skell's suggestion to wear it on the underwear layer in blended mode but set the other two (unused) layers to Masked. I couldn't test this because it worked fine on the underwear layer either way, but it did inspire me to try something else. Tattoo on tattoo layer, blended. Empty Underwear layer, and Clothing layer, both Masked. This works. 

Curiously, I've had this tattoo for at least a year and only just started having this problem, so I am wondering if it's somehow related to this new environment thing that the Lab is rolling out? Especially as @Kotelle also mentioned the same thing just starting to happen at the same time.

In any case, having the other layers set to Masked seems to work.

Thanks for the idea Skell!

  • Thanks 1

Share this post


Link to post
Share on other sites

Welcome. Glad it worked!

I'm curious about the fact that it's now only working on one layer (underwear) when it was fine on the tattoo layer before. Does the same issue happen on the clothing layer? Does it happen with other underlying skins? With any other bodies (if you have different ones to try it on)? If it is to do with EEP then it might be worth doing some testing to see if it requires further investigation by LL.

Share this post


Link to post
Share on other sites

I haven't tried it on the clothing layer or with any other skins yet. The only other body I have is Signature Gianni, not sure if that'll make any difference since they're from the same creator and presumably work the same way with the same scripts.

I will do some more experimenting this evening.

Can anyone identify me some sims that have EEP definitely enabled, and some which are definitely not enabled yet? I'd like to test it in each to see if it makes a difference.

I will also download the EEP  viewer and see if that makes a difference.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...