Jump to content
Prokofy Neva

New Annoyances

Recommended Posts

There are so many annoyances you have to bat away in Second Life.

There's that homing beacon that won't go away after you land -- it's supposed to guide you to the place you clicked on the map, although most of the time you don't need it. Yes, there is a trick to get rid of it -- open up the mini-map and click on it -- but that's not enough. You have to then right click, look for the menu on the right, and select "Stop Tracking". 

There's the edit menu that opens up over the very object you are trying to edit -- yes, it does that. Yes, you can push it to the left or right -- it's a tear sheet. But it keeps coming back. There's no way to get rid of it permanently. I know some don't believe this, but it's real, and documented.

There's the glaring object highlight that illuminates all the vertices in a mesh object, to the point that you finally have to turn it off. Yes, then you risk picking up an entire house tthen, when you merely when to pick up a flower off the floor. But at least you're preserving your eyesight.

Leave aside grey squares -- if you wait, they go away. But be sure not to tab out of the window and do something else while you wait -- it won't go away then.

Oh, and the fact that since the new installation, pictures won't save to the drive path that in fact does exist, saying it doesn't exist. Oh, well. There's always "print screen".

But now there are two new annoyances. One seems to be gone in the latest patch; another is back.

When you hover over an object, you get its name (all discussions here reference the regular SL viewer, which should be made to work; I don't use Firestorm and will never use it). Great, you need that object's name! But that's when you *right* click. Lately when you *left* click, you get the hover, too, which blocks the edit tab. You can't go into edit until you re-try several times to get past the stupid hover. This happens regardless of whether you first right-clicked to seek the object name; if you're editing it, chances are you know its name or don't care, because you're editing it. You have to bat it away multiple times. This seems gone now, but boy, what a pain.

Now, there's the "intrusive parcel border line" back again.

This is NOT the line you get if you check "show parcel borders". On group land, that would be aqua. On individually-owned land, that would be bright green.

THIS IS DIFFERENT, and obtains even when you have NOT checked "show parcel borders".

When you go to edit an object, the parcel border intrudes with a yellow-hued line, as you can see below.

Now why would any Linden think that is useful?

Obviously, if I'm in a house I've already placed between my borders, and I'm hanging a picture, I don't need to know the parcel borders. I have a rough sense of them anyway, even if I am just randomly putting around flowers or lawn furniture.

I can't think of a time when I would need the parcel borders to glow up in my face to "help" me place an object -- especially when they render in a foreshortened way. I can't see any way to get rid of this.

It's quite possible in fact this isn't a "boon" a Linden has conceived (although they do that and annoy the heck out of users) but simply a glitch -- but then it doesn't annoy Lindens enough to get them to remove it as it keeps coming back (or maybe never went away).

 

 

Pure Poison_005.png

Glitch.png

Share this post


Link to post
Share on other sites

Those beacons do not require anything more than clicking on the little arrow pointing you in their direction to remove - this has been true for every viewer, including the Linden Built ones predating 1.23 and 2.0+.

The edit menu issue you describe seems to only affect you - maybe a small handful of others users at most. This was pointed out to you before and you continue to act as if it is some wide-spread glitch. It isn't. Stop it.

You've conflated shutting off object highlighting with someone not paying attention when picking up/editing an object. Furthermore there is no need to keep the object highlighting off if you're not doing work on a dense mesh object (or on any object where you do not need to clearly see the surface textures).

The hover you are complaining about - that you say has gone away as well, for now - could be the hover popup that is caused by ... hovering over the object. To ensure that such is not the case, shut off Show Hover Tips. That's in your preferences, don't remember where - not like you'll read this or bother to actually listen if you did.

The land borders you are seeing are not "new"n however the behavior might be. Track down Show Property Lines under World and make certain it is turned off. If it is, then you're seeing improper behavior.

Mind that if it is indeed some new function or derivative of an existing function, it was put in more likely on request. Probably by a large enough group of users that were sick and tired of guesstimating their parcel sizes when moving objects around.

You may not like it, that's life.

  • Like 1

Share this post


Link to post
Share on other sites

1. The beacons do not require just mere clicking, as anyone who goes online in fact and doesn't stay on the forums will discover. Others report to me the same thing. You have to additionally check "stop track" or it remains, even when clicked.

2. The edit window blockage issue doesn't only affect me; that's not possible. I have an ordinary computer and regular SL viewer, so that means it affects others. They just don't edit, so they don't notice. That would include Lindens.

3. Um, if you shut off the highlighting, when you click on an object, even paying rapt attention, you might miss it and pick up something else. That's why highlight exists in the first place. Most objects in fact ARE mesh and many of them ARE dense, when you are decorating houses. The end.

4. No, the solution is not to "shut off" hover tips, as you need them. The solution is not to have them interview with "edit". If an action generated by right clicking does one thing, there is no need to have it recur from left-clicking.

5. Once again, as I explained, this is NOT NOT NOT related to "show property lines". Because -- wait for it! -- they are shut off (since they are annoying, too). This is an EXTRA highlighting of the parcel that is not in the regular list of lines (and you can tell them because -- as I pointed out -- it's a different colour). The end.

There is no large group of customers who want a line thrust in their face because they were tired of "guestimating". For one, most people aren't doing this. For two, something that renders foreshortened and disrupts the view isn't helpful. I suspect Whirly will be along in a minute to explain this is a glitch.

I see you are still residing at the center of the universe. Must be cold -- or hot -- there. Back on block you go.

 

Edited by Prokofy Neva
  • Haha 1

Share this post


Link to post
Share on other sites

I would suspect the yellow parcel border highlight during edit is an attempt to reduce accidental encroachment on neighboring parcels and thus decrease related abuse report activity.

Share this post


Link to post
Share on other sites
1 hour ago, Ardy Lay said:

I would suspect the yellow parcel border highlight during edit is an attempt to reduce accidental encroachment on neighboring parcels and thus decrease related abuse report activity.

Go and examine it inworld and you will discover that it does not serve that purpose. The line is so up close to your view -- that is what I mean by "foreshortened," you see -- that you can't possibly judge anything.

It's a total absurdity to think this is any kind of "help". And the Lindens don't need to reduce encroachment reports, because now, any object that does in fact encroach can be returned by the suffering neighbour. They introduced that reform ages ago.

Oh, except there are a few use cases where it doesn't work. Linden trees can seem impervious, for example, even when clearly encroaching. Or if a land has you banned or has "access only," apparently your ability to return is hampered. Or something. But generally it works, so no need for this "help".

  • Haha 1

Share this post


Link to post
Share on other sites

I agree that the yellow parcel highlight when editing objects is rather obnoxious and that is shows through everything causing confusion and annoyance when inside the house, hanging a picture, for example.  You may turn it off by setting RenderParcelSelection = FALSE in the viewer debug settings.  I looked through the UI and didn't see the parameter exposed elsewhere.

Share this post


Link to post
Share on other sites
13 minutes ago, Ardy Lay said:

I agree that the yellow parcel highlight when editing objects is rather obnoxious and that is shows through everything causing confusion and annoyance when inside the house, hanging a picture, for example.  You may turn it off by setting RenderParcelSelection = FALSE in the viewer debug settings.  I looked through the UI and didn't see the parameter exposed elsewhere.

Wow, thank you! That does the trick! 

But then that means the Lindens put it in deliberately, which is sheer, sheer MADNESS.

And how would the average person EVER figure out how to turn that off??? I know lots of things can be turned off in the Debug menu -- but you have to "just know" what the command is to look it up, like that "RenderVolume" thing that fixes up the view of sculpties (and they claim mesh, too, but not sure about that).

Of course, I expect each time there is a new update you will have to re-disable that. Just as I had to do with RenderVolume just now with a new patch.

Again, when the Lindens cook up "boons" like this, they are just abstract and theoretical, like microcredit schemes or one laptop per child, they don't really live in the world and see the results of their handiwork. That is, some of them may be inworld all day, every day, like Moles. But they are doing something different. I can't believe Moles would find it useful to have a yellow squiggly line that doesn't really indicate the parcel interrupt the view and annoy their building. Truly.

Once again, THANK YOU. And how did you ever find that?!

BTW, as if to prove to the Unbeliever that this is NOT related to "show property lines," even AFTER you make "RenderParcelSelection = FALSE," you can still turn on the OTHER "View property lines" just fine. It's a separate function, a different colour even.

Edited by Prokofy Neva
  • Haha 1

Share this post


Link to post
Share on other sites
2 minutes ago, Prokofy Neva said:

Once again, THANK YOU. And how did you ever find that?!

I sat and explored the UI and then debug settings while listening to NASA TV.

  • Like 1

Share this post


Link to post
Share on other sites
3 hours ago, Prokofy Neva said:

1. The beacons do not require just mere clicking, as anyone who goes online in fact and doesn't stay on the forums will discover. Others report to me the same thing. You have to additionally check "stop track" or it remains, even when clicked.

 

8 hours ago, Prokofy Neva said:

When you go to edit an object, the parcel border intrudes with a yellow-hued line, as you can see below.

64f5f4d112.png

3 hours ago, Prokofy Neva said:

2. The edit window blockage issue doesn't only affect me; that's not possible. I have an ordinary computer and regular SL viewer, so that means it affects others. They just don't edit, so they don't notice. That would include Lindens.

All of these were done on the latest Second Life Release 6.3.6.535003 (64bit), fresh install that I downloaded just to make this post.

Edited by Wulfie Reanimator
  • Like 1

Share this post


Link to post
Share on other sites
7 minutes ago, Wulfie Reanimator said:
All of these were done on the latest Second Life Release 6.3.6.535003 (64bit), fresh install that I downloaded just to make this post.

Oh, looks like the yellow parcel highlight is occluded by objects in that version.  That's what the design language for the feature called for.

Share this post


Link to post
Share on other sites
11 minutes ago, Wulfie Reanimator said:

 

64f5f4d112.png

All of these were done on the latest Second Life Release 6.3.6.535003 (64bit), fresh install that I downloaded just to make this post.

Well, I'm on the same viewer. And none of those behaviours are the case for me. Wouldn't it be nice to have JUST an outline of an object and not all those vertices. Believe me, I explored the menu and there isn't another option.

 

I'll screenshot it to prove to you in a bit.

 

Share this post


Link to post
Share on other sites
2 minutes ago, Prokofy Neva said:

I'll screenshot it to prove to you in a bit.

No need, I know what you're talking about as it's the case in every viewer besides Black Dragon. Yes it would be nice, I also often hide selection highlights in Firestorm.

That said, my screenshots/clips prove that the other issues are not the viewer's fault but something in your settings. I changed absolutely nothing from the defaults.

Edited by Wulfie Reanimator
  • Like 1

Share this post


Link to post
Share on other sites
17 minutes ago, Wulfie Reanimator said:

 

64f5f4d112.png

All of these were done on the latest Second Life Release 6.3.6.535003 (64bit), fresh install that I downloaded just to make this post.

So, first up, the mini map. Behold, three screen shots that illustrate:

1. Arriving at a sim (by the way, as a ghost for some time) with the annoying beam.

2. Open up the mini map, click -- beacon remains.

3. Right-click to get the menu and check "stop track" and walla, it goes away.

If clicking on it made it go away, Wulfie, it would go away. It doesn't. First two:

 

Feb 2020_008.png

Still There.png

  • Haha 1

Share this post


Link to post
Share on other sites
15 minutes ago, Wulfie Reanimator said:

No need, I know what you're talking about as it's the case in every viewer besides Black Dragon. Yes it would be nice, I also often hide selection highlights in Firestorm.

That said, my screenshots/clips prove that the other issues are not the viewer's fault but something in your settings. I changed absolutely nothing from the defaults.

What can I possibly change in my settings to make the beacon go away with ONE CLICK on the map instead of opening and hunting for STOP TRACK? I don't see what that could possibly be.

Share this post


Link to post
Share on other sites
4 minutes ago, Prokofy Neva said:

What can I possibly change in my settings to make the beacon go away with ONE CLICK on the map instead of opening and hunting for STOP TRACK? I don't see what that could possibly be.

You don't click on the map... Watch the video clip again. You click on the red arrow itself.

24dc509331.png <-- That one. Just left-click it. You won't even need to open the minimap.

Edited by Wulfie Reanimator
  • Like 1

Share this post


Link to post
Share on other sites

Next up, the way everything in the object is lit up, not just the outlines:

Note that on the menu, I have checked only "Show Selection OUTLINE"

Then I go into edit mode -- what do I get? Not an "outline" but a bath full of highlighted vertices.

 

 

Show Selection.png

See.png

  • Haha 1

Share this post


Link to post
Share on other sites
38 minutes ago, Wulfie Reanimator said:

You don't click on the map... Watch the video clip again. You click on the red arrow itself.

24dc509331.png <-- That one. Just left-click it. You won't even need to open the minimap.

That doesn't work either. In vain you will click everywhere on it, around it, etc.

Only "Stop Track" works --- and only for that log-in session, sadly.

Share this post


Link to post
Share on other sites
2 hours ago, Prokofy Neva said:

Next up, the way everything in the object is lit up, not just the outlines:

Note that on the menu, I have checked only "Show Selection OUTLINE"

Then I go into edit mode -- what do I get? Not an "outline" but a bath full of highlighted vertices.

 

 

Show Selection.png

See.png

This isn't due to the viewer, it's due to the object being mesh. The outlining feature does exactly the same thing it does on a prim object; it outlines each face/triangle. It's just that a mesh object has so many more of them. You'd get the same effect if you had a prim object that was made up of 4,000 prims (if anyone had the land capacity to rez such a thing). 

  • Like 1

Share this post


Link to post
Share on other sites
23 minutes ago, Matty Luminos said:

This isn't due to the viewer, it's due to the object being mesh. The outlining feature does exactly the same thing it does on a prim object; it outlines each face/triangle. It's just that a mesh object has so many more of them. You'd get the same effect if you had a prim object that was made up of 4,000 prims (if anyone had the land capacity to rez such a thing). 

Not quite right. Try selecting a sphere prim. Also, even prim cubes actually have 9 quads per side -- that's 18 triangles, 108 in total. Go ahead and rez a new cube and go into wireframe view. If you make the cube hollow, it'll jump to around 270 triangles. (The numbers as easy to check because you can export any fullperm object, even prims, out of SL and put them into Blender.)

61a252691c.png

Edited by Wulfie Reanimator
  • Like 1

Share this post


Link to post
Share on other sites
3 hours ago, Prokofy Neva said:

That doesn't work either. In vain you will click everywhere on it, around it, etc.

Only "Stop Track" works --- and only for that log-in session, sadly.

Or you can just walk through the beacon and it will automatically cancel it.

Orrrrrr you can click on the button on the World Map that has the 3/4 circle with the arrowhead.

In fact, I'm trying to figure out how you're getting beacons at all without opening the World Map to place them, as you can't place them with the Mini Map.

And yes, clicking on the red arrow also cancels them. For me, at least.

  • Like 1

Share this post


Link to post
Share on other sites
14 hours ago, Prokofy Neva said:

There's that homing beacon that won't go away after you land -- it's supposed to guide you to the place you clicked on the map, although most of the time you don't need it. Yes, there is a trick to get rid of it -- open up the mini-map and click on it -- but that's not enough. You have to then right click, look for the menu on the right, and select "Stop Tracking". 

Clicking the arrow has always made it disappear for me. I didn’t even know “stop tracking” existed until this thread.

  • Like 1

Share this post


Link to post
Share on other sites

LEFT clicking on the red arrow on your screen has always made the beacon go away - worked that way in 2010 and still does!  Of course you need an arrow, and need to actually click on the red arrow with your mouse pointer, not on the moon or something.

Obviously, LL has sent Prok a special Viewer version, as they detect who is downloading their update - that has disabled the click the red arrow feature - just for her!  

:)

Edited by Jaylinbridges
  • Haha 1

Share this post


Link to post
Share on other sites
On 2/10/2020 at 3:37 AM, Matty Luminos said:

This isn't due to the viewer, it's due to the object being mesh. The outlining feature does exactly the same thing it does on a prim object; it outlines each face/triangle. It's just that a mesh object has so many more of them. You'd get the same effect if you had a prim object that was made up of 4,000 prims (if anyone had the land capacity to rez such a thing). 

It didn't use to do that, however,

And now I finally understand why.

I noticed that everything seemed so "see-through," and the hover texts of objects normally only seen right nearby were showing clear through a house, so that you would see dozens of them. The walls seemed paper thin. Everything had a translucent quality that was annoying.

I discovered that when I downloaded the new viewer on a re-set machine, it automatically checked off "Advanced Lighting". Yes, I realize this is all the rage, with many creators making things for it and telling you to turn it on or things don't look good, etc. I actually don't like the "materials" look, as it always looks to me like everything is a lot of sweating, lead medieval goblets. So I turn it off, and even the shaders, too, as they lag. Not everyone has the graphics card for all these things.

So as soon as I turned off "Advanced Lighting," the excessively highlighted vertices went away. Now they are basically just around the edges. The excessive hover texts intruding went away. Perhaps I would find the annoying border indication would go away too but I already got rid of that in the debug menu.

So at least some of these annoyances are caused by "Advanced Lighting". 

Again, clicking on the arrow does nothing. Double clicking does nothing. You have to check "stop tracks".

 

  • Haha 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...