Jump to content

Deploys for the week of 2013-01-07


Maestro Linden
 Share

You are about to reply to a thread that has been inactive for 3208 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts


Maestro Linden wrote:


Ayesha Askham wrote:

Dora

I have seen the phenomenon that you refer to several times, and not confined to LeTigre and the last roll either.  Sometimes a sim shows you its contents, then suddenly it all vanishes, only to return some moments later.  It doesn't seem to matter if the sims are contiguous or  diagonally linked.  It is a most disconcerting occurence when the sim you have just or its objects briefly vanishes only to reappear a few seconds later!:smileysurprised:

Ah, it sounds like you're referring to BUG-141 "50 seconds after a region crossing, the previous region disappears.".  A fix for that bug is in the upcoming interest list update project.

What I see is not: "50 seconds after a region crossing, the previous region disappears."

but rather:

"A large number of objects right in front of you in the region you just left vanish immediately"

Anyway I've never seen this before the role out of Le Tigre yesterday

:smileysurprised::):smileyvery-happy:

Link to comment
Share on other sites

I want to show you what I see:
First a photo taken inside Nautilus - Suniaton running: Second Life RC LeTigre 13.01.04.268719

Studdi Beck_006.png

Then the same motive a few steps back over the region border to Nautilus - Hanno running: Second Life Server 12.12.18.268345

Out of Le Tigre_007.png

I hope I am not the only one who is missing something on the second photo::):smileyvery-happy:

Link to comment
Share on other sites

Dora and Maestro

What I have seen is most likely the bug to which you refer Maestro, but I have also seen objects in a recently left sim vanish, while the ground has remained rezzed too.  Now I think they preceded this week's RC roll, but I'm not prepared to testify to it!

One thought, Dora..are the objects that vanish plain prims and sculpts, or just sculpts? I will leave Mesh objects out of this, since they do as they please, it seems at the moment!

Link to comment
Share on other sites


Ayesha Askham wrote:

One thought, Dora..are the objects that vanish plain prims and sculpts, or just sculpts? I will leave Mesh objects out of this, since they do as they please, it seems at the moment!

The car and the surfboard are made of sculpties

The roof, sign, building and floor are plain prims

The curtain is flexi

The 'paintings' on the wall are all plain prims

The statue is mesh

The bluish chair in the middle of the room is made of sculpties

Some sculpties are rendered and some are not

Some ordinary prims are rendered and some are not

:smileysurprised::):smileyvery-happy:

 

Link to comment
Share on other sites

  • Lindens

Ah, I see what you mean, Dora.  When I leave your parcel and cross the region border to the south, some of the objects in your parcel 'disappear'.  Usually just disappear temporarily, but the set of objects which disappear and the duration of the disappearance varies a bit with each crossing.

When I crank up my draw distance to 256m, I see the problem - when the objects are 'missing', they are appearing in the wrong region.  For example, an object at 'Nautilus - Suniaton/25/8/23' is being rendered at the same coordinates in 'Nautilus - Sidobrim' when I cross into the latter region.  It's a little hard to see your objects since they're somewhat small, but if you make an object such as a 64m tall red 'pole', you can see it clearly in the horizon when it disappears from your parcel. I'm fairly certain this is MAINT-1341 (internal Jira), which is a viewer bug against the 3.4.1 development viewer (the issue does not appear in your sim when using the 'Second Life 3.3.4 (262321)' viewer).

Link to comment
Share on other sites


Maestro Linden wrote:


Marianne McCann wrote:

Hey Maestro! Happy New Year!

I am seeing some performance hits on Livingtree (Main Channel) since today's restart. Owner is filing all the relevant tickets as we speak, but mesh is not loading, friends lists not loading, etc. Not anything I would have expected, nor that I'm seeing elsewhere.

Okay, thanks for keeping us posted.  I wouldn't have generally expected that either - something on the sim host may be acting up.  Support tickets are probably the best route to take at this point.  Happy new year to you too!

Welcome - and yes, in retrospect, this was indeed not server stuff, but the network issues.

Link to comment
Share on other sites


Maestro Linden wrote:

Ah, I see what you mean, Dora.  When I leave your parcel and cross the region border to the south, some of the objects in your parcel 'disappear'.  Usually just disappear temporarily, but the set of objects which disappear and the duration of the disappearance varies a bit with each crossing.

When I crank up my draw distance to 256m, I see the problem - when the objects are 'missing', they are appearing in the wrong region.  For example, an object at 'Nautilus - Suniaton/25/8/23' is being rendered at the same coordinates in 'Nautilus - Sidobrim' when I cross into the latter region.  It's a little hard to see your objects since they're somewhat small, but if you make an object such as a 64m tall red 'pole', you can see it clearly in the horizon when it disappears from your parcel. I'm fairly certain this is MAINT-1341 (internal Jira), which is a viewer bug against the 3.4.1 development viewer (the issue does not appear in your sim when using the 'Second Life 3.3.4 (262321)' viewer).

 

Heya Maestro,

This behaviour is not new.  I am not sure if it is even a server bug because it does not appear to occur on Phoenix viewer, but does occur on Viewer 3 and Firestorm.

I believe this behaviour is what was reported at BUG-621

What seems to happen is is that when crossing to a neighbouring region, some of the objects from the previous region "follow you over" for a couple of seconds until you move your avatar or cam. The objects you primarily see are objects that occupy the same coordinates as you although in the previous region.

Is this a viewer or a server issue?

Further reports of this are on the Firestorm JIRA:

FIRE-8626 Sim build ghosting to next sim during border crossing

FIRE-7586 Some objects disappear from regions (become invisible) while user crossing boundary of region  (from the 13/Nov/12, 10:53 comment onwards)

 

 

Link to comment
Share on other sites

I'm not sure it's related, but back in June, Kito Flora submitted a bug affecting scripts that suggests some similar server-side confusion. It's not limited to the sim, however, because the viewer also gets shipped the incorrect coordinates: in a duplicate bug, I noted: "Crossing region borders in a physical vehicle, the parcel name and coordinates corresponding to the opposite side of the old region briefly appear in the address bar before arriving in the new region."

I've seen both the visual and script effects sporadically since at least September, as well as the spurious prims in the viewer, with no pattern I've been able to discern in the location, frequency, or duration of the effects.

Link to comment
Share on other sites


Whirly Fizzle wrote:

What seems to happen is is that when crossing to a neighbouring region, some of the objects from the previous region "follow you over" for a
couple of seconds
until you move your avatar or cam.

This is exactly what I see occasionally, objects from previous region follow over for few seconds.

When you approach the region border, you can clearly see the region ahead.  At crossing where the region handover is taking place, suddenly those objects - even part of the ground -  from the previous region is in front of you.  And then the stuff vanishes after few seconds and you can see clearly the region again where you are now after the border crossing has succesfully completed.

Seen this happening with: Firestorm 4.3.1 (31155)

Link to comment
Share on other sites

My apolgies for having only impressions rather than hard data, but I think this is similar to something I have been seeing more of over the last few weeks.   Sailing mainly in Blake and Sailors Clove sims.   Unexpcted objects appear briefly in front of the boat, just after a sim crossing (trees or fauna from the sea bed) when the boat is NOT flying or submarining.

Also seeing far more ghost objects.   The boat ahead appears as a static shipwreck.   Hover text shows the skipper aboard.   As you sail through it it vanishes.  And then reappeasrs sailing normally up ahead again.  (This is on current Firestorm but I hear its the case with other viewer).

I would say that sim border crashes are reduced (for the sake of clarity, this is a GOOD THING   I know people expect complaints here mostly    :)   ).   But the time delay over a sim crossing now seems much more variable, in a 30 minute race Im seeing 3 or 4 crossings over 3000 msec, as high as 8000 msec (typically the delay is 500 - 1200 msec -- 'delay' means diff between sl time and real time).

 

[edited for typos]

Link to comment
Share on other sites


JoyofRLC Acker wrote:

Also seeing far more ghost objects.   The boat ahead appears as a static shipwreck.   Hover text shows the skipper aboard.   As you sail through it it vanishes.  And then reappeasrs sailing normally up ahead again.  (This is on current Firestorm but I hear its the case with other viewer).

Yeah, the ghost objects too.  When I stay long time mooring in place, more and more ghost boats and planes will appear.  Looks like a kind of communication failure between servers and the viewer.

When I right click the ghost objects they will vanish.  It's as if this clicking awakens the communication again and updates the scene for the viewer.

Then there is still that annoying thing that parts of mesh boat sometimes vanish in region crossing.  Sometimes the boat will re-render back fully "by itself".  Sometimes it won't.  But again the boat will re-render fully when I right click on it.  WIth the annoying side effect that the boat freezes in place for moment before going on again.  Just yesterday I first time saw the same thing happening to sculpted boat.  Never seen that before for a sculpted boat.

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 3208 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...