Jump to content

Recommended Posts

I'm at a loss here to be honest, I couldn't find any information on this issue. So, I have a mesh shirt that I made in MD...It's pretty high poly so I wanted to reduce it using the "decimate" modifier but it doesn't do anything! Ripping my hair out over here. Does anyone have any suggestions?

For reference:

Blender: v2.75
Avastar: v1.71

Some other modifiers do work on the mesh, and it is not bound to an armature or anything.

Share this post


Link to post
Share on other sites
4 minutes ago, LightNina said:

I'm at a loss here to be honest, I couldn't find any information on this issue. So, I have a mesh shirt that I made in MD...It's pretty high poly so I wanted to reduce it using the "decimate" modifier but it doesn't do anything! Ripping my hair out over here. Does anyone have any suggestions?

For reference:

Blender: v2.75
Avastar: v1.71

Some other modifiers do work on the mesh, and it is not bound to an armature or anything.

There are different modes within decimate; did you try each of them?

image.png.9165d6ae0af5545682e2199595c2b06a.png

It might just be easier to cut the  complexity down in MD (been awhile so I have forgotten the name of the setting that makes things "smoother") and then export.  That would be pretty simple if you can't get decimate to work.  I use Blender 2.79 so can't speak to your version but it doesn't seem like that would be the issue. I don't think decimate has changed much over time. 

 

Share this post


Link to post
Share on other sites
9 minutes ago, Chic Aeon said:

There are different modes within decimate; did you try each of them?

image.png.9165d6ae0af5545682e2199595c2b06a.png

It might just be easier to cut the  complexity down in MD (been awhile so I have forgotten the name of the setting that makes things "smoother") and then export.  That would be pretty simple if you can't get decimate to work.  I use Blender 2.79 so can't speak to your version but it doesn't seem like that would be the issue. I don't think decimate has changed much over time. 

 

Yeah, I did try all of them and nothing happened x.x

Share this post


Link to post
Share on other sites

Ok these are like "did you try turning it off and on again" scenarios but I'm going there anyway because I've seen even experienced blender hands get the odd forehead-slapping moment from them...

 

"nothing happened" -

  • Did you add the modifier while in edit mode, try adjusting its parameters and see no difference? Even if you set modifiers to visible in edit mode if what you're watching is the edit cage and not the underlying model its sometimes hard to spot the model changing underneath it while the edit cage desn't, particularly if the starting point is insanely high-poly.
  • You did remember to set the parameters, right? Add a decimate modifier it defaults to "collapse" mode  and a ratio of 1.0. Until that ratio is reduced below 1.0 the decimate modifier will do nothing as it is already at its target. Similarly for unsubdivide mode it defaults to zero iterations, so no change - it has to iterate the process at least once to remove anything.

Share this post


Link to post
Share on other sites
1 minute ago, Da5id Weatherwax said:

Ok these are like "did you try turning it off and on again" scenarios but I'm going there anyway because I've seen even experienced blender hands get the odd forehead-slapping moment from them...

 

"nothing happened" -

  • Did you add the modifier while in edit mode, try adjusting its parameters and see no difference? Even if you set modifiers to visible in edit mode if what you're watching is the edit cage and not the underlying model its sometimes hard to spot the model changing underneath it while the edit cage desn't, particularly if the starting point is insanely high-poly.
  • You did remember to set the parameters, right? Add a decimate modifier it defaults to "collapse" mode  and a ratio of 1.0. Until that ratio is reduced below 1.0 the decimate modifier will do nothing as it is already at its target. Similarly for unsubdivide mode it defaults to zero iterations, so no change - it has to iterate the process at least once to remove anything.

Yeah, I applied the modifier in Object mode and Edit mode to see if there was any difference and none. And yes, I did set the parameters lol

  • Like 1

Share this post


Link to post
Share on other sites

Just to check......

When using the Decimate modifier you will not see any changes in Edit mode. Switch to Object mode then move the slider and you should see the face count dropping both in the modifier and in the 3D editor.

Edit mode :

decimate.gif.9898ec46f559a093027f63514762d9c7.gif

 

Object mode:

decimate2.gif.bf2e57d43f8ba95063f095b38dd9925e.gif

 

Share this post


Link to post
Share on other sites

Another possibility could be .............    this time not using a modifier,

In Edit mode,

          Mesh > Cleanup > Decimate Geometry. then you will find the options at the bottom of the tool panel.

decimate3.gif.8ac06ef3fd3c3658d9ad3127a7c54faa.gif

You will have to check to see how this effects UV mapping.

Blender version 2.79

Share this post


Link to post
Share on other sites

What version of MD are you using? If it’s a later version, you can decimate it before you export it to blender.

Share this post


Link to post
Share on other sites
5 hours ago, janetosilio said:

What version of MD are you using? If it’s a later version, you can decimate it before you export it to blender.

I used MD 8 I think :) 

Share this post


Link to post
Share on other sites
11 hours ago, Aquila Kytori said:

Another possibility could be .............    this time not using a modifier,

In Edit mode,

          Mesh > Cleanup > Decimate Geometry. then you will find the options at the bottom of the tool panel.

decimate3.gif.8ac06ef3fd3c3658d9ad3127a7c54faa.gif

You will have to check to see how this effects UV mapping.

Blender version 2.79

As I've mentioned before, i did use the applier in BOTH object and edit mode and it just wasn't working for some reason, but I haven't tried this method yet so I'll give it a whirl :)

Share this post


Link to post
Share on other sites
6 hours ago, LightNina said:

I used MD 8 I think :) 

Perfect. All you need to do is increase the particle distance of the fabric from the default setting. You’ll reduce the number of verts that way before you export to something more manageable.

Decimate does some really unpredictable things with MD mesh that you probably wouldn’t be happy with. Even if you convert the mesh to quads (which you should) it’ll never perfectly quadrangulate the mesh. So it’s better to play around with the particle distance in MD before you export. It’ll lose some shape because there’s less geometry, but that’s ok. It’s fixable.

Of course you’ll have to still retopo in Blender.

Share this post


Link to post
Share on other sites
28 minutes ago, janetosilio said:

Of course you’ll have to still retopo in Blender.

I think that is the process the OP is trying to avoid by using decimation, otherwise the imported model would work just fine for that purpose.

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, OptimoMaximo said:

I think that is the process the OP is trying to avoid by using decimation, otherwise the imported model would work just fine for that purpose.

I think she’s trying to reduce the polycount. The thing is when you decimate the mesh it’s going to deform a little bit. When it’s a MD mesh and you decimate in Blender, not only does it deform but you’re going to get some strange edges. It’s going to look pretty bad, then you’ll have to retopo anyway.

If you increase the particle distance in MD, you will reduce the polycount when you import into Blender. The added bonus is going to be nicer quads, but you’re going to have to pull on some vertices in Blender. Once you spent a few minutes doing that though, you can drop a subsurf( a single one should do) modifier on the object, not only would it be better quadded, but it would be much closer to what you originally had in MD.

So let’s not say retopo, let me rephrase that as pulling on some vertices and sorting out your edge flow. Increasing the particle distance will definitely lower the polycount and do a better job of decimating the mesh than simply decimating the mesh in blender though.

Share this post


Link to post
Share on other sites
5 hours ago, janetosilio said:

think she’s trying to reduce the polycount

Yes that was quite clear, the point is why reducing by decimation if the next step would be retopo? I could see that on a model over 2 or 3 million polygons, like a sculpt from zbrush that woukd choke your 3d app, but if this object comes from MD it most likely won't be that level of density. 

I'm not saying that fixing verts here and there on decimated object is wrong (well...), but the process is clearly aimed at avoiding proper retopo. 

6 hours ago, janetosilio said:

When it’s a MD mesh and you decimate in Blender, not only does it deform but you’re going to get some strange edges.

It happens on many different meshes that result from simulation and not only in Blender, rest assured. That's why proper retopo is the way to go, so you can control roundness and edgeflow where it matters the most. Decimating a properly retopoed object doesn't result in the same jaggy or odd results like a mesh generated from simulation does, which is a better use for decimation to optionally create LODS quickly. 

  • Like 2

Share this post


Link to post
Share on other sites
32 minutes ago, OptimoMaximo said:

Yes that was quite clear, the point is why reducing by decimation if the next step would be retopo? 

I think we’re having a minor misunderstanding. I already said I shouldn’t have said “retopo”. By taking the model in MD and increasing it from 20 (which is the default) to 30, 35 or 40. You’re going to end up with a simplified model when you export. Basically, by doing this you already decimated it, but it’s less messy. 

Share this post


Link to post
Share on other sites
Posted (edited)
15 hours ago, janetosilio said:

I think we’re having a minor misunderstanding. I already said I shouldn’t have said “retopo”.

Sorry, i missed that bit!

15 hours ago, janetosilio said:

By taking the model in MD and increasing it from 20 (which is the default) to 30, 35 or 40. You’re going to end up with a simplified model when you export. Basically, by doing this you already decimated it, but it’s less messy. 

I'm not grasping the reason for such a thing, sorry. What I do is the following:

  1. Make the clothing in MD at default particle distance (or even slightly lower)
  2. When the patterns are ok, decrease the particle distance by a lot (5 or even 3) and simulate again, adjustments for wrinkles and stuff (pull here and there, etc)
  3. Export the model
  4. Retopo in Maya over the exported model. Its polygon density isn't a problem until it gets to 3 million polygons, after that Maya starts stuttering a little for me (it chokes badly when i exceed the 4 million polygons), thing that doesn't happen with models from MD, those never get that high even with minimum particle distance 
  5. Texture bake high to low poly
  6. Trash the MD model altogether
  7. Work on the retopo'ed model textures with the extracted maps
  8. All other steps required to have a working model for SL (baking, rigging, etc)

So why exactly is the reason to get a decimated model if you're losing all details by reducing the clothing model for use in Blender, if doing so doesn't let you extract maps for it? Moreover, even though you may use both models and do an extraction from high poly to the "decimated" one as you describe, the topology is s**t to weight paint and to UV map (i can see the reason of doing the decimation in MD though, so you retain the same UVs, still the topology is so bad for rigging)

Edited by OptimoMaximo
typo
  • Like 2

Share this post


Link to post
Share on other sites
5 hours ago, OptimoMaximo said:

I'm not grasping the reason for such a thing, sorry. 

Because....that’s what the OP asked for?

5 hours ago, OptimoMaximo said:
  1. Retopo in Maya over the exported model. 

She’s not using Maya though. She asked how to decimate the model. I said before the reason you don’t want to use decimate in Blender is because it’s going to trash the model.

5 hours ago, OptimoMaximo said:

Make the clothing in MD at default particle distance

Wasn’t that why she wanted to decimate the model in the first place? Because it was too high poly? Instead of lowering the particle count ( which will raise the poly count), she can raise it. Raising it will lower the poly count, which is what the OP asked for. If it’s too low, that’s fine because after she adjusts the model, she can do a subsurf modifier and get the detail back and have a better model than she started out to boot.

  • Haha 1

Share this post


Link to post
Share on other sites
6 minutes ago, janetosilio said:

She’s not using Maya though. She asked how to decimate the model. I said before the reason you don’t want to use decimate in Blender is because it’s going to trash the model.

That is part of the list of steps I take in Maya. Substitute Maya with Blender and you get the same workflow, the software doesn't make a substantial change to the method. Blender Decimation or Maya Reduction will always break the shape somehow of course, perhaps Maya does a better job at saving the UVs though.

10 minutes ago, janetosilio said:

Wasn’t that why she wanted to decimate the model in the first place? Because it was too high poly?

I used Blender for a long time in the past, so i can't see how a MD model can be that high poly to choke Blender, which is the only reason to want it decimated. Even in such case, would it be wise to try a modifier or operator like that in any software while it's choking for the model that is supposed to undergo such a procedure?

13 minutes ago, janetosilio said:

Instead of lowering the particle count ( which will raise the poly count), she can raise it. Raising it will lower the poly count, which is what the OP asked for.

Exactly, lowering particle distance raises the poly count which makes the simulation create more details to be used in a proper retopo. Lowering it just annihilates those details, so what would the point be? Even if the OP isn't willing to retopo at all, the higher poly count model is still needed for maps extraction over to the model that was decimated by increasing particle distance. Which brings us back to:

23 minutes ago, janetosilio said:
6 hours ago, OptimoMaximo said:

I'm not grasping the reason for such a thing, sorry. 

Because....that’s what the OP asked for?

 

  • Like 1

Share this post


Link to post
Share on other sites
37 minutes ago, OptimoMaximo said:

stuff

We’re going in circles. The OP asked how to decimate a MD model...in Blender. Several people gave her a solution. I offered an alternative and a reason why that could be better that simply decimating it. That is all.

  • Haha 1

Share this post


Link to post
Share on other sites
On 6/19/2019 at 7:02 AM, janetosilio said:

Perfect. All you need to do is increase the particle distance of the fabric from the default setting. You’ll reduce the number of verts that way before you export to something more manageable.

Decimate does some really unpredictable things with MD mesh that you probably wouldn’t be happy with. Even if you convert the mesh to quads (which you should) it’ll never perfectly quadrangulate the mesh. So it’s better to play around with the particle distance in MD before you export. It’ll lose some shape because there’s less geometry, but that’s ok. It’s fixable. 

Of course you’ll have to still retopo in Blender.

Yeah that sounds reasonable. I believe there is an option to convert the mesh to quads in MD if I'm not mistaken. And also, I'm a newbie to mesh making (clothes specifically) so I don't really know how to retopo, details about it, ect.

Share this post


Link to post
Share on other sites
On 6/19/2019 at 9:01 AM, janetosilio said:

I think she’s trying to reduce the polycount. The thing is when you decimate the mesh it’s going to deform a little bit. When it’s a MD mesh and you decimate in Blender, not only does it deform but you’re going to get some strange edges. It’s going to look pretty bad, then you’ll have to retopo anyway.

If you increase the particle distance in MD, you will reduce the polycount when you import into Blender. The added bonus is going to be nicer quads, but you’re going to have to pull on some vertices in Blender. Once you spent a few minutes doing that though, you can drop a subsurf( a single one should do) modifier on the object, not only would it be better quadded, but it would be much closer to what you originally had in MD.

So let’s not say retopo, let me rephrase that as pulling on some vertices and sorting out your edge flow. Increasing the particle distance will definitely lower the polycount and do a better job of decimating the mesh than simply decimating the mesh in blender though. 

Thanks for the good advice! MD does give seams on the mesh, which isn't connected so It would pull apart if you tried to use specific modifiers. I would like to avoid having to completely redo such a good mesh by hand as others have pointed out xD (newbie) but I don't mind doing corrective work :)

Share this post


Link to post
Share on other sites
On 6/20/2019 at 7:56 AM, OptimoMaximo said:

I used Blender for a long time in the past, so i can't see how a MD model can be that high poly to choke Blender, which is the only reason to want it decimated. Even in such case, would it be wise to try a modifier or operator like that in any software while it's choking for the model that is supposed to undergo such a procedure?

The mesh doesn't choke up blender, that was never the problem. It's more about the fact that I will be bringing these clothes into SL. A general rule of thumb is that you should optimize your mesh as best as possible for games. The poly count would be an insanely high number for just one piece of clothes for SL, which is not what I want. So was aiming for good quality for a lower poly count, Decimate is often used on objects to achieve this to avoid retopoing the mesh, so I just assumed that it would work on clothes as well (according to others, it is not a good option, though).

 

On 6/20/2019 at 7:56 AM, OptimoMaximo said:

Exactly, lowering particle distance raises the poly count which makes the simulation create more details to be used in a proper retopo. Lowering it just annihilates those details, so what would the point be? Even if the OP isn't willing to retopo at all, the higher poly count model is still needed for maps extraction over to the model that was decimated by increasing particle distance. Which brings us back to:

The initial reason I had it high was in fact for more details. However, I do not quite understand exactly what you mean here as I am new to this whole process for clothes in SL.

Share this post


Link to post
Share on other sites
54 minutes ago, LightNina said:

Thanks for the good advice! MD does give seams on the mesh, which isn't connected so It would pull apart if you tried to use specific modifiers. I would like to avoid having to completely redo such a good mesh by hand as others have pointed out xD (newbie) but I don't mind doing corrective work :)

That might have to do with how you’re importing the mesh or....you might’ve not let the simulation do it’s thing so it didn’t completely join. It’s hard to say without images. Alt+M will join two vertices, that usually does the trick. 

If parts of your mesh are going crazy in the simulation...you’re definitely going to have an issue in Blender.

If you post a screenshot of what you’re working with, I can kind of duplicate it and help you a little better. I’m not going to promise a quick turnaround, because most of the time I post here I’m at work. But I’ll try to help where I can.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...