Jump to content
  • 0
Velk Kerang

Firestorm saves chat logs to different locations for each user.

Question

So Firestorm saves chat logs to different locations for each user. For example I am on Windows 7 and I been using the 32 bit version of the viewer and recently I had to reinstall it because for some weird reason my slplugin and some files vanished which I haven't worked out how and my logs with my wife on here is in my chat logs for my 64 bit viewer version of Firestorm, but I had a log with a friend not show up when I was working on my store alt and it created in my 32 bit chat log folder. I want to say if I recall correctly my wife had a similar issue from her main account only. My question is what causes this and can this easily be fixed in my settings by redoing the save location or is there something else I need to do? Thanks in advance. :)

Edited by Velk Kerang

Share this post


Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0
12 minutes ago, Velk Kerang said:

So Firestorm saves chat logs to different locations for each user. For example I am on Windows 7 and I been using the 32 bit version of the viewer and recently I had to reinstall it because for some weird reason my slplugin and some files vanished which I haven't worked out how and my logs with my wife on here is in my chat logs for my 64 bit viewer version of Firestorm, but I had a log with a friend not show up when I was working on my store alt and it created in my 32 bit chat log folder. I want to say if I recall correctly my wife had a similar issue from her main account only. My question is what causes this and can this easily be fixed in my settings by redoing the save location or is there something else I need to do? Thanks in advance. :)

duh... not only each user but even each account. Default settings are in your account subfolder in a firestorm folder in your user's home directory...

change that in preferences>network&files>directories to direct to the same place in both accounts ;)

 

Edited by Fionalein
  • Like 1

Share this post


Link to post
Share on other sites
  • 0
15 minutes ago, Velk Kerang said:

So Firestorm saves chat logs to different locations for each user. For example I am on Windows 7 and I been using the 32 bit version of the viewer and recently I had to reinstall it because for some weird reason my slplugin and some files vanished which I haven't worked out how and my logs with my wife on here is in my chat logs for my 64 bit viewer version of Firestorm, but I had a log with a friend not show up when I was working on my store alt and it created in my 32 bit chat log folder. I want to say if I recall correctly my wife had a similar issue from her main account only. My question is what causes this and can this easily be fixed in my settings by redoing the save location or is there something else I need to do? Thanks in advance. :)

32-bit programs and 64-bit programs often save things in different locations.

You can specify where you want logs saved, as Fionalein mentioned.  You can also copy logs from location to another - and even edit them to combine logs (do that while not logged on).

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0

Thanks, but I don't think ya'll get what I am asking. Let me try this again. Does FS bug out alot on where it saves this stuff? The crap installs where it wants to from what I see like it has a mind of it's own. lol I just reinstalled 32 bit as I said and it sent the logs for my main account to the 64 bit folder. Explain that one. lol My wife had hers at one point saving in two different locations without her even knowing it. Only reason I noticed a mix up on mine is because I pop links to myself sometimes between avatars when shopping on market. And to add fun *chimes in the music of sarcasm* in to the mix I just had a serious wtf moment and irritated because when I reset it rather then just switching the save location and resuming from there it backed up the entire folder so now I got my 32 bit duplicated with my 64 bit and doubles of every log and back ups. I am like seriously? lol Now I have to sort all this crap out. Like when did this become such a pain in the behind? lol :D

Share this post


Link to post
Share on other sites
  • 0

Hi Velk.

I have  never experienced anything like what you describe.  Is it possible that you have specified the SAME folder as the place for FS32 and FS64 to save backup settings?  In that case, maybe the two versions have gotten confused over which backup settings to use??

If you can get things sorted out by simply going into each viewer and specifying directories where various things are to be saved, then good.  It will be a pain, as you say, but at least you'll have everything straightened out. 

Or, if it's just too much trouble, and you don't mind losing your chat logs, you could do a complete wipe and a clean install of both viewers.  Since the problem seems to be something in the settings, in this case I would recommend not restoring your old settings from a backup.  Delete EVERYTHING, and then re-create all your settings and preferences, and back them up.  Be sure to use different locations to store the backups for the different viewers.

Maybe @Whirly Fizzle will chime in with a better suggestion; she is the Firestorm Goddess.

Share this post


Link to post
Share on other sites
  • 0

Viewers are very consistent. They are programmed to put stuff in Root Drive [C:\]Users\[Win_User_ID]\AppData\[Local or Roaming based on type of data]\[Viewer_name]\[various category folder names]\[identifying_filename]

The [ ] denote variable names. Some of these depend on how you setup Windows. Others depend on which viewer you are using and 32 and 64-bit viewers distinguish themselves by name. Later names in the path are determined by what is to be stored there, i.e., logs, settings, cache, etc.

Some viewers provide a user-choice for where some of these data collections can be kept. Users are unpredictable. But, the viewer is very predictable.

Share this post


Link to post
Share on other sites
  • 0
On 10/31/2018 at 2:49 PM, Velk Kerang said:

I had to reinstall it because for some weird reason my slplugin and some files vanished which I haven't worked out how

Probably your antivirus deleted them - it happens a lot unfortunately.

12 hours ago, Velk Kerang said:

I just reinstalled 32 bit as I said and it sent the logs for my main account to the 64 bit folder.

Did you backup your settings on the 64bit version & restore those settings into the 32bit version? Pretty sure this will cause the 32bit version to save chat logs to the location you had set  for the 64bit.

  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0

Sorry for the delayed reply everyone. I had to seriously take a step back from SL and my Firestorm issues. I needed some woosaa and chillax time I got so irritated messing with this. lol So in the Halloween spirit and in light of the new Halloween 2018 movie that just came out I had logged in to Steam and played some Dead By Daylight as Micheal Myers to release the rage!!!! lol I learned one thing as a survivor main is that I make a very crappy killer in that game so I don't feel at all to bad about that. lol :D

Ok so moving on. lol I didn't make a back up or anything and restore them like that. I sorta wish I had back the folders up to another drive before making the changes, but I do think I manage to work out what happened. I was using Firestorm 32 bit OS version for Open Sim. When I reinstalled because I generally keep a copy of the install for each version of FS I installed the FS 32 bit version for SL only. I did so in haste because I was irritated and that's really on me. Initially this was just to be a simple reinstall and replacement of missing files. So what happened was when I installed the SL only version I believed it changed my save logs location on me and for some reason it saved it to the 64 bit location.

At this point I went in to settings and changed it back and it automatically backed up any duplicate logs in that folder giving me doubles of almost every log file. The good news is this did not happen to any store/design alts so the damage is limited to only my main avatar. The bad news I mostly only ever log my main from a normal viewer because once I set the alt up I text viewer it from there if I need them for anything. lol So in short I don't think it's anything I did persay other then being stupid and rushing the process and installing the SL version of the 32 bit rather then the 32 bit OS version because that is ultimately when and were my problems with it began to start.

I pretty much at this stage have two choices. I can either leave it as it and say stuff it since I already set it back to the correct path. Then it's pretty much a question of if I can be bothered to individually fix all the log files back to the correct ones. I can tell you now I won't. lol That's just way to many files to deal with. lol Or I can go with option two and back up all logs to another drive and nuke everything and do one fresh clean install and start everything entirely over from scratch.

Now to address the specific questions I was asked so I didn't miss anything here.

 

On 11/2/2018 at 2:53 PM, Whirly Fizzle said:

Probably your antivirus deleted them - it happens a lot unfortunately.

Did you backup your settings on the 64bit version & restore those settings into the 32bit version? Pretty sure this will cause the 32bit version to save chat logs to the location you had set  for the 64bit.

No I did not. In fact since I started using 32 bit I seldom have ran my 64 bit version other then to test performance differences between the two viewers.

On 11/2/2018 at 9:16 AM, Lindal Kidd said:

I have  never experienced anything like what you describe.  Is it possible that you have specified the SAME folder as the place for FS32 and FS64 to save backup settings?  In that case, maybe the two versions have gotten confused over which backup settings to use??@Whirly Fizzle

I don't think so and the reason I say that is because until I had this issue I never had to manually go in and set the folder. They saved to their correct locations up until recently when I had to fix it back.

 

I think like Nalates mentioned with viewer being unpredictable the SL 32 bit version in comparison to the OSG version had in fact an unexpected and unpredicted response during the install process and instead of it setting itself to the log folders for the 32 bit version like it should have it defaulted to the folder and path for the 64 bit version of the viewer instead. So in short the moral of the story is I need to pay more attention and stop rushing when I am installing this stuff. lol :P

If you all have any other takes on this I would love to hear about them. Thank you all for the help with this. I appreciate it alot. Hope you all had a fun Halloween as well too. :)

Edited by Velk Kerang
  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0
6 hours ago, Love Zhaoying said:

I know chillax, gotta lookup woosaa!

Oh I gotta hook you up girlfriend. lol It can also be spelled Woosa or Woosah, but check this clip out and then you'll know what it means. lol :D

 

 

Also just an update for whatever reason the 32 bit viewer keeps setting off Avast now and the dullahan_host.exe has multiple processes of itself that stays running in the background even after I shut the viewer down. Now when I scan the Firestorm folder it scans clean, but when I run the viewer I get this message I'll post a photo of every time.

https://gyazo.com/3037af1ba92e4bd68b253e2458970ee2

The weird thing is it doesn't do that when I first installed it. It only started that today when I decided to run it finally after my break and time off from dealing with it. I am assuming Avast deleted my files the first time and just didn't tell me. Another weird thing is my 64 bit viewer seems to have no problems what so ever. lol Go figure. lol :D

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...