Jump to content
Sign in to follow this  
Myra Wildmist

How do I make V3 my default viewer for slurls?

Recommended Posts

I've started using different viewers, for a number of reasons. Firestorm has set itself up as the default viewer for slurls, though, and I'd like to change that back to V3, at least when I'm using V3. How do I do that? I'm on Vista, if that makes an difference.

Actually, I'd like to have whichever viewer I'm currently using always be the default viewer for slurls, but unlike web browsers, neither FS nor V3 seem to inform you if their viewer is not currently the default viewer of choice. I'm going to continue to use both, so this would be a nice feature to add.

Share this post


Link to post
Share on other sites

Actually its your internet browser (IE Explorer, Firefox, etc) that determines what viewer runs when you click on an SLurl.  In the case of Firefox, the selection is in the Options menu under Applications.  To set it up so that you get to choose between Firestrom or V3, you set the secondlife application to Always Ask and it will prompt you whenever you click an SLurl.

--Cinn

Share this post


Link to post
Share on other sites

Thank you, Cinnamon. Perfect! Found it and learned something about my browser. Thanks much.

 

(I'd give you a kudos, but I don't seem to have an option to do that.)

Share this post


Link to post
Share on other sites

Only specific sub-forums have kudos and all the "Answers".  General Discussions and Second Life Viewer does not have kudos..........and for good reason.  I'm sure Cinn appreciates the "thank you" more than any kudo.........she's that way.   :matte-motes-big-grin:

Share this post


Link to post
Share on other sites

I'm away from an SL-configured computer at present, but from memory the process is as follows.

In Windows 7:-

Start button > Control Panel > View by: Large/small Icons > Default Programs > Associate a file type or protocol with a program

Then scroll until you see 'Secondlife', select and 'Change Program...', then browse to the viewer executable you'd prefer.


Editted to add:-

I think there's also a specific setting for Chrome, which I believe to be in Settings > Privacy > Content Settings > Handlers > Manage Handlers button, and go from there. You may have to play around with this.


Bear in mind that using protocol extensions (i.e., secondlife://) for third-party applications can be considered a security hazard.

Some sources that may be more help:-

https://code.google.com/p/chromium/issues/detail?id=73710

http://productforums.google.com/d/msg/chrome/S9POECEIx70/eAL3cdZJl8cJ

Share this post


Link to post
Share on other sites

ok I use different viewers as well and I want my default viewer to be the Second Life viewer as well for chrome. BUt Im using a mac and I dont see any of these things on mac. I checked handlers and there was nothing at all about anything there. just one item in the list webcal. so obviously thats not it.

help! this is making me nuts. I know Ive set this before but the stupid chrome is using whatever last viewer was opened as its default for surls!

Share this post


Link to post
Share on other sites

http://www.rubicode.com/Software/RCDefaultApp/

Try it now.  If this link still doesn't work, go to rubicode.com (which will automatically take you to the software page).  On the right hand side of the page is a box titled Go To.  In that box click RCDefaultApp.

Update:  I still don't think this link works, but if you copy and paste it I believe it will.

Good luck!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...