Jump to content
Sascha Steampunk

Recently started crashing as soon as I log in

Recommended Posts

Around the first week of this month I started having horrible crashing fits out of nowhere. Before the crashing fits started I had been using the exact same viewer (Firestorm viewer version 6.0.2.56680) since its release but as I said I have been crashing non-stop within 5 minutes of logging in (sometimes within seconds of logging in) since the first week of April. I even tried downloading an older version of Firestorm to see if maybe there was some sort of bug with the more recent one that was suddenly causing me to have crashing fits. Nothing with my laptop has changed so that shouldn't be where the source of the problem is. Has anyone else ever had this problem and know of a way to fix it? Also I don't know whether or not this makes a difference but around the time the crashing fits started I had also downloaded the Alchemy viewer because I was having other problems with Firestorm (though I can't remember what exactly those particular issues were). I chose Alchemy since it's the first one listed here (I loved the blur effect it has but it isn't bento compatible so I deleted/uninstalled it and went back to using Firestorm). About a day or so after that is when I started having the crashing fits every single time I logged in. It got to the point where I just deleted/uninstalled Firestorm off my computer and decided to wait for the next update. Today though I figured I would try to install an older version of Firestorm and see if that fixed my problem but it hasn't so now after deleting/uninstalling the older version of Firestorm I am at a loss. I have no idea what to do or try next. I love Second Life and have been active in SL since February 2008. I also have RL friends and family on there that I am unable to interact with in RL because we live in different states. SL is the closest thing to physically interacting with them as I can get and being unable to log in without crashing has started taking a toll on my mental health since its a sort of escape from RL stress that I deal with 24/7 (I am a full-time caretaker for both my grandmother who has Ovarian Cancer, Diabetes, and is Anemic, and my dog who has Diabetes, Anemia, and Cushing's Disease). I have already had a mental break down that has lasted for 2 days from being unable to get away from the stress so any help or suggestions on how I can fix this crashing problem is very much welcomed and appreciated. It is the only social interaction (that is as close to physically spending time with others as I can get) that I have access to anymore since I have to stay within hearing range of my grandmother at all times in case she needs me.

Share this post


Link to post
Share on other sites
2 hours ago, Sascha Steampunk said:

I chose Alchemy since it's the first one listed here (I loved the blur effect it has but it isn't bento compatible so I deleted/uninstalled it and went back to using Firestorm).

Actually, Alchemy IS Bento compatible, you just used an older version. Get the one at : https://www.alchemyviewer.org/pages/downloads.html

 

Share this post


Link to post
Share on other sites

Are you having the same problem with the Linden Lab viewer?  Downloads | Second Life

What happens when the viewer "crashes"?
Does the viewer just poof to desktop & the crash reporter pops up, or do you get a message similar to "You have been disconnected from Second Life.  View IM/Quit"?

Do your alt accounts also crash soon after logging in?
A large flat inventory can cause a disconnect soon after logging in.  If your alts do not have the problem, you may need to get your inventory fixed.

Do you crash no matter what region you login to?

Share this post


Link to post
Share on other sites

@Whirly Fizzle I never use the Linden Lab viewer because it lacks everything that makes Firestorm amazing and way better than every other viewer I have tried (my personal preference is to avoid the Linden Labs viewer like the plague lol). When the viewer crashes though it freezes me in place to where I can only spin in a circle and then pops up the "you have been disconnected from Second Life. View IM or Quit". Sometimes it freezes my av up to where I can only spin in a circle but takes much longer to close out so I go and just close out the viewer myself. I have also tried logging in on an alt and it does the exact same thing as when I am on my main av and yes I crash no matter where I am in SL. Currently as I type this out my partner is on my av trying to clear my cache for me on her gaming laptop to see if maybe that helps at all so when she logs my av out I will try again to get online.

@Fritigern Gothly I might try using the Alchemy viewer again one day but for now I think I will avoid it since the last documented archive is from 2017.

Share this post


Link to post
Share on other sites
Posted (edited)

That .... is not a crash. That is a disconnect.

A crash is when the client (viewer) closes on its own. With or without an error message.

Further, your partner cannot clear your cache unless they are attempting to do so on your machine or you use that machine when you normally log in - otherwise there is nothing to clear.

Edited by Solar Legion

Share this post


Link to post
Share on other sites

@Sascha Steampunk:

All your "crashes" do indeed sound like disconnects and the culprit may be your modem or your ISP having a bad time.  It may help to turn off your modem and your computer for a good couple of minutes, ensuring thy are properly "off" at the mains.  Trying other viewers, since you have (you said) tried the Linden viewer, is unlikely to help.

@WhirlyFizzle's suggestion about inventory problems may be also contributing, though I'd be surprised if it affects all your Alts similarly.

@Solar Legion is correct about the cache issue...it cannot be done on another computer.

Share this post


Link to post
Share on other sites

Sounds like you are having a problem with your connection or router/modem.

If you haven't done so since the problem started, power off your router/cable modem for a couple of minutes & reboot your computer.  Often that is enough to fix transient connection issues.

Share this post


Link to post
Share on other sites
Posted (edited)

I hope things get better. 

 

I crashed so hard last night I lost all my settings, UI was busted and my backup was not current enough so I lost all log ins info. 

Edited by Sasy Scarborough

Share this post


Link to post
Share on other sites
On 4/25/2019 at 12:38 AM, Sascha Steampunk said:

(...)
When the viewer crashes though it freezes me in place to where I can only spin in a circle and then pops up the "you have been disconnected from Second Life. View IM or Quit".
(...)

That's a disconnect, and since you don't seem to be having a problem doing anything else online (are you?) I'm gonna roll a dice and say it's your DNS.

You can change your DNS by...
1) Look under your router to see the make and model on a sticker.
2) Search online on how to change the DNS for your specific router.
3) Pick a better DNS to replace the one your ISP (Internet Service Provider) has set up your router with by default.

While you are at it, and since you mentioned someone was trying to clear your cache on their machine... your should also lookup how to check every device connected to your router (see if you have any neighbors in there) and change your WiFi password.
You should do that monthly and use long ones as well as WPA2, for good measure.

After all that and if you use WiFi on your machine for SL, go to a store and buy an RJ45 cable, as big as you need.

Share this post


Link to post
Share on other sites

Thanks everyone for the suggestions and such on how to help me fix my problem. I actually managed to fix it a few days ago but since RL and a recent commission request have been keeping my attention I didnt have a chance to say anything in here about it. So thanks again to everyone! It was a big help and while I admit I was a bit stubborn about even considering it could be a problem with my router since its a brand new router I actually gave in and restarted it after trying to get on SL with a different laptop and had the same problem. After the router was restarted I havent had a problem with logging in and staying online. In fact the only time I crashed (actual no warning crash lmao) was last night while I was working on textures in photoshop on my desktop while I had SL open so I could test those textures on avatar dummies lol

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...