Jump to content
  • 1

Suddenly my camera view has changed.


Giadda Robbiani
 Share

You are about to reply to a thread that has been inactive for 281 days.

Please take a moment to consider if this thread is worth bumping.

Question

Yesterday, after repeated other problems with SL, my camera view angle has changed.

It used to be behind my avi so that I could see at least my upper torso when I walked and now it's higher over my head and needs adjusting everytime I get up and walk or if I want to get up close when talking to someone.  I've tried adjusting the camera in preferences... nothing brings it back where it was.    This happened on my other pc some time ago. What's going on?

Link to comment
Share on other sites

14 answers to this question

Recommended Posts

  • 2

If your camera is suddenly pointing straight up - or straight down - or some impossible direction, then try these:

  • Press escape a few times. Pressing escape will clear focus from any windows that have focus, and finally, will reset camera position.
  • Open the camera controls from the top menu → Avatar → Camera Controls, then click the X icon to reset your view to default.
  • Go to Advanced (Ctrl-Alt-D if the Advanced menu is not visible) → Show Debug Settings and enter “FocusOffsetRearView” 1) in the input field. Click “Reset to default” at the bottom.
  • Press Ctrl-9 - a few times even.
  • If that doesn't work, hold down Shift, then use the mouse wheel to change the camera angle.
http://wiki.phoenixviewer.com/doku.php?id=fs_camera#fnt__1'>1) This setting is the one that can also be changed by holding your shift key pressed, and using your scroll wheel on the mouse and therefore can easily be changed unintentionally
 
  • Like 2
  • Thanks 1
Link to comment
Share on other sites

  • 0
On 11/4/2011 at 5:13 AM, Charolotte Caxton said:

Not sure, I would try pressing CTRL 9. This resets the pan.

Then you could go to the debug settings. Advanced > Show Debug Settings > CameraOffsetRearveiw > Reset to Default

and FocusOffsetRearveiw > Reset to default. 

 

This didn't work, either. :(

Link to comment
Share on other sites

  • 0
On 11/4/2011 at 9:45 AM, Rolig Loon said:

If your camera is suddenly pointing straight up - or straight down - or some impossible direction, then try these:

  • Press escape a few times. Pressing escape will clear focus from any windows that have focus, and finally, will reset camera position.
  • Open the camera controls from the top menu → Avatar → Camera Controls, then click the X icon to reset your view to default.
  • Go to Advanced (Ctrl-Alt-D if the Advanced menu is not visible) → Show Debug Settings and enter “FocusOffsetRearView” 1) in the input field. Click “Reset to default” at the bottom.
  • Press Ctrl-9 - a few times even.
  • If that doesn't work, hold down Shift, then use the mouse wheel to change the camera angle.
http://wiki.phoenixviewer.com/doku.php?id=fs_camera#fnt__1'>1) This setting is the one that can also be changed by holding your shift key pressed, and using your scroll wheel on the mouse and therefore can easily be changed unintentionally
 

Woooot - Control + 9 did it!  Thank  you!

  • Thanks 1
Link to comment
Share on other sites

  • 0

This is very simple but doesn't seem to be documented anywhere.  Hold down control and use your mouse wheel to change the angle between the view cam and your avatar.  Hold down the shift and control keys and use your mouse wheel to change the angle of your camera.  For example, click on your avatar.  Hit escape until your view stops changing.  Hold down the control key and roll toward you with your mouse wheel.  You'll see your camera get higher but continue to point at your avatar.

Next example prepare the same way, click on your avatar, hit escape as many times.  Hold down control and shift while you roll the mouse wheel toward you.  You will see your camera rise above your avatar.

If these examples and descriptions don't make sense then keep it simple: try holding down control or control and shift while you roll your mouse wheel forward and back.  See what happens.

  • Like 1
Link to comment
Share on other sites

  • 0
On 4/29/2022 at 2:40 PM, Rendorz said:

This had something to do with the TMP Legacy HUD for me. Open HUD and lick the little camera icon at the bottom left.

THANK YOU!  While trying to figure out how to BoM my avatar, I must have click that button by mistake.  Luckily, a warning popped up that the Legacy body was preventing my camera angles.  Your message was a exactly what I needed to fix my camera views!

Link to comment
Share on other sites

  • 0
On 4/29/2022 at 10:40 PM, Rendorz said:

This had something to do with the TMP Legacy HUD for me. Open HUD and lick the little camera icon at the bottom left.

Yes!!! I tried everything and usually the first thing I look at is the debug settings but adjusting those was making no difference, but then I remembered I was wearing my Legacy body tonight and BOOM - your answer was the fix I needed! Thank you!!!!

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 281 days.

Please take a moment to consider if this thread is worth bumping.

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...