Jump to content
  • 0
MoldyLocks

Firestorm misrendering textures - blurry, out of focus textures

Question

I am having an ongoing issue with textures going in and out of focus (see pics).  It happens constantly and I can't even take a picture without random textures going from sharp to fuzzy to sharp again several times a minute.  Other textures will stay fine but certain others just get crazy, no matter the distance of the camera to the object. See pics.  I have the latest Firestorm; I have ALM off, I have object LOD at 2; I don't have Malewarebytes as others suggested in similar post. I've reduced scripts on my land, I've cleared my cache, I've gotten rid of heavily scripted items, I rebake textures with no real results.  This only happens:

1.  In a particular building I have which has many objects; on the same land in other houses, I don't have this problem. 

2.  Related or not, I'm not sure, but my FPS goes down to the 20s when I'm on my land.  I go to my Linden house, and it shoots up to the 50s. I have a really good graphics card, btw altho its two years old.

Any help would be gratefully appreciated.  Thanks.  

da8ab3979700a00945a004be9df86c27.jpg

6995317a3921dc41c2b1613169b8382d.jpg

284465a375f8592e2eb0ea74c9529223.jpg

Share this post


Link to post
Share on other sites

8 answers to this question

Recommended Posts

  • 2
1 hour ago, MoldyLocks said:

I am having an ongoing issue with textures going in and out of focus (see pics).  It happens constantly and I can't even take a picture without random textures going from sharp to fuzzy to sharp again several times a minute.  Other textures will stay fine but certain others just get crazy, no matter the distance of the camera to the object. See pics.  I have the latest Firestorm; I have ALM off, I have object LOD at 2;

Your viewer has a set amount of Video Ram (VRAM) available to it. When the viewer starts up, it asks to be given an amount of VRAM and it uses it to store textures and meshes while they are being rendered.

Textures are decoded as a series of images at ever increasing resolutions. So they start off small and fuzzy and slowly load more information and get sharper. The textures are decoded into your computers VRAM.

The viewer has used up all of the VRAM it's been allocated yet there are still textures to be loaded. 

So .. It throws out a texture and loads one of the pending ones  .. and oh look, there's a missing texture, so lets throw one out and ..  

Bottom line, you have too much stuff in one place and your computer can't keep it all in the amount of VRAM it's been allocated at the same time.

 

There is unlikely to be a singular object at fault, it's death by a thousand cuts.

 

Depending on your graphics card you may be able to get the viewer to ask to use more.

In Firestorm, open prefs and search for "memory", you will see a slider called "Viewer Texture Memory Buffer (MB)", if you can increase this slider .. it should solve the problem.

 

If you can't do this, then you can do other things to reduce the amount of demand on what VRAM you do have. Reduce draw distance. Remove all HUDS. Simplify your avatar by removing attachments. Pick stuff up, especially stuff that is very detailed.

 

 

1 hour ago, MoldyLocks said:

I don't have Malewarebytes as others suggested in similar post.

Nothing to do with this issue.

1 hour ago, MoldyLocks said:

I've reduced scripts on my land,

Scripts have nothing to do with this issue at all.

1 hour ago, MoldyLocks said:

I've cleared my cache,

Don't do this. All this does is force the viewer to redownload textures. This just makes it worse.

1 hour ago, MoldyLocks said:

I've gotten rid of heavily scripted items, I rebake textures with no real results.  This only happens:

Again, scripts are not a problem here. Rebake textures just forces the viewer to reload .. it might be handy if  you need a specific thing to be 'in focus' but its not going to solve the overall problem.

 

 

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
  • 1

What you are seeing is called texture thrashing. Your video card loads and renders a texture. As it moves from item to item to render it runs out of texture memory, discards a texture to load another. The item who's texture is discarded goes fuzzy. Then as the card makes the rounds of refreshing rendered things textures get reloaded and others discarded so you see the clear, blurry, clear cycles sweeping across the scene.

I wrote Second Life Texture Thrashing in 2013. Viewers have gotten better since then. But, we still have the problem. You can Google for Texture Thrashing and blurry textures. Look at the more recent results for fixes.

Two things contribute to the majority of the problem in SL. HUD's and some viewer settings. Avoid wearing HUDs that use a lot of textures when you aren't using them. Firestorm warns you about HUDs using lots of textures. My Slink body HUD and GAEG head HUD both use a large number of textures. Once I finish using them, I detach them. The other is the tiny images of people's profile pictures used in chat. I understand work has been done to mitigate the tiny image issues. But, I turned them off long ago and have never turned them back on.

You can lower the ACI limit setting to reduce the number of avatars you render.

Reducing Draw Distance reduces the texture load too.

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
  • 1
6 hours ago, Nalates Urriah said:

Reducing Draw Distance reduces the texture load too.

I don't know if this applies or not, but along with draw at 128, I've also lowered LOD to 2, I think (50% on the slider bar) and that seems to help A LOT. So, is that true or is it placebo effect for me? It also tends to show the crap-quality mesh junk and that's good for a laugh when a Titanic-size yacht turns into rubble at 30 meters Hahahaha

  • Like 1

Share this post


Link to post
Share on other sites
  • 1
1 hour ago, Alyona Su said:

I don't know if this applies or not, but along with draw at 128, I've also lowered LOD to 2, I think (50% on the slider bar) and that seems to help A LOT. So, is that true or is it placebo effect for me? It also tends to show the crap-quality mesh junk and that's good for a laugh when a Titanic-size yacht turns into rubble at 30 meters Hahahaha

I doubt LoD settings affect texture thrashing. Every mesh has 4 models, detailed to most simplified. But, all models have to use the same textures otherwise the viewer complains and refuses the upload. When people use the viewer's built-in LoD generator to make a model  for LoD they often get errors because the generator removed all the parts using a specific texture. 

However, testing and use often reveal aspects of SL rendering even the Lindens have thought of...

  • Like 1

Share this post


Link to post
Share on other sites
  • 0
9 hours ago, Nalates Urriah said:

What you are seeing is called texture thrashing. Your video card loads and renders a texture. As it moves from item to item to render it runs out of texture memory, discards a texture to load another. The item who's texture is discarded goes fuzzy. Then as the card makes the rounds of refreshing rendered things textures get reloaded and others discarded so you see the clear, blurry, clear cycles sweeping across the scene.

I wrote Second Life Texture Thrashing in 2013. Viewers have gotten better since then. But, we still have the problem. You can Google for Texture Thrashing and blurry textures. Look at the more recent results for fixes.

Two things contribute to the majority of the problem in SL. HUD's and some viewer settings. Avoid wearing HUDs that use a lot of textures when you aren't using them. Firestorm warns you about HUDs using lots of textures. My Slink body HUD and GAEG head HUD both use a large number of textures. Once I finish using them, I detach them. The other is the tiny images of people's profile pictures used in chat. I understand work has been done to mitigate the tiny image issues. But, I turned them off long ago and have never turned them back on.

You can lower the ACI limit setting to reduce the number of avatars you render.

Reducing Draw Distance reduces the texture load too.

thanks.  how do i lower the ACI limit setting please?

Share this post


Link to post
Share on other sites
  • 0
9 hours ago, CoffeeDujour said:

Your viewer has a set amount of Video Ram (VRAM) available to it. When the viewer starts up, it asks to be given an amount of VRAM and it uses it to store textures and meshes while they are being rendered.

Textures are decoded as a series of images at ever increasing resolutions. So they start off small and fuzzy and slowly load more information and get sharper. The textures are decoded into your computers VRAM.

The viewer has used up all of the VRAM it's been allocated yet there are still textures to be loaded. 

So .. It throws out a texture and loads one of the pending ones  .. and oh look, there's a missing texture, so lets throw one out and ..  

Bottom line, you have too much stuff in one place and your computer can't keep it all in the amount of VRAM it's been allocated at the same time.

 

There is unlikely to be a singular object at fault, it's death by a thousand cuts.

 

Depending on your graphics card you may be able to get the viewer to ask to use more.

In Firestorm, open prefs and search for "memory", you will see a slider called "Viewer Texture Memory Buffer (MB)", if you can increase this slider .. it should solve the problem.

 

If you can't do this, then you can do other things to reduce the amount of demand on what VRAM you do have. Reduce draw distance. Remove all HUDS. Simplify your avatar by removing attachments. Pick stuff up, especially stuff that is very detailed.

 

 

Nothing to do with this issue.

Scripts have nothing to do with this issue at all.

Don't do this. All this does is force the viewer to redownload textures. This just makes it worse.

Again, scripts are not a problem here. Rebake textures just forces the viewer to reload .. it might be handy if  you need a specific thing to be 'in focus' but its not going to solve the overall problem.

 

 

The viewer texture memory buffer trick greatly improved things; still not perfect but way better.  Thanks very much.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)

Open the graphics preferences in Firestorm and under the rendering tab, look for this option shown and enable it, restart the viewer. This will pretty much eliminate most blurring and thrashing that I have seen in FS.

 

Capture.PNG.cee169190271c4c58af27fb7133fd8ab.PNG

Edited by NonVoxSedVotum
  • Thanks 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...