Jump to content
  • 0
Baraka Boucher

Mac Wireless Mouse

Question

With the last update of SL, my mouse is again having the problem of trying to use "object view," and when trying to look around or behind an object, the screen just goes crazy...round and round...and I had this problem once before and it has to be a glitch in the SL software....I checked my mouse operation, no problem there.  SL is the only place it does this.....

Share this post


Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0
3 hours ago, Baraka Boucher said:

With the last update of SL, my mouse is again having the problem of trying to use "object view," and when trying to look around or behind an object, the screen just goes crazy...round and round...and I had this problem once before and it has to be a glitch in the SL software....I checked my mouse operation, no problem there.  SL is the only place it does this.....

It's not your mouse. Though check your viewer settings to make sure that your view is not obstructed by objects. I forget the exact name of that setting (and could be slightly different name depending on the chosen viewer) - but it's that setting where if your back is to a wall then your camera "bounces" off the wall. You want to turn that off.

I'm not saying this is the problem and solution, I'm just suggesting you check it, just in case it is. :)

Share this post


Link to post
Share on other sites
  • 0

I got the same issue as yours. I am using an iMac with a wired mouse.

With the latest version of SL, I got an issue when I use "Object View" with Alt+Left hold click to zoom in and out, then my screen is spinning.

I used to have this problem before around last month (older version). I tried deleting and downloading the viewer again. That time the issue has been solved.

But this time, I tried the same way but still cannot fix it. I tried restart my Mac, delete the viewer and download again but the issue still happens.

I think I should contact LL or submit a ticket to get support.

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)
5 hours ago, CrystalDoll Lemon said:

I got the same issue as yours. I am using an iMac with a wired mouse.

With the latest version of SL, I got an issue when I use "Object View" with Alt+Left hold click to zoom in and out, then my screen is spinning.

I used to have this problem before around last month (older version). I tried deleting and downloading the viewer again. That time the issue has been solved.

But this time, I tried the same way but still cannot fix it. I tried restart my Mac, delete the viewer and download again but the issue still happens.

I think I should contact LL or submit a ticket to get support.

Have either of you tried a different viewer? I just tried it on my Office Mac and I'm not reproducing what you describe. The three up-to-date viewers I know that have macOS versions are: Official Second Life Viewer (a.k.a. LL viewer), Firestorm, and Kokua. Catznip dev has expressed interest in doing a macOS version but haven't heard anything otherwise. So before you begin thinking it's your hardware, you should try the LL Viewer and Kokua viewer first (or if you are using one of those, then swap it for Firestorm). If the same is happening on *all three* then (and only then) should you begin to consider a hardware issue - in any case, it is NOT (cannot be) a server or LL issue. The problem is happening at your machine..

Edited by Alyona Su

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)

It's been many years since I had this issue. As I recall (and there's good reason to distrust my memory), it was fixed by deleting the viewer's Saved Application State. I think a mangled camera setting was persisting across log-ins. Alyona's recommendation of testing on a second viewer is a good one. I always keep two viewers up-to-date on my Mac so I can determine whether a problem is systemic or viewer related. If another viewer works, your camera problem is related to the wayward viewer.

The viewer's saved application state is stored in the Library folder. To access that, hold down the Option key while selecting the "Go" menu from the Finder menu bar. Select "Library" to get the Library window, then scroll down to the "Saved Application State" folder and look for something related to the particular viewer you're using. Toss that folder in the trash and relaunch the viewer.

If an alternate viewer works and trashing the wayward viewer's saved application state doesn't fix the camera, you may have to try a clean re-install

Edited by Madelaine McMasters

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)

This is a known bug on Mac with the latest Linden Lab viewer release.
There's a bug report filed here: BUG-226660 - [Mac] Camera spins and pulls back when using alt+zoom
This bug was caused by adding HiDPI support for Mac.

Here is the Linden workaround given in the comments:
 

Quote

To anyone dealing with this issue we have a work around. I'm hesitant to share it though because this change will persist through regular updates and it's easy to forget you've done it.
Only full uninstall and reinstall would reset this particular setting. (Or you can delete/rename your /user_settings/ folder)

Please write this down on a sticky note somewhere near your computer so you don't forget, how, or that you have, made this change. Note: that using this work around will result in some other subtle changes like your mouse cursor hopping back to the center of the screen after each alt+left click and being limited to 180 degrees panning in mouse-look.

Caveats done, here is a quick fix:
Open the menu Advanced > Show Debug settings, then type in DisableMouseWarp and then set the value to True.

That's it, the spinning alt+zoom issue should be fixed on either primary or secondary monitor.

Please keep watching future release notes and when you see this issue marked as fixed you should be good to set DisableMouseWarp back to False.

Additionally, please let me know if this does not resolve the issue.

Thanks!

 

Edited by Whirly Fizzle
  • Like 3

Share this post


Link to post
Share on other sites
  • 0
10 minutes ago, Baraka Boucher said:

Thank you Whirly Fizzle, it solved the problem. I appreciate your help.

 

So.... testing on a different viewer would have helped you spot this *viewer bug*  much sooner, then. Good to know. And happy to see you've got your issue resolved.

Oh, and to answer your question where you said: "Alyona Su, then how do you explain the fact that it wasn't happening before the last update?" - precisely because it didn't happen *before* the update is why the viewer update itself is the suspect.

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...