Jump to content
  • 0

Poseballs No Longer Work - Other Scripts Do


Denny Souther
 Share

You are about to reply to a thread that has been inactive for 1860 days.

Please take a moment to consider if this thread is worth bumping.

Question

Greetings,  I've exhausted Google and myself trying to troubleshoot and fix this.
Windows 10 Professional Creator's Edition (Version 1703) 64-bit
Intel i7-6700K @ 4GHz
64GB RAM
Viewers Tried: Second Life 5.0.5 (default), Second Life 5.0.6 (release), Firestorm 64-bit 5.0.1

Menu shows, and poseballs rez when menu item is chosen
When I move the cursor over the poseballs, the cursor doesn't change meaning it's not clickable
When I left-click poseball, nothing happens
When I right-click poseball the 'touch' menu item is grayed out
I own the land and all objects
I've checked to make sure scripts can run on land
All other scripts work fine: lights, doors, etc.
I've tried this on several different pieces of furniture inside and outside the house - sex and 'cuddle'
Turned off AO
Clicked 'Stop Animating Me' menu item
Set poseball permissions to 'All'
Attached image is with above settings
Read any other info I could find
I own furniture
There are probably other things I've tried that I've forgotten

I'm confounded by this. I hope someone out there has experienced this or has an idea I haven't listed above.

Thanks!
 

SecondLifeViewer_2017-05-30_23-58-42.png

Link to comment
Share on other sites

5 answers to this question

Recommended Posts

  • 0
38 minutes ago, Denny Souther said:

Is there anybody OUT there...

Several people, I imagine.  These days, though, it's harder and harder to find furniture with poseballs -- it's old technology -- so our collective memory is fading. :)

You seem to have thought of several possibilities, leaving only a few for anyone else to suggest. 

Have you maybe blocked (muted) the furniture?  That's a distressingly easy mistake to make.  You go to close the dialog box and hit "Block", which is right next to "Ignore", neither of which sounds like a friendly exit.  The only way to recover is to open your blocked list and UNblock the item again.

It's also possible that the items were scripted by an amateur who has forgotten to return the script to state default or to reopen a listener after a previous use.  (The fact that the cursor doesn't change to indicate that it's clickable suggests that the script is either not running or stalled in a state with no touch_start  event, so this is a reasonable possibility.)  If so, you would have to reset the script manually each time, if you have mod perms and have that option.

I'm sure there are other possibilities, but those leap to mind first.

Link to comment
Share on other sites

  • 0

If this was scripted so that the poseball "pie menu" options are set by the poseball itself after rezzing, perhaps something is gone wrong and the scripts are not running in the poseball themselves?  I wonder...is it possible that if you check the poseball contents you will see that the scripts are not "set to running"? 

The next steps are ???, it's not like replacing those poseballs back into the object after setting scripts to running will fix them..necessarily.

I hope you have multiple copies of the object in case you decide to experiment.

Link to comment
Share on other sites

  • 0

I don't quite understand the significance of your saying "I've tried this on several different pieces of furniture inside and outside the house - sex and 'cuddle'."  Do you mean that none of your furniture that uses poseballs works, or that the rest of you furniture is working normally?   

I'm interested to know the history to this.   Scripts don't suddenly stop working for no reason.   Have the pose balls ever worked?   If they did, do you remember anything significant happening just before they broke?   Have you tried taking the chair to another location and seeing if it works there?

Whatever the history, though, and assuming it's just this chair that's broken, it looks to me as if there may be a problem with the poseball object inside the chair.   Assuming the animation system used is MLPV, and if the chair is modifiable, try deleting the poseball object inside it and replacing it with one from another MLPV item that you know is working (the poseball is just a dumb relay that broadcasts the uuid of the avatar sitting on it to the animation engine inside the chair, so you can safely swap them round).

 

Edited by Innula Zenovka
Link to comment
Share on other sites

  • 0

There's an older poseball system that "remembers" who last used a poseball so it doesn't have to ask your permission, but there are situations where it still thinks you granted permission for it to animate you when the permission has actually been revoked ("Stop Animating Me" can do this) and not only doesn't ask you for permission, it doesn't bother to check if you even need to be asked.

You might be able to make it ask you for permissions by jumping on the poseball you normally don't use and then back on your usual one; other than that, you'll need to reset the scripts.

  • Like 1
Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 1860 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...