Jump to content
  • 0
Sign in to follow this  
Luc Starsider

media_plugin_webkit error in latest viewer (2.6) on OS X

Question

Recommended Posts

  • 0

That pesky plugin is still failing in 2.6? *sigh* Looks like we will be getting  lots more posts like this in that case, I was hoping they had finally fixed that thing.

Since this problem started a few months back, there have been a variety of fixes that work for some people & then the next wave come along that they don`t work for and more workarounds pop up for them and so on.

A lot of the fixes I know of are for Windows which won`t be much help to a Mac user.

Try this lot, see if it helps:

There are reports that recent Quicktime updates actually cause problems, giving plugin errors. If this is the case for you, then remove Quicktime entirely from your system, then reinstall it.

Check the SLPlugin file

  • Relog and open Search
  • Go to your computer processes and look for “slplugin.exe”
    • For Windows users, go to Task Manager → Processes Tab
    • For Mac users, go to Activity Monitor → My Processes (usually by default, but you can check top right drop down)
    • For Linux users, go to Command Terminal, and type “ps aux”
    • You may see four instances of the slplugin running (that is normal behavior)
    • If you do not see any instances of slplugin running, that is the cause of media failing
  • If slplugin is not running, disable all firewall and virus protection (including anti-virus software and windows or other operating system firewalls)
  • Relog and attempt video playback again
  • If it works, you will need stop your firewall/virus protection from blocking the slplugin file by granting it appropriate permissions in your firewall/virus protection software
  • If all of the above does not resolve the issue, you can try downloading the latest Snowglobe viewer and replacing your slplugin file with the one from Snowglobe.

Clearing QuickTime Cache

If you have issues watching movies (as opposed to YouTube videos) it might help to clear your QuickTime cache:

  • Open the QuickTime player
  • Click on Edit → Preferences → QuickTime Preferences → Advanced Tab → Empty cache
  • Click on Apply then Ok and reboot your computer
  • Like 2

Share this post


Link to post
Share on other sites
  • 0

Thanks Irene!

I had a quick look, but didn't see anything obvious in that post to help. I'll check again. Problem is, I have all Apple updates installed, but I will have a look at Flash.

 

- Luc -

Share this post


Link to post
Share on other sites
  • 0

Yes, it's baaaaacccck! I've noticed lately that I have a couple of issues it seems nobody else has, so let's hope this is another one :) If so, at least ther won't be to many questions about it.

 

Funny, really. I'm not sure what's broken here since everything works fine as long as I'm logged in on the Mac as the same user I installed the viewer with. Great info in your post, though, that I'll have a look at later today.

 

Oh. Come to think of it; it might be related to read/write/execute rights to the SL app on different OS accounts. I'll have to check this after work. I'll post back what I find.

 

Thanks for the info!

 

- Luc -

 

 

Share this post


Link to post
Share on other sites
  • 0

Yay glad its fixed, if you do manage to deliberately reproduce it & fix it again, absolutely post back what the fix is, because it will definately be needed for other Mac users, we never seem to know good fixes for them hehe :)

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Problem gone!!!!! It's definitely an access right issue with one or more file in the program. I have not had time to research what file(s) actually have the issue, so I changed the rights on all files in the program package. That solved the error message, and everything works fine.

The procedure is this: Open the folder where the program is located. Right click the viewer icon and select 'Show package content'. Right click the 'Content' folder in the window that opened in the previous step and choose 'Get Info'. Expand the 'Sharing & Permission' section, click the padlock icon in the lower right hand corner and provide a username and password. Change the 'privilege' for the group (normally there will be only one) in the access list to 'Read & Write'. Then press the gear icon below the list and select 'Apply to enclosed items'. Close the info panel and the package content window and everything should be ok.

YAY!

- Luc -

  • Like 2

Share this post


Link to post
Share on other sites
  • 0

That is something to look into. I'm not sure what to look for, actually. I found media_plugin_webkit in the program package along with SLPlugin.app and a couple of other files that seemed related, but I didn't think look in any of the library folders for anything. If you know what files I should look for, let me know and I'll have a poke around to see what I find. BTW. Did you upgrade the viewer? Without this issue?

 

I'm wondering, though, if it could be an issue - installed in the wrong library - for a couple of reasons. When I changed the access rights on the content of the program it works, and I installed this version the same way as always - dropping it on the Application folder - which has worked well before. With this method, if something was installed in a library folder it would have to be put there on first startup, right? I had the exact same issue on two macs. Don't know if that is relevant, but at least it is consistent which is, in a way, an improvement :)

 

- Luc -

Share this post


Link to post
Share on other sites
  • 0

Sorry for the late response, I'm just catching up. Did you ever resolve this? I did a quick search and I don't have any media plugin anywhere except in the SL app bundle, as you noted. I upgraded to 2.6 without any issues, just by dropping the new version into my Applications folder. Are you using the system Applications folder? I always put everything there, my user Apps folder is empty.

 

It doesn't make any sense that you'd get that error on login to the system, unless there is some native app that needs it which launches on login or startup. Do you have the viewer set to start up automatically?

Share this post


Link to post
Share on other sites
  • 0

No problem, Paladin. Any reply is a good reply, early, late or on time. It does not matter :)

 

It seems, though, as if I didn't manage to explain the problem properly. I didn't get the error message on system startup. No, no. I got the message on logging in to SL with the viewer, but on a system account that was not the one used when installing the viewer.

 

Yes, problem was solved after I changed access rights to the viewer app bundle. But you may be on to something still; I do install the viewer in the user app folder before moving it to the system app folder. Thing is; I've done this since the first viewer I ever installed, and the only one that has given me problems is v. 2.6. No issues before OR after. I installed 2.6.1 and 2.6.3 beta without issues. The problem with 2.6 was also only a problem for any other user than the one installing the app.

 

It's all working fine now, so I'm happy :)

 

- Luc -

Share this post


Link to post
Share on other sites
  • 0

Heh. I spoke a bit to soon. Get the error message on launch of 2.6.1. Not a problem now that I know how to fix it. But 2.6.3 installed - by doing it the same way as always - without any error messages on launch.

 

- Luc -

Share this post


Link to post
Share on other sites
  • 0

In a way, I'm glad you aren't getting errors on OS startup, that'd make me nervous. :) I'm thinking the change isn't with the viewer version but with your OS version. The user Applications folder only gives permissions for that one user, and moving an app out to the system Applications folder should theoretically change permissions to "all users". I wonder if the latest OS updates aren't doing that any more.

I've never installed to the user Apps folder, I always go right to the system one, so I don't have much experience with it. But permissions aren't generally assigned by apps, the OS does that. The only way an app can assume particular permissions, as far as I know, is if it is installed with an installer. If you drag from a .dmg, the OS assigns perms.

 

Edit: Oh wait, you say 2.6.3 acts correctly? In that case, I have no idea. Can't be the OS then.

Share this post


Link to post
Share on other sites
  • 0

Yupp, I'm also glad the error is not coming from the OS. I *think* the OS is assigning permissions correctly, but I haven't made any extensive checks on that.

I've sort of given up trying to pin down the cause of this. As long as people only use SL on the same OS account they install the viewer on, everything's fine. If not, the issue is easily fixed. And since the latest beta is working right anyway, it may simply be a temporary issue anyway and nothing to make more fuss about.

 

If it comes back in the 2.6.3 release version, I might do some more checks. It also seems I'm the only one who has the problem :( which makes it difficult to get a jira looked at if I make one.

 

Ah, well, such is (S)Life...

 

- Luc -

Share this post


Link to post
Share on other sites
  • 0

OK, so I had a go at installing the 2.6.1 on another Mac I have, where I haven't installed a viewer for a while. This time, I installed it into the system application folder straight away. It did not make any difference; On the OS account where I installed the viewer - no error message when I launch the viewer. On any other OS account I get the error message on launch.

 

I'm wondering if I am the only one experiencing this issue, so I thought I could ask you if you could try to launch the viewer while logged in as a different user on one of your Mac? The message should appear before the login screen pops up in the viewer. I'd appreciate it if you could give it a go and comment back what the result is.

 

- Luc -

Share this post


Link to post
Share on other sites
  • 0

I had the same problem but found that Flip4Mac was the culprit.  It makes some sense since it impacts how Quicktime deals with certain Microsoft related files.  I had unrelated issues in the past.  I moved the two plugins from the internet input file to an inactive file and the problem has gone away for now.  The other suggested solutions here didn't work for me.

 

Starbuck Hax

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

@ Starbuck thankyou for posting your fix, there seems to be an increase in this error lately and sending people to this thread they now have a choice of fixes to try. Kudos to you. :)

Share this post


Link to post
Share on other sites
  • 0

I FOUND THE SOLUTION TO THE MEDIA PLUGIN ERROR:

 

I changed "User Account Control Settings" in Windows 7 to "Never Notify" about changes made to my computer.

 

After I changed this setting to Never Notify, I could then enter into viewer 2 witthout getting the media plugin webkit error. I could open and use search perfectly and view profiles :)

 

There is a JIRA on this and a lot of people trying to figure out why they are getting this error message, so something to seriously look into.

 

The way I found it was when i was in the phoenix viewer, the user account control would pop up and ask me if this program had permission every time i opened search or a profile.... so annoyed with that, I turned the user account control settings down,.. this didn't help so i turned them off. ... and... ummmm that fixed it and also v2 media pluging webit error message never appeared again :))) ..

 

Hope this helps..... Kimber Carter.

 

Share this post


Link to post
Share on other sites
  • 0

That's great, Kimber! I mean; great you found a solution that works, but not so much that you had to turn off UAC in window. Don't know if I would advice that on a permanent basis. You're right, though, that plenty of people have the same issue, and this will be something to tell them to try.

Perhaps you can add your comment - with details of what you did - to the jira so it can be taken in to account if/when it's needed?

 

- Luc -

Share this post


Link to post
Share on other sites
  • 0

I've tried everything and I keep getting the webkit plugin error.....Can someone help me. It does not seem to matter what viewer I use, the search function will not work. I am using a mac.

 

Thanks

AthenaDreamer

Share this post


Link to post
Share on other sites
  • 0

Hi Athena. Did you try what we talked about in the comments here: http://community.secondlife.com/t5/Technical/media-plugin-webkit-error-in-latest-viewer-2-6-on-OS-X/qaq-p/785235/comment-id/4712 and also some of the things suggested in the other replies?

 

Also, it may be better if you ask this in a question of your own. This one is marked as answered, and only the people who answered will be notified of your followup question. Not many others will notice a new reply. In the question you ask, it might be a good idea to say also which Mac you use and what version of the operating system you use. :)

Share this post


Link to post
Share on other sites
  • 0

LINUX USERS

 

I just had this error on my LINUX Fedora 18 machines both the x86 and 64 bit  machines...


Fixed it by installing pangox

yum install pangox-compat.i686 -y

 

 

  • Like 2

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...