Jump to content
  • 0
Darius Sharkfin

My AO is not working (cannot turn it on/off) and any attached HUDs are not responding

Question

  • 0

Hi Darius,

AOs and HUDs are scripted objects. If you attach them while in a no-script area, they're not going to work. Make sure you're in a place that allows scripting before attaching such things.

  • Like 2

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0

Hi Darius,

AOs and HUDs are scripted objects. If you attach them while in a no-script area, they're not going to work. Make sure you're in a place that allows scripting before attaching such things.

  • Like 2

Share this post


Link to post
Share on other sites
  • 0

Sometimes the scripts get corrupted. RIght click and choose edit. Go to the contents tab and see if you can reset scripts. If you can, do so. If that doesn't work, see if you can get a redelivery of your AO. If not, you'll need to contact your AO creator and get help from them.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Mess up my AO while playing around with face+hand mesh AO. Old AO became unresponsive. TPed to a sandbox allowing scripts and AO magically worked :)

Edited by Howard Rich

Share this post


Link to post
Share on other sites
  • 0

I had that once with a ZHAO it just stopped working, nothing could get it working again... I got a redelivery and am fine again (now I keep a working backup copy in stahs, just to be save)

Share this post


Link to post
Share on other sites
  • 0
2 hours ago, Howard Rich said:

Mess up my AO while playing around with face+hand mesh AO. Old AO became unresponsive. TPed to a sandbox allowing scripts and AO magically worked

Normally, scripts won't run in an area that is designated as a "no-script" area. Because certain scripted objects like AOs and vehicles need to keep running, though, LSL has a built-in loophole.  A scripter includes a small bit of code that takes control of your keyboard's arrow keys and, without changing the way that they operate, tells your viewer and the servers that the script is exempt from the "no-scripts" rule.  That works as long as the scripted object was set to running before you entered the no-script area.  However, if you are in the no-script area and decide to reset the script -- often done automatically if you rez or attach a scripted object -- it won't run.  As you discovered, all you have to do to get it working is leave the area.  No real magic.  9_9

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...