Reply
Honored Resident
Chaoss
Posts: 5

Second Life standard viewer, click upload = crash

If i try to upload ANYTHING, the viewer crashes before the upload dialog box appears, whether it's an image or a mesh crash everytime at that place and I can't build, I've waited a week to see it fixes itself but it hasn't, tried reinstalling SL, removing app settings and cache manually all the usual bollocks any ideas?

Honored Resident
Chaoss
Posts: 5

Re: Second Life standard viewer, click upload = crash

Reply to Chaoss - view message

I've done an exordinate amount of research on the web regarding this issue and still can't come up with a fix. please someone give us a hand

Nyll Bergbahn
Posts: 6,922
Registered: ‎09-18-2009

Re: Second Life standard viewer, click upload = crash

Reply to Chaoss - view message

I don't know why this is happening but you could try saving an image in a different format, say TGA, in a graphics image program such as Photoshop, Gimp,Graphics Converter etc and then see if the image will now upload. I assume your images are 1024 x 1024 or smaller and not some massive size which perhaps is causing an issue, as SL will cut them to 1024 x 1024 anyway.

Caine: I seek not to know the answers, but to understand the questions.
Honored Resident
Chaoss
Posts: 5

Re: Second Life standard viewer, click upload = crash

Reply to Nyll Bergbahn - view message

I made a Jira, image format change isn't going to help as this happens with ANY open file dialog. Here is my issue in extensive detail and the Jira link

 

https://jira.secondlife.com/browse/VWR-28843

 

OK I will start by saying I do not have a prebuilt system, and the Windows 7 installation does not have any bundled software. The only security software I am running is Anti-Malwarebytes... which I have temporarily disabled until this issue is resolved.

The issue is upon trying to either upload any asset or bulk the viewer crashes BEFORE the open dialog appears, this also happens on trying to save a snapshot to the hard disk, and trying to change the cache location in Preferences. I have tried the following (in this order)

  • Clear cache
  • Uninstall/reinstall Second Life using the uninstaller and reinstalling the latest standard viewer
  • Uninstalling Second Life and using an older version
  • Uninstalling Second Life and using Firestorm (same issue occurred)
  • Uninstalling Firestorm and clearing out my %Appdata% folder of ALL SecondLife stuff and reinstalling the latest version of Second Life
  • Uninstalling Second Life, removing everything from my msconfig startup, removing all entries tagged with "SecondLife" and "Second Life" from the registry and restarting. then reinstalling Second Life
  • Disabling ALL 3rd party services and keeping only Microsoft services enabled from msconfig dialog, and removing ALL startup entries
  • Installed Development, Beta and Second Life viewers and tried multiple versions of each
  • Kick the computer, bang the keyboard and swear loudly, restart Second Life and try again
  • Disable Aero and ran as administrator
  • Uninstalled and reinstalled as administrator
  • Change UAC settings
  • Disable and enable various Windows features
  • Re-enable all previously disabled services and settings, uninstall Second Life, Restart, Reinstall Second Life
  • Install more ram as second life uses a lot (I tried installing an extra 4GB in one of the free RAM slots despite the fact I already have 32GB, this obviously didn't help, I tried with just the 4GB stick in and this didn't help either)
    *Update graphics card drivers (they are the latest beta version from www.nvidia.com - the standard ones do not work with my GTX 560ti 448 core 2GB)
  • Updated other various system drivers and checked for windows updates

After spending the best part of a day, none of this has fixed the issue. After extensive Google searching, research and asking in various Second Life related groups I have come to the conclusion that Second Life has some sort of showstopper bug (Second Life is a content creation platform, i cannot create content. therefor this bug is classified as a showstopper) in the code, and has a compatibility issue with my hardware and/or software choice. I have paid work in Second Life which at this time I am unable to complete, having this issue resolved is VERY important to me.

The following is a list of everything installed on my machine

Adobe Photoshop CS6
Autodesk 3ds Max 2013 x64
SecondLifeViewer (remove only)
Mozilla Firefox 12.0 (x86 en-US)
Microsoft SkyDrive
Malwarebytes Anti-Malware version 1.61.0.1400
FileZilla Client 3.5.3
StarCraft II
Microsoft Visual C++ 2005 Redistriburable
XNResourceEditor 3.0.0.1
Steam
Quake
The Binding of Isaac
Notepad++
Skype 5.9
Adobe Flash Player 11 Plugin 64-bit
Java(TM) 6 Update 31
VTFEdit 1.2.5
Dropbox
Garry's Mod
Garry's Mod 13 Beta
iTunes
Unity
Paint.net 3.5.10
Media Player Classic - Home Cinema
CCleaner
Speccy

My NVidia driver version is: GeForce 301.24 Driver BETA - 301.24 9.4.2012

Hardware accoring to Speccy:

Operating System
MS Windows 7 Ultimate 64-bit SP1
CPU
Intel Core i3/i5/i7 @ 3.20GHz 35 °C
Sandy Bridge-E/EP 32nm Technology
RAM
31.9 GB DDR3 @ 800MHz (9-9-9-24)
Motherboard
Gigabyte Technology Co., Ltd. X79-UD5 (SOCKET 0) 28 °C
Graphics
Standard Monitor (2880x1800@60Hz)
DELL 2007FP (1600x1200@60Hz)
NVIDIA GeForce GTX 560 Ti
Hard Drives
234GB ATA Corsair Force 3 SCSI Disk Device (SATA)
59GB ATA Corsair Force 3 SCSI Disk Device (SATA)
977GB FUJITSU MARVELL Raid VD 0 SCSI Disk Device (SATA)
Optical Drives
PIONEER BD-RW BDR-206 SCSI CdRom Device
Audio
Realtek High Definition Audio

janitor1
Posts: 11
Topics: 3
Registered: ‎06-18-2011

Re: Second Life standard viewer, click upload = crash

Reply to Chaoss - view message

ive been getting the same problems and after looking at the jira it seems to be the mircosoft sky drive software breaking the upload somehow...

 

uninstall the sky drive software and try the upload again

Honored Resident
Chaoss
Posts: 5

Re: Second Life standard viewer, click upload = crash

Reply to janitor1 - view message

Yeh I was meant to update here as well, that is my jira entry and yeh MS SkyDrive is the cause

Resident
Dragontat Rugani
Posts: 1

Re: Second Life standard viewer, click upload = crash

Reply to Chaoss - view message

i dont even have to try to upload for some reason everytime i build something in sl now i crash straight to desktop no warning nothing just poof.i have the current sl viewer all updated i even tryed phenoix viewer current updates doesnt seem to matter i start building and sl just crashes. started about a week ago.im trying to get out new items for customers and i cant till i figure this out. any help would be nice..

Resident
Nicc Benelli
Posts: 1

Re: Second Life standard viewer, click upload = crash

Reply to Chaoss - view message

Janitor1, thanks for your hint about sky drive!

I've been trying for days, now upload finally works again :matte-motes-smitten:

Honored Resident
VauhnHelfer
Posts: 13

Re: Second Life standard viewer, click upload = crash

Reply to Chaoss - view message

I had the very same problem and worked for 2 days on it, crashed every time I tried to save a photo or upload a texture. Finally I saw this post and uninstalled my Microsoft Skydrive. I was able to begin uploading textures again right away! Thanks for the help!

“I contend that we are both atheists. I just believe in one fewer god than you do. When you understand why you dismiss all the other possible gods, you will understand why I dismiss yours.” – Stephen Roberts
Honored Resident
Avariado
Posts: 32

Re: Second Life standard viewer, click upload = crash

Reply to Chaoss - view message

It worked with me too.

So anyone knows why is this happening?

I'd like to keep using Sky Drive software...