Jump to content
Sign in to follow this  
Rumancekk

my avatar is constantly breaking for my friends, but not me

Recommended Posts

their viewer is fine but every time I tp from somewhere, to the land that I live on, my avatar breaks for my friends but not me. My body pokes out of all my clothes. It isn't where i'm T-posing and holding my clothes on my t-posed arm but like my alpha is just failing for everything and it doesn't work until I log back in. I'm assuming it is not for anywhere else because no one ever says anything or my friends don't say anything when we go somewhere else. I'm getting very tired of having to log back in and out everytime I go somewhere. I can't fix it myself because my alphas are all activated and I look fine.

 

Why is this happening? How can I fix this? I'm using LeLutka and Belleza Jake both with BoM. It seems like this is a recent  development but we all have up to date viewers.

This is a pic they took of me a while back, and this is what it has been doing,

]y6s2gxF7RR2Po2F4W5TKgA.png?width=303&hei

 

vs what i actually look like

a8db3c18a5e970eb3aede3c745405014.png

Share this post


Link to post
Share on other sites

I'm guessing that what is actually happening is your mesh body is failing to rez for others, and what they are seeing is the classic body underneath (which has no alpha as you are using BoM).

This usually results from wearing more than one attachment on the same attachment point, and I would bet real money that you have your mesh body plus at least one more thing on the same point. You can detach your body and re-attach it to any alternative point; being rigged it will still automatically sit in the right position.

You can temporarily resolve it by doing "refresh attachments" from the avatar health menu, at least in Firestorm. But switching the body to an alternative attachment point is a permanent fix.

Share this post


Link to post
Share on other sites

Those seeing you are not having BoM problems. If they were they would be seeing yellow, red, and blue body parts.

The problem is on their side. For whatever reason they are being slow downloading all your parts. You "might" be contributing to that. If your alpha layers are made from 1024 size images rather than 512s they could be slow downloading and cause the problem they see.

They should be able to click on your avatar and do a Texture Refresh to get you rezzed.

If the region is lagging, it may be slow telling them about your avatar parts.If they are losing network packets or have a weak connection to SL (not the same as having a good Internet connection) this can happen.

When people first come into a region there is a lot to download. Even if the material is cached it has to be checked for updates. So, if you do eventually rez you know it is their system catching up.

 

Share this post


Link to post
Share on other sites
1 hour ago, Nendolt said:

It's probably because their viewer is outdated. And your using BoM

as i said before, their veiwers are up to date and this fixes when i restart. i'd imagine if their veiwers werne't up to date, it would be like this all the time, wouldn't it?

Share this post


Link to post
Share on other sites
6 minutes ago, Nalates Urriah said:

Those seeing you are not having BoM problems. If they were they would be seeing yellow, red, and blue body parts.

The problem is on their side. For whatever reason they are being slow downloading all your parts. You "might" be contributing to that. If your alpha layers are made from 1024 size images rather than 512s they could be slow downloading and cause the problem they see.

They should be able to click on your avatar and do a Texture Refresh to get you rezzed.

If the region is lagging, it may be slow telling them about your avatar parts.If they are losing network packets or have a weak connection to SL (not the same as having a good Internet connection) this can happen.

When people first come into a region there is a lot to download. Even if the material is cached it has to be checked for updates. So, if you do eventually rez you know it is their system catching up.

 

why does it fix itself after i relog tho for everyone?

Share this post


Link to post
Share on other sites
17 minutes ago, Rumancekk said:

why does it fix itself after i relog tho for everyone?

What happens is they are getting all the other stuff in the region downloaded while you are away. When you come back the region has less info it has to hand out to these people so all your stuff is more likely to make it through and they see you render. Since you are new in the region the server sends out a new set of information on how you look. Often a second try fixes everything.

You can check your connection to SL (Shift-Alt-1). Look for packet loss. If you are having problems, you may be getting out of sync with the region server. That usually only affects what you see. Everyone else gets your appearance from the SL system. Your current outfit folder is on the SL servers. That is what the region server sends to others. So, if your appearance is messed up the places where it can go wrong are mostly between those observing and the SL system. But... if your connection confuses the data SL has it can propagate to everyone else, but that is rare.

The fix is in pushing the SL system into updating your appearance. A relog does that.

If you press Ctrl-Shift-Alt-U (Show Updates) You will see colored dots rising form avatars and things in SL that the region is updating. When you TP or login you see a rush of dots. If these updates are lost (they travel the UDP side of the network without error correction) then whatever the viewer is supposed to update per that dot never updates. When you come in after a relog the server sends a new set of updates for your avatar. Everyone updates and things tend to work out.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...