Jump to content
  • 0
Thomas Cisse

Camera controls - no control possible

You are about to reply to a thread that has been inactive for 237 days.

Please take a moment to consider if this thread is worth bumping.

Question

Hi

Since 3 or 4 months I cant use sl anymore. The same problem with the sl viewer as well as with the firestorm viewer. I have no control anymore of the camera controls. 

Before Alt + Left mouse button, moving the mouse should control the view quite precisely. 

But now, In my case, since couple of months, controlling the view is impossible. Alt + Left mouse button and moving the mouse gets the view zooming immediately very close and most of the times in an object. Moving the mouse/view back out of the object is not easy controllable. The view holds long in the object and when continuing the mouse motion backwards the view jumps immediately far far out.  What preferences should i change .. ? thx

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0

Look in the Advanced menu, and be sure that "Disable Camera Constraints" is not checked.  I leave mine checked, but maybe your mouse is a lot more sensitive than mine.

(That's another thing you could check...the mouse sensitivity settings in your system.)

Share this post


Link to post
Share on other sites
  • 0

Thx Lindal, but no. "Disable camera constraints" was not checked. I set mouse controls on very slow and used another mouse, but .. no improvement at all.  It is strange, pointing at an object and moving the mouse the slightest tick (a milimeter movement) makes the view jump very very close or right in the object. Ok well, i m not using sl and waiting for an update that fixes it since four months now and can wait some more months. thx

Share this post


Link to post
Share on other sites
  • 0

Thomas, I have the same issue.  Moving the viewer camera with alt+mouse can zoom crazy distances sometimes since I switched to a cordless mouse

what I have found that helps me most of the time, is in Debug Settings, set DisableMouseWarp to True. Why this helps I dunno, just that with my cordless mouse it does

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

The viewers are sensitive to various input devices. Windows/Apple system settings and some software also affect how the viewer camera behaves. For instance I can not have Bluetooth enabled and my SpaceNavigator (SN) connected at the same time. XBox controls wake up with Bluetooth and try to figure out the SN inputs and the viewer camera goes nuts.

Also, we are assuming you are using the Linden made viewer. A number of third party viewers are available. Fixing things depends on which viewer you use.

There are a number of mouse settings in Debug Settings.

My mouse has a button that increases and decreases the mouse resolution/sensitivity.

Share this post


Link to post
Share on other sites
You are about to reply to a thread that has been inactive for 237 days.

Please take a moment to consider if this thread is worth bumping.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...