Jump to content
Dictatorshop

No Double Click in SL after Win10 Updates

Recommended Posts

Hi all, after a windows update a few weeks back  I noticed that I was suddenly no longer able to double click in SL.  I do not mean just to teleport but to open files in inventory or anything.  I went through all the settings, reinstalled mouse drivers and a dozen other things suggested around the internet, nada.  Last night suddenly it worked, and I had not changed *anything* that I am aware of.  I was ecstatic.  Then windows decided to update itself overnight and I am right back to double clickless again.  I just tried the uninstalling of the drivers, of the LL viewer, and Firestorm (had same issue in both) and reinstalling.  STILL no double click.  This makes using SL a real pain.  You don't know what you have until its gone, lol.  Is anyone else experiencing this double click problem?  Is there some fix I didn't come across?  Why would it suddenly start working again out of the blue?  The why it broke again must be related to the MS update.  Suggestions?

Share this post


Link to post
Share on other sites

Do only mention Second Life, what about the desktop in Windows itself?

First, double check the mouse settings in Windows control panel (in case the double-click speed setting has changed, you may be double-tapping too fast or too slow) - if that is all fine and well, try another mouse in case it's your mouse that's going bad.

If the mouse works normally in Windows, have you tried a different viewer such as LL Viewer, Catznip, Firestorm, or Kokua (whichever is not what you're using now)? If the double-click works in another viewer then the problem is in your main viewer. If not then the problem is with your system.

Share this post


Link to post
Share on other sites

I've only had this problem with dirty and decaying mouses. If you have an old mouse lying around somewhere try it and see if it also has the same problem.

Share this post


Link to post
Share on other sites

If you run the viewer as admin, does double click work then?
Right click desktop shortcut to viewer -> Run as administrator.

Bit of a long shot but I'm wondering if the Win update has messed up some permissions.  If double click works when running with admin perms then we know where to start looking.

 

Share this post


Link to post
Share on other sites
Posted (edited)

@Alyona Suwhen it first happened it was all of windows - but once i went in and adjusted the doubleclick speed it was fine for everything except SL/FS.  I usually use Firestorm but tried the LL viewer too, same issue in both.  The weird thing was it started working last night out of the blue, and then the windows update killed it again.

 

@Whirly Fizzle I tried administrator now and sadly that isn't helping (in FS atm).  I even completely uninstalled all SL and Firestorm stuff I could find and reinstalled FS fresh just now, still no change.

 

@KT Kingsleythe mouse is fine (that was the first thing i checked), i have tried different mice, including my husband's which i know is working find on his computer.

Both of my mice are the same maker, so I tried husbands which uses different software and it still had no double click in SL.  An odd thing, if i am uploading files and SL opens an explorer window, double click is fine, but I am assuming that that is due to that module being a windows thing and not an SL thing.  Any other ideas?

 

Edited by Dictatorshop
  • Thanks 1

Share this post


Link to post
Share on other sites
Posted (edited)

One thing i have noticed that while clicking around in sl into popup menus and whatnot, my cursor doesnt look right, it is a white Plus sign looking cursor that has a round ring with a solid gray background behind it... Perhaps sl is using some sort of precision mouse or something that I didnt choose?  Hmmm or maybe that is only over the radar map. grasping for some explanation here.

Edited by Dictatorshop

Share this post


Link to post
Share on other sites
2 hours ago, Dictatorshop said:

One thing i have noticed that while clicking around in sl into popup menus and whatnot, my cursor doesnt look right, it is a white Plus sign looking cursor that has a round ring with a solid gray background behind it... Perhaps sl is using some sort of precision mouse or something that I didnt choose?  Hmmm or maybe that is only over the radar map. grasping for some explanation here.

Can you post a screenshot of how the cursor looks?

Share this post


Link to post
Share on other sites
Posted (edited)

@Whirly Fizzle I only get that weird cursor over the radar map - i thought i was getting it all the time but it just happened that i had that up under the blue menus so the cursor was flashing with that as i changed menus.  Without map there no strange cursor.  So, guess that isnt it.  This is a very unhappy situation for me.  I sure wish I knew why it fixed itself, however briefly, and how i do that again!

Edited by Dictatorshop
  • Thanks 1

Share this post


Link to post
Share on other sites
Posted (edited)
On 8/8/2019 at 1:49 PM, Dictatorshop said:

One thing i have noticed that while clicking around in sl into popup menus and whatnot, my cursor doesnt look right, it is a white Plus sign looking cursor that has a round ring with a solid gray background behind it... Perhaps sl is using some sort of precision mouse or something that I didnt choose?  Hmmm or maybe that is only over the radar map. grasping for some explanation here.

I noticed that odd cursor, too. Although it was a big tan cross on light background. It was so strange that while browsing through the world map, I thought someone had made a little island with a cross on it until I realized it was the cursor itself! This lasted all through the last version of SL but seems to be gone now and I didn't screen shot it. I wondered if LL changed the graphics to the cursor.

I don't use double click on inventory because it only makes whatever I click on go on to my avatar, which then strips off my attached clothing.

 

Edited by Prokofy Neva

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...