Jump to content
  • 0
SunShine Kukulcan

Issues with See-through areas

Question

Posted (edited)

I am having an issue with rigged mesh hair (Truth), Bento mesh head (LeLutka) and mesh body (Maitreya). The hair that is over shoulders or down back causes see-through issue as if there were an  alpha layer. This happens with both the underwear and clothing layers on the Maitreya HUD.

Does anyone know how to remedy this situation? Screen shot attached.

TIA to all that respond.

 

Edit1: More info--wearing the head and body alpha for LeLutka head. If I only wear the head only alpha? Some old skin shows through..how to remove non-mesh skin? I have attempted to take off that skin, but can not. So it is imperative that I wear the body alpha so that old skin no longer shows through the clothing. I think this may be the issue!

Edit2: Changed LeLutka alpha to head only and added Maitreya body alpha, SAME ISSUE appears.

 

Screen Shot 2019-08-02 at 09.32.44.jpg

Edited by SunShine Kukulcan
Add info

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 2

If you can edit it, try setting the texture's alpha mode to alpha masking, and then fiddle with the mask cutoff setting until it looks ok.

If you can copy it mess about with a copy of the original until you're happy with the result. If you can't copy it, a) send it back or, b) make a note of the original settings (which'll probably just be alpha mode: alpha blending) and reset those when nothing works.

Be aware that it's entirely possible that there's more than one face in your hair object, so you'll have to repeat the process for each.

(Also, this cures that annoying halo effect you get around your hair when it's seen against a background of trees and vegetation that also has an alpha blending texture. Bottom line: the graphics engine used by SL – and countless other games and whatevers has problems deciding what's in front when it has to render overlapping semi-transparent textures. Alpha masked textures are not semi-transparent: they're either completely transparent, or not at all transparent.)

  • Like 3
  • Thanks 1

Share this post


Link to post
Share on other sites
  • 1

You may have noticed -- or maybe not, depending on how your hair is textured -- that using Alpha Masking has one small drawback.  It does not allow for partial transparency. A pixel is either visible or it's not.  There's no translucency option.  Under some circumstances, that will make for sharp, rather unsightly edges between opaque and transparent areas.  The two big advantages to alpha masking are that (1) it avoids the "alpha glitch" problem that you noted and (2) it reduces some rendering load.  The design challenge, then, is to balance the pros and cons of alpha blending and alpha masking, recognizing that neither one is always the "best" choice.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0
4 minutes ago, KT Kingsley said:

If you can edit it, try setting the texture's alpha mode to alpha masking, and then fiddle with the mask cutoff setting until it looks ok.

If you can copy it mess about with a copy of the original until you're happy with the result. If you can't copy it, a) send it back or, b) make a note of the original settings (which'll probably just be alpha mode: alpha blending) and reset those when nothing works.

Be aware that it's entirely possible that there's more than one face in your hair object, so you'll have to repeat the process for each.

(Also, this cures that annoying halo effect you get around your hair when it's seen against a background of trees and vegetation that also has an alpha blending texture. Bottom line: the graphics engine used by SL – and countless other games and whatevers has problems deciding what's in front when it has to render overlapping semi-transparent textures. Alpha masked textures are not semi-transparent: they're either completely transparent, or not at all transparent.)

YOU ROCK!! Will be trying this now and will post results. Many thanks.

Share this post


Link to post
Share on other sites
  • 0

UPDATE:

Setting hair's texture to alpha masking worked. No fiddling needed.  If this situation ever presents itself again, I will thank you silently as I fix it!

😉

  • Like 2

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)

Sometimes, hair looks awful with alpha masking on, particularly if it's a wispy style.

In this case you can alpha mask the clothing layer instead. Not by removing your alpha mask that hides your system body, but using the hud for your body. Go to the section of the hud that selects the clothing layer that you're wearing, and change that to alpha masking instead.  Note that this too will look awful if your clothing is lacy or sheer, and it will not solve the problem of getting the halo around your hair against a background of trees, but it often works better than masking the hair when wearing regular clothes such as what you're showing in your photo here. It also solves the problem if your hair is no-mod.

Edited by Matty Luminos

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...