Jump to content

Scripts frame time anomaly?


ChinRey
 Share

You are about to reply to a thread that has been inactive for 2222 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

On a mostly empty sim, you will see low values. Rental sims, since people rez tons of stuff, it could be up to 8-10 ms. But normally if everything is optimized and there are not many scripts, it's perfectly normal to see for 1-5 ms script time.

Basically, the lower the better.

As for scripts run, I believe that is percentage of active scripts/disabled scripts. Not script failure(Unless it crashed). Simply restart them if they crashed.

Link to comment
Share on other sites


Chaser Zaks wrote:

As for scripts run, I believe that is percentage of active scripts/disabled scripts. Not script failure(Unless it crashed). Simply restart them if they crashed.

Not quite. Disabled/inactive scripts are completely ignored by the software and don't show up anywhere in the stats.

 

Nalate Urriah quoting Kyle Linden:

"This is a new stat in the Viewer Statistics panel. Kelly Linden says this reports what percent of scripts are getting a chance to run each frame. 100% means all scripts got a chance. 90% means 90% got a chance. That doesn’t mean they actually ran. They may be waiting for an event. But they did get to check if the event fired."

(http://blog.nalates.net/2012/09/18/sl-news-week-38/)

 

So in my example here 78.854% of the poor li'l scripts didn't get a chance to run during that frame even though the sim server had plenty of time to spare for them. That lazy server was idling the microseconds away rather than doing its job. ;)

Link to comment
Share on other sites

Yeah, looking around at other sims, I haven't found a pattern like that.

In lieu of a clue, could this possibly be a Homestead or OpenSpace sim?

Otherwise, we'd either need something besides frame time that prevents the scheduler from getting through its queue (memory?) or maybe something messing up the accounting. (Does it feel as if there's script lag? or... probably we could come up with a script that tests for that.)

Link to comment
Share on other sites

This is definitely a sim issue.  I run a homestead and the script-run stats are broadly similar to any full region.  Your stats are indicative of a simulator that is having trouble running scripts and that is NOT normal.  5000 scripts on a homestead is a bit high, I try to keep mine below 2000.  Restart your sim.  I'm no expert but the unacked data figure looks abnormally high too.

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 2222 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...