Jump to content
  • 0

Does anyone know why my prims rotate, move, or change size randomly by .5?


Carson Brandenburg
 Share

You are about to reply to a thread that has been inactive for 4090 days.

Please take a moment to consider if this thread is worth bumping.

Question

  • 0

Prim creep isn't common, but it does happen, often when you are building at very high altitudes.  SL's servers have a harder time positioning items precisely in a sky platform at 4000m than they do on the ground for some reason.  As you say, it can be very frustrating when you're trying to avoid ugly match lines. Recent server upgrades (which have contained other bugs) may have temporarily made this behavior worse, although I can't find anything in the JIRA to confirm that.  Since you are seeing this creep primarily on prims that you have shift-dragged, try retyping the correct positions and rotations in the editor.  Those numbers sometimes stick better.  You might also try posting your question in one of the many builders groups in world, like Builder's Brewery.

  • Like 1
Link to comment
Share on other sites

2 answers to this question

Recommended Posts

  • 0

Prim creep isn't common, but it does happen, often when you are building at very high altitudes.  SL's servers have a harder time positioning items precisely in a sky platform at 4000m than they do on the ground for some reason.  As you say, it can be very frustrating when you're trying to avoid ugly match lines. Recent server upgrades (which have contained other bugs) may have temporarily made this behavior worse, although I can't find anything in the JIRA to confirm that.  Since you are seeing this creep primarily on prims that you have shift-dragged, try retyping the correct positions and rotations in the editor.  Those numbers sometimes stick better.  You might also try posting your question in one of the many builders groups in world, like Builder's Brewery.

  • Like 1
Link to comment
Share on other sites

  • 0

Ooh I haven`t seen that bug for a few years, its called prim drift and you are correct it is 0.05 and it also multiplys if you copy a whole row of prims, you will find the last compared to the first is wayyyy out. It usually affects hollow or cut prims more than others.

Do you know when it started? Was it a particular viewer update or after a server update in a rolling restart? Does it happen on all sims or just ones on particular server channels? You can create a JIRA to report the bug & its much easier for the devs to reproduce it if you can pin-down exactly where the cause is.

I just tested on my sim which is RC BlueSteel & on Phoenix viewer and I can`t create any drift at all even with hollow prims, everything was surprisingly accurate.

EDIT: I was testing at 3700m too. The last time I recall it being a huge widespread problem was when Havok 4 was introduced, so I would look to see if there have been any changes in Havok.

 

  • Like 1
Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 4090 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...