Jump to content

Mesh strange behavior


vybeimvu
 Share

You are about to reply to a thread that has been inactive for 2309 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

Hello, I'm new to meshing on SL, although i have made meshes on other platforms. I have made some furniture but what happend just now hasnt occured to me yet.

When moving around the mesh some parts seem to dissapear or behave strangely.





Here's the model inside 3DS Max:



 

The mesh was exported to .dae with default settings (like i said it didnt happen to the other meshes)

It has 3 diffuse, normal and specular maps.

 

Any solutions or guidence in why this happens would be appreciated :)

 

Edit: Without the normal & specular maps the biggest problem is gone, but there is still some minor behavior, i've checked inside 3ds max if the (polygon) normals were flipped that was not the case.



Link to comment
Share on other sites

Make sure your diffuse textures doesn't contain an alpha channel when you don't need transparency. To check that the alpha channel is the issue, set the diffuse maps to None in the Alpha mode drop down menu. (Only selectable if the texture has an alpha channel.) If there is an alpha channel on purpose in your diffuse maps, set the alpha mode to Masking and adjust the Mask cutoff, to avoid the sorting glitch.

If you don't need transparency, upload diffuse textures without an alpha channel rather than just setting them to alpha mode None. They will have a smaller memory footprint.

 

Link to comment
Share on other sites

Thanks this fixed it :) i forgot that my diffuse has a black background, didnt know that would pick up as transperant on the diffuse, it was set to "Alpha Blending" i changed it to  "Alpha Masking" now it looks fine, thanks :)

Link to comment
Share on other sites

A black background doesn't pick up as alpha. I guess you saved out your maps as PNG from Photoshop. PS handling of the PNG format is rather poor. it can add an alpha channel on it's own, even if there is none listed under channels. I prefer the targa format because of that. It's easier to handle in PS.

Link to comment
Share on other sites


arton Rotaru wrote:

A black background doesn't pick up as alpha. I guess you saved out your maps as PNG from Photoshop. PS handling of the PNG format is rather poor. it can add an alpha channel on it's own, even if there is none listed under channels.

Gimp has the same issue. It adds an alpha channel to a png by default and you have to remember to remove it manually.

With Paint.net you get to choose when you save but the option descriptions aren't very clear to everybody: "24 bit" is without, "32 bit" is with alpha.

Link to comment
Share on other sites

It's just good practise that when you're not using the alpha channel to remove it from your textures. This goes for diffuse as well as normal and specular maps. Targa can have an alpha channel as well. After upload the image gets converted to jpeg2000 with or without alpha channel. Texture memory in SL is limited so every bit helps. :)

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 2309 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...