Jump to content

radeon HD 7850M - not working with viewer.


Panic Mode
 Share

You are about to reply to a thread that has been inactive for 3599 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

I bought my HP Envy 17 a year and half ago. Imagine my surprise when I tried to open second life and got the black and or white screen of "your video card is not compatible". I googled and dug through here and found some loop hole.. a registry hack or something pretty easy that allowed me to log on.

Windows updated. It erased what I had done, I can't remember what I'd done and now can't seem to find the info anywhere. Can ANYBODY help me?

Link to comment
Share on other sites

I remembered.. I figured I'd answer my own question for anybody else who has this problem in the future. It's the windows seven areo display that, for some reason, screws it. If you're running off of a radeon 7850M video card and when you open your viewer you get a solid black screen, a solid white screen or a two toned screen this is the problem.

Go to control panel > apperance and personalization > personalize and select one of the "Basic and High Contrast" themes. I didn't even have to shut down the frozen viewer. It insantly loaded correctly.

I have no idea why this problem exists.. 

Link to comment
Share on other sites

Drake, AMD changed the ATI branding to AMD at least two years ago so the Radeon HD 7850M is not an ATI card, it's AMD and it not only meets the minimum requirements, it exceeds them by a sizeable margin. The desktop 7850 is up there with the Nvidia GTX 570 while the notebook 7850M provides about the same performance as the desktop Nvidia GTX 550 Ti.

Link to comment
Share on other sites

On a sidenote... it's not really the wrong theme selected but Aero running. That's the 3D mode of the desktop in Vista and Win 7. With selecting an alternative theme you probably disabled Aero aswell which fixed the white login screen. 

What you also could do would be:

- Rightclick your shortcut or executable to SL

- Properties

- Compatibility

- check "Disable Visual Designs"

Link to comment
Share on other sites

Excellent! This solved my problem as well. Radeon HD7870 and 65" TV connected HDMI-HDMI and every other game in the universe runs perfectly (some in 3D). Even Rage runs very well - the only other OpenGL game that I've played recently. But no Second Life on this computer since Summer. And such a simple solution. I did fill out a bug report with AMD a week ago, before I saw this thread.

Link to comment
Share on other sites

  • 1 month later...
You are about to reply to a thread that has been inactive for 3599 days.

Please take a moment to consider if this thread is worth bumping.

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...