Jump to content

Problems with the PHYSIC SHAPE


Rosanna Ewing
 Share

You are about to reply to a thread that has been inactive for 3651 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

i built a simple cube with 3 floors and roof. When i uploaded it with: PhysicTab - Lowest - pressing Analyze i got these Convex Hull-thing and fly through my floors and roof. So i made a very simple Physics on my own using 4 planes (3 planes for the 3 floor and another one for the ceiling). I linked them after right positioning in the cube and upload it: Physic tab - click the dae. file and did'nt press "Analyze". I set it to "prim" in world: the result is: i can't walk on my floors and dont fly through the roof - but i stand too high above the grounds in each floor. I tried to position the planes again a few times unfortunateley the result is always the same. Nothing changed it.

Would be nice to get some helpful tips about the right physics here and generally (beside of the informations here in the blog about this theme). Thank you!

Rosanna Ewing

Link to comment
Share on other sites

My best guess is the physics shape is rescaled by the uploader. Before upload you have to make sure the physics model you build is the exact same size as your visible model. All models you upload are scaled to the dimensions of your high LoD model and I can imagine your floors and ceiling have some thickness, where the ones in your physics model do not. So the lowest physical plane will be on the bottom of your lowest floor and the physical ceiling will be on the top of your ceiling. You can add very small triangles to match the size of your visible model. The same is the case for Your medium, low and lowest LoD model btw.

Inworld you can check how your physical model looks by clicking render metadata->physical shape (or something similair) in either the advanced or develop menu. If the physical shape does match your visible shape, something else is going on. My experience with physical models set to prim, is that the avatar position will work fine.

Link to comment
Share on other sites

thx to Kwakkelde and Aquila for your answers. I tried to solve the problems by uploading my mesh model and in the physic tab i choosed the lowest and clicked analyze. After rezzing in world i did normal prims for the floors, roof and walls set it to invisible (and prim of course) linked it and connected it with the mesh model (mesh model should not be the root prim!) and i then i set the mesh to no physics. Works fine and LI does'nt increase very much.

Later i would prefer to do an seperate own physics and i think the link from Aquila could help me here. One question i have: did someone have experiences with this program(s) which allow to do the physics in world, save it as dae.files and load up, does that make things probably easier?

Link to comment
Share on other sites

I don't see a reason why you want to make the physical model inworld. For something like floors and a ceiling you want planes, not boxes. In SL you can't build planes so you'll use more geometry than needed. All you need to do is make sure it all fits and when making a physical model inworld, that's no different.

Link to comment
Share on other sites

There is a good thread that explains how to deal with the floor thing here:  http://community.secondlife.com/t5/Mesh/Walking-on-Water/m-p/1756173/highlight/true#M18106

 

BUT, I have to say that while it worked perfectly when I originally used the technique, it appears that the server (agni) has changed its ideas on things. My floor that WAS perfect lost the physics connected to it it seems and I was once again walking in the air.

 

So, like you and in subsequent builds, I made a separate  "just a prim" mesh and used that as the solid part of the floor. Not only did I not want to redo and upload again, I had absolutely NO faith that the same thing wouldn't happen in the future. So for both my sanity and my customer's walkability I went with the workaround. .5 LI isn't too much to sleep at night. You could of course use a regular prim and set to convex hull and get the .5 too.

 

Note that the rise above previous levels on floors was not only in MY builds but in some from others that also had been working fine before whatever change was made.

 

And for those of you working on Aditi, beware that the physics at least on Mesh 3 or 6 (forgot where I was) do NOT translate over to Agni at the moment. I had issues with the walking through walls thing on a surround even though it should have been fine. I decided that using the "none" option would be fine for this this and didn't worry too much. Then when I uploaded at Agni it was a VERY solid surround. More LI than I wanted but  still reasonable. Have no clue what's going on there, just be aware that it might happen to you too.

 

Keep on keepin on!!!

 

 

Link to comment
Share on other sites

No idea if this is what causes the walkthrough walls for you, but if you rezz a mesh object in such a way that you are in it at rezz time, it will be phantom/physicalshapeless. Rezz it in an open space and it will behave as you expect. At least that happened to me and I think I read it happened to others as well.

  • Like 1
Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 3651 days.

Please take a moment to consider if this thread is worth bumping.

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...