Jump to content

scripting errors


Lydia Craig
 Share

You are about to reply to a thread that has been inactive for 135 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

  • 9 years later...

I'm seeing this with a pair of KeyframedMotion objects that for the past four or five days have spates of failing to reach the target, they send error IMs when they time-out.

I have a feeling this is due to region idling.

ETA

With a couple of extra checks added I am seeing the KFM failures when region FPS is low and there are zero avatars in the region, so it is caused by region idling.  Identical scripted objects in another Grid (outside of SL) do not show any similar errors.

If the scripts are your own, or are modifiable, you can try testing for region idling and not initiate actions in those circumstances. (llGetEnv and llGetRegionFPS).

However, given that region idling must have happened many times in the particular parcel I have, I can't really think of any reason why the objects should suddenly start throwing up lots of errors. I don't recall seeing anything in the recent release notes saying changes were being made to region behaviour in these areas.

Edited by Profaitchikenz Haiku
Link to comment
Share on other sites

13 hours ago, Profaitchikenz Haiku said:

I'm seeing this with a pair of KeyframedMotion objects that for the past four or five days have spates of failing to reach the target, they send error IMs when they time-out.

I have a feeling this is due to region idling.

ETA

With a couple of extra checks added I am seeing the KFM failures when region FPS is low and there are zero avatars in the region, so it is caused by region idling.  Identical scripted objects in another Grid (outside of SL) do not show any similar errors.

If the scripts are your own, or are modifiable, you can try testing for region idling and not initiate actions in those circumstances. (llGetEnv and llGetRegionFPS).

However, given that region idling must have happened many times in the particular parcel I have, I can't really think of any reason why the objects should suddenly start throwing up lots of errors. I don't recall seeing anything in the recent release notes saying changes were being made to region behaviour in these areas.

The OP was from 2013; Whatever problem they were having has hopefully been fixed.

Whatever problem lilike1981 is having with their fishing rod is probably specific to whatever fishing rod they're using.

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 135 days.

Please take a moment to consider if this thread is worth bumping.

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...