Jump to content

Rigged mesh no joints or skin weights


JackRipper666
 Share

You are about to reply to a thread that has been inactive for 4403 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

Hey guys, I've been trying forever to simply wear a rigged mesh. No matter where I upload it OSgrid or Second LIfe grid the upload on the latest viewer will not show joints or skin weights, the check boxes are always greyed out. I have tried just uploading and wearing it but all it does is attach to my hand. Also tried invisible alpha an wearing it. Other things I tried are using a skeleton I found here on the forums and one from second life wiki. Still won't upload a damn skeleton. Starting to drive me nuts. Anyone else having this problem lol?

Link to comment
Share on other sites

 I'm using Maya 2011, I have attempted to also use FBXconverterUI since the collada export doesn't work for Maya 2012 when you import it into SL. I figured maybe it's the same issue with 2011. Apparently it's only a 2012 issue either way exporting a mesh with a rig as FBX converted to .dae with FBXconverterUi or just straight collada export from maya as a .dae file doesn't work either.

 

I have used over 21 bones so far. Really not sure just how touchy second life. Is it only blender compatible? I don't like blender at all. Feels very cumbersome with the movement and it's one of those things once I get use to software it's where I'd like to stay since I know where everytrhing is that I need.

When I upload though I see my mesh and I can upload it. I just have no options for joints or weights.

Any other details you might need? Not sure what else I could mention....

Link to comment
Share on other sites

I have the same issue and I simply cannot figure it out. I followed Asha's tutorials to the T.. and it all works in blender (2.4.9 if you're curious) and yet when I bring it to SL, I have no option for skin weights (see below)

http://postimage.org/image/stu5xf3gh

http://postimage.org/image/v6pmymsdf

I understand your frustrations Jack!

I've tried both Viewer 3 and the new Phoenix 1.6.0.1600, and both come up with the same issue. If anyone could PLEASE help, it would be massively appreciated. I'm very eager to see what my meshes look like on the avatar.. actually moving and doing stuff rather than the stiff, statuesque way they are now.

As an edit: I have successfully uploaded weighted/skinned meshes in the past, however I am no longer able to, and there seems to be no reason or explaination as to why those two buttons have been greyed out.

Link to comment
Share on other sites

its most probably the 21 bones constraint.

in all cases which i was looking at that was the main issue. BTW the old avatar.blend misses the 2 vertex groups:  "mFootRight" and "mFootLeft"... adding them even as empty groups often solves the problem already.

 

Link to comment
Share on other sites

I am having the same problem. I have bound mesh, and did it to the standard SL skeleton. I hand painted the weights, and I exported it using the OPENCOLLADA exporter (not DAE FBX< because that exports is not Opencollada). I do not have an option in the SL Viewer for importing a skin weighted mesh. the mesh itself comes in fine though. A similar file had been imported into Sl three months ago (Same Mesh, same Skeleton file), but it needed beter skin weighting... so I got it. I am using Maya 2010, in Windows XP, and using the latest Opencollada plug in, and still getting no dice. Is this an operator error, or should we enter a JIRA note? As an aside, the beta Grid is down to one sim with annoying children pestering you for attention. --KARL

Link to comment
Share on other sites

ok, here is one of the weird issues with good old blender. I have never seen this happen before, but ok. Look at the following series of images:

zmbies.png

See the object counter at the top. the left number tells you the number of objects in the scene (3) and the right number tells the number of selected objects. this number should be 0,1,2,3 from left to right. But actually only the armature is recognized as "selected". This is clearly a Blender bug and i have absolute no idea how this situation can happen.

anyways here is a "workaround" for this situation:

 

  • Open a new blend file.
  • File -> Append 
  • then navigate to your original blend file and proceed to "Scene -> Scene"
  • then click on the "Load Library" button

Now open the scene.001 from the scene selector:

zmbies_2.png

Actually you even can delete "Scene" and rename Scne.001 to Scene.
Anyways now your objects are selectable again.
File fixed, export and SL-Import work again :)

Link to comment
Share on other sites

Ya, I'm having said problem. Works fine in blender, I followed Gaia's tut/video and everything works except when I go to u/l it to SL no weights or joints. Oddly enough I get them with the ready-made simplebot (got from LL's website). I even opened the blend of that and exported it as collada using Gaia's video as a guide and it u/l fine, got the weights & joints for it. Not sure what's wrong with my av or the default avatar.blend files ;o. I'm using Blender 2.61 and have the SL Collada installed as an add on.

Link to comment
Share on other sites

Thanks for your replies. I'm *new* to this blender mesh stuff, not sure how I'd post my blender file. I can't remember where I got it either but it happens with several files, like if I export my xml (from Phoenix) and then import it into blender that one doesn't seem to save right. Or if I use an avatar.blend file (can't remember where I got it). I've tried a few things. How do I post the file for you to see?

Link to comment
Share on other sites

k I'll keep that in mind Gaia, I am working my way through some tutorials so it's possible I didn't have it boned (rigged) right.  I think I'm using the avatar.blend file from wizard's site, can't remember now! I'll send up another flair if the problem continues and I'm sure it's *not me* LOL Thanks for replying.

Link to comment
Share on other sites

Hey guys sorry I'm late getting back to this post. Nice to see all the help here. Gaia where can I find your tuts I have your blender SL collada installed. I made a quick rig, no restraints or anything. Just a quick parent to the mesh with automatic skin weights. I decided I'll try blender since I'm having no luck with Maya. I exported it but it's way over 21 bones. So you're saying I can't upload anything under 21 bones or it just needs to be 21 bones or more? Most of my bones are in the fingers. I hope it's not losing the joints, weights just by naming convention. That would annoy me lol. Anyway I'm now gonna look aorund see if I can find one of your tutorials on google. 

Link to comment
Share on other sites

From what i understand, for it to work the skeleton has to be exactly the skeleton used on SL, No more, No less. and the bones have to have the exact names as the bones in the SL Skeleton. SL does not allow for custom skeletons yet. it requires the same skeleton as is used in SL. --Karl

Link to comment
Share on other sites


Karl Reisman wrote:

From what i understand, for it to work the skeleton has to be exactly the skeleton used on SL, No more, No less. and the bones have to have the exact names as the bones in the SL Skeleton. SL does not allow for custom skeletons yet. it requires the same skeleton as is used in SL. --Karl

I would say it's still possible. But, I have a used a SL skeleton in Maya and if anyone got it to work not sure what the trick is. So far I have tried the work bench from Gaia and her avatar definitely works but I'm not sure how to use it for my own character. I emailed her hopefully she can enlightment me.  

Couple things I noticed she does differently is use armature in blender that is not the typical rig I see. It's more like she is using hte bones as joints and also the armature looks different. It's more like sticks for bones intead of a triangle shape to the bones that i am use to seeing in Blender ever since I been introduced to rigging through some tutorials. 

I am just going to stick to blender currently since it's seems extremely touchy to get anything to work outside of maya. Even though even when I do a basic skeleton with no constraints etc and just simply parent that to my mesh with automatic weights. I still even exported from blender get no skin weights or joints uploading. The boxes are still greyed out. So if SL is going to be this complicated they really need a sure fire example with exact steps on how to rig an avatar. Otherwise for the seasoned pro's you'll do fine figuring it all out. But for anyone who is more of an artist and just learning Crash courses of multiple 3d software programs like, zbrush, maya, 3dsmax, blender etc. It's going to leave most confused and exhausted after a few months of working hard on just one avatar. 

 

I won't give up till I figure out how to do this though. I have worked hard on a mesh that came out really good and would like to bring it to life lol.

Link to comment
Share on other sites

Just going to start adding my findings here lol. I know now why those bones are in the joint position. Here is part of the reason why rigged meshes aren't working in Second Life. Your bones are acting as a joint in in a horizontal position. Here is a post by Masami Kuramoto. Here explains it more in detail. Now he actually got to wear his lol. I can't wear Gaia's mesh but does see her skin weights once I check it joints shows up as well. Either way that's a step forward this this confusion. There is a guy who sells on SL Market that I'm trying to ask how he gets fully rigged meshes to work in SL. He makes some cool avatars. I forget his name though..

 

 

Here is the link http://www.secondcitizen.net/Forum/showpost.php?p=410101 

Link to comment
Share on other sites

CanOk here is a screen shot of all the suggestions made, Sl Collada, Roll set to 0 etc. I have got as far as Skin weights, joints but still can't wear it. With or without alpha mask on. I have tried just skin weights and no joints to see if I got a different result still no go lol! Here is a screen shot of my settings.

 

Larger resolution of screen shot here. 

http://img507.imageshack.us/img507/7495/twearavatar.jpg

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 4403 days.

Please take a moment to consider if this thread is worth bumping.

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...