Jump to content

Link prims togather question


Shikar
 Share

You are about to reply to a thread that has been inactive for 4070 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

Hello

I'm new at SL so I have a question I read thru the linking prim togather and pretty much understand how to do it. But right now I have seawolf gryphon in biped, I am trig to get ear ring put onto his ears which I can do without linking them. but the ear has a moving animation so the ear rings don't move with the ear. So I tried linking the 2 togather but my ears are )No modify) can I still link the to and if so how

thanks

 

Link to comment
Share on other sites

You can animate a root prim and attach objects to it however, the entire linked set will move or you can make a child prim animate but you cannot animate the prims attached to it.  Only a root prim animation will affect the associated prims and child prims act independently.

As such, people often create smaller linked sets as in houses where you have a rezzer so that doors, windows etc can be added.

Options to make this work are to use animated textures and not animated primps or flex primps.

Link to comment
Share on other sites

I I was working on it at lunch time I was able to get the item link to the ear but I lost all the animation from the ear. I lost all the script files in the content folder of the item I link the earing to. the ear now never moves :(. I can;t copy the script files becuase ther " No copy"

Link to comment
Share on other sites

It sounds a bit more complicated than your first note suggested.  If the ear was truly no mod, you shouldn't have been able to do anything to it.  That includes linking an earring to it, removing an animation, or removing a script.  My guess is that the ear itself wasn't no mod, but the script in it was.  That would have set the no mod flag, but you would still have been able to remove the script -- which you obviously did. So .... where did it go?  Did you look at the Recent tab in your own inventory, or in the Scripts folder?  Unless you manmaged to drop it into some other object, the script pretty much has to be in your inventory somewhere.  So, find it and put it back.

Link to comment
Share on other sites

I think you need to find the root prim of the original ear. For every multi-prim object there is a root prim. When you edit an object it is the prim that is yellow and all the child prims are blue. When you attached the earing you might have made something in the earring into the root prim. Where is the yellow prim now when you edit your new ear? It's possible your move scripts are still in the ear but not functioning because they aren't in the current root prim.

You may want to look at an un-modified ear to see where the original root was. You could possibly try to un-link the earring and see if the ear works. If it does you can re-link it by first selecting the earring, then the ear, and then ctrl-L to link them.

Also, sometimes the move script is very link dependent where every single prim has to be linked in a certain order. Hopefully this isn't one of those.

Link to comment
Share on other sites

Well talk with the creator of the avatar, I guss it's nothing I am doing wrong, the script that in the ear will not support attachment at this time he is planning on working on it when he as time. So ty very much for all the help for tracing this problem down.

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 4070 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...