Jump to content

Mesh Face Orientation


Pedlar Decosta
 Share

You are about to reply to a thread that has been inactive for 1438 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

I just came up with something I haven't seen before and wondered if anyone knew what the cause was. I was uploading a mesh model from Blender, and when I got it inworld I noticed the face orientation was wrong. I checked the blender model and it was fine, but I reversed the faces none the less and the next import was fine. But the blender model was (of course) wrong lol. Anyone shed some light on why I had this happen ?

Link to comment
Share on other sites

Hm. Did you have the faces set to double-sided (no backface culling) in Blender? SL is single-sided, so it's best to model single-sided in Blender. (The switch for that moved in Blender 2.8x, and it's hard to find.)

There's also some new Blender mode where back faces show up in a warning color. If you can see a back face, your model has a problem. (Again, I forget where that is in the new interface.)

  • Like 1
Link to comment
Share on other sites

Hi Animats, thanks for your reply. I didn't even know blender had the option of double sided (or that backface culling meant that even), but no I didn't have that on. In fact I had checked the model for face orientation as part of my normal workflow. The only thing that was out of the ordinary was that originally, when I tried to upload the collada it returned an error for missing level of detail. It only had about 14,000 triangles, no ngons as far as I could see and it was not too dense. I got around this issue (couldn't see anything wrong) by copying the model into a new blender file and exported it from there, instead of where I built it. 

Link to comment
Share on other sites

27 minutes ago, animats said:

There's also some new Blender mode where back faces show up in a warning color. If you can see a back face, your model has a problem. (Again, I forget where that is in the new interface.)

I'm guessing but I think you are referring to the overlays button, which has a check box in the geometry section for Face Orientation. Blue is right and red is wrong. The shortcut for fixing incorrect faces is SHIFT N with the object or faces selected in Edit Mode.

Link to comment
Share on other sites

I would suspect that you have a negative scale or a have mirrored at some point.This can cause some things to invert.

Check that before anything else.otherwise Here is how to access the nice face orientation display in 2.8 

In 2.8 

edit->preferences

select themes and scroll down until you see face orientation. 

I have set the normal orientation colour to be fully transparent as the default blue seems utterly pointless, I don;t want to know when it is "right" generally. I leave the back face as red then when I am in edit mode and enable "show orientation" I can see clearly all the red faces I need to fix.

With that setting in place (or for now just leave the red and blue default, go edit mode and then in viewport overlays (the two circles icon top right), click and select "face orientation"

2148b428176f36cd73d1d95c3f02c8a7.png
 

A quick video clip showing the settings and then a quick demo.

https://i.gyazo.com/0ba31e9ec7fc234c2f52adfb5b549897.mp4

Not an SL model just a handle I made to 3d print, but you can see that when I deliberately switch the normal direction the face is showing as red. 

 

 

 

  • Like 1
Link to comment
Share on other sites

Thanks Bec. I kind of explained the face orientation above, but I hadn't thought of changing the blue in settings so that you could leave it on all the time, so that is a great tip, thank you. At some point this model had a mirror modifier applied, however I had uploaded it before with no issues and then I 'expanded' on it. Nothing technical really. Basically just took 2 rectangular parts and made them longer. Even so, I think you may have hit the nail on the head. The face orientation is the result of something, not the cause. A negative scale would seem a sensible culprit. Thank you so much :)

Link to comment
Share on other sites

In 3ds Max, using "mirror" instead of symmetry modifier results in inverted normals and it won`t show in viewport even with backface culling enabled which makes you unaware of the problem until upload..Resetting Xform will resolve this 

Not sure if this applies to Blender and how it translates in terms of nomenclature, just throwing it out there in case it does...

  • Like 1
Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 1438 days.

Please take a moment to consider if this thread is worth bumping.

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...