Jump to content
  • 0

Rotating prims (Like windmills) have ceased to do so...Why?


You are about to reply to a thread that has been inactive for 199 days.

Please take a moment to consider if this thread is worth bumping.

Question

Hello all!

 

I'm having a problem, which I notice at least one other person or group on another sim is having as well. I notice there are at least a couple different windmills, where the blades no longer rotate. I see this happened with mine and someone else's on a public sim. Does anyone have any idea why this could be?

 

Note: My windmill is called the Rustic Windmill. And it was built by Aniki Adamczyk. The other windmill is called the 02_8f8 - New Beginnings - Windmill RARE, which is a gacha item. Though this other one isn't mine. And when I was on the sim it was on, I saw its 'blade' wasn't spinning either. However, the windmill sound can still be heard playing on both mine and the other one. And yesh, I have tried resetting the script for my windmill and its 'blade'.

Broken Windmill._001.jpg

Edited by HenryCrawford
Adding information about hearing sound with no movement.
Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Ouch, a broken gacha item. Probably no-copy, so you can't rez a fresh one, and you're not a customer of the creator, so no fix.

Rotation speed is a persistent prim property, but not quite persistent enough. See http://wiki.secondlife.com/wiki/LlTargetOmega

This kind of rotation is actually done in the viewer. The viewer gets an object update when the object comes into view telling the object to rotate in the viewer. The object then continues to rotate without further attention from the server. That's an SL feature to reduce server to viewer traffic for things like wheels, so you're not frantically commanding "left front wheel, rotate 3 degrees counterclockwise" 20 times a second for each wheel.

However, viewer side things such as trying to edit the object can sometimes stop it, and it may not get restarted. If there's a script managing the windmill, it might get restarted.

Logging out and logging back in may help.

Buying a non-gacha windmill will help. There are many windmills on Marketplace. Land impact, price, and quality vary widely.

 

  • Like 1
Link to post
Share on other sites
  • 0
8 hours ago, HenryCrawford said:

I'm having a problem, which I notice at least one other person or group on another sim is having as well. I notice there are at least a couple different windmills, where the blades no longer rotate. I see this happened with mine and someone else's on a public sim. Does anyone have any idea why this could be

The most common - and least bad - answer is that there simply are too many rotating objects in the scene for the software to handle. I ran across that problem myself a while ago when I held a class about omega rotation at HHBS and the classroom was full of prims the poor pupils were desperately trying to put a spin on. Not fun but we worked it out.

When it comes to the gacha windmill, there's another possible explanation. Gacha items tend to be quick-and-dirty builds of course so it's possible it uses forced scripted rotation. That can cause a lot of problems for the sim and one of them is that the script may stop working completely.

Link to post
Share on other sites
  • 0
Posted (edited)
13 hours ago, animats said:

Ouch, a broken gacha item. Probably no-copy, so you can't rez a fresh one, and you're not a customer of the creator, so no fix.

Rotation speed is a persistent prim property, but not quite persistent enough. See http://wiki.secondlife.com/wiki/LlTargetOmega

This kind of rotation is actually done in the viewer. The viewer gets an object update when the object comes into view telling the object to rotate in the viewer. The object then continues to rotate without further attention from the server. That's an SL feature to reduce server to viewer traffic for things like wheels, so you're not frantically commanding "left front wheel, rotate 3 degrees counterclockwise" 20 times a second for each wheel.

However, viewer side things such as trying to edit the object can sometimes stop it, and it may not get restarted. If there's a script managing the windmill, it might get restarted.

Logging out and logging back in may help.

Buying a non-gacha windmill will help. There are many windmills on Marketplace. Land impact, price, and quality vary widely.

Ironically enough, my windmill is not a gacha item. And yet, it is also no-copy. I went as far as to contact LL and have them attempt a region-restart. Well, this did absolutely no good! So, I tried once again resetting the windmill 'blade' scripts, re-logging, and re-rezzing it...None of which worked. My last repair attempt, as had been suggested by the Linden, was to contact the creator directly. I asked him via NC to see if he could fix the script in my rezzed windmill. Hopefully, he will oblige and not block me in frustration. EDIT: The gacha windmill on the other sim now seems to be fixed.

Quote

 

 

Edited by HenryCrawford
Added new information.
Link to post
Share on other sites
You are about to reply to a thread that has been inactive for 199 days.

Please take a moment to consider if this thread is worth bumping.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...