Jump to content
  • 0
Sign in to follow this  
ozcan

Process credit problem

Question

I am trying to make a transaction but it says in progress since 27 March. The website says it takes 2-5 business days but its already been 7 business days. What is the problem? Why SL keeping my money?

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0
1 hour ago, ozcan said:

I am trying to make a transaction but it says in progress since 27 March. The website says it takes 2-5 business days but its already been 7 business days. What is the problem? Why SL keeping my money?

We can't really answer that.  Is your billing information uptodate on the website?  If using paypal is it verified?  Have you submitted a support ticket to ask LL if there is a problem?

Share this post


Link to post
Share on other sites
  • 0
4 hours ago, Cindy Evanier said:

We can't really answer that.  Is your billing information uptodate on the website?  If using paypal is it verified?  Have you submitted a support ticket to ask LL if there is a problem?

Yes, it is up to date and its skrill. I am from Turkey so I can't use PayPal. I used the same skrill account for other transactions also. Its something I am doing regularly but this time I have an issue

 

4 hours ago, Fionalein said:

You didn't use Limit Buy, did you?

No I don't think I did

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...