Jump to content

(Shading) Hard edges with Blender and Second Life


Izzy Stipe
 Share

You are about to reply to a thread that has been inactive for 2327 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

I've hit yet another road bump on my progress to making a mesh home in Second Life. I can't get the shading to work properly for my building. The lighting on walls is being divided between the triangles. What I find odd is how the Edge Split modifier seems to work fine on Blender, but whenever I upload the same model to Second Life I get the same result I got without using the Edge Split modifier.

 





Before exporting I did make sure to apply the modification.

Thank goodness for the Beta otherwise I would have spent a lot of my own Linden trying to understand SL meshes. What am I missing here?

Link to comment
Share on other sites

I tried enabling auto-smooth, setting shading to flat, adding the edge split modifier; just about everything that I know. The results are always different in Second Life from what's shown in Blender. I'm getting ready to give up.

Link to comment
Share on other sites


Izzy Stipe wrote:

I tried enabling auto-smooth, setting shading to flat, adding the edge split modifier; just about everything that I know. The results are always different in Second Life from what's shown in Blender. I'm getting ready to give up.

Yes, so you said, but did you add the edge loops? 

Link to comment
Share on other sites

Hmm. One thing that will undo the effects of the edge split modifier after it is applied is to move the mesh in edit more if you have "Automerge Editing" turned on (Mesh menu - effectively applies remove doubles). That sounds unlikely to be the problem here. You say the effect still happens if you switch the mesh to flat shading. That is very strange indeed. The only thing I can think of that does that as well as undoing the edge split is if you check "Generate Normals" in the uploader. For your model, you would also have to set the crease angle to greater than 90 degerees. I don't suppose you did either of those, did you? Another point that is also very unlikely to be your problem - if you set the shading to sharp in Blender by switching on Auto Smooth (Object data properties/Normals) and lowering the angle, that will not work in the uploaded model because the auto-smoothed normals are not exported* (although the ones you see using custom normal editing with data transfer are exported, even though they look similar).

*unless the exporter has been changed recently.

  • Like 1
Link to comment
Share on other sites

I'm sorry; yes I did try adding edge loops but in order to get it looking better I'd have to add a lot of them (I think), and I really want to keep it low impact. Still newish to creating meshes so there's something I may have done wrong that I haven't noticed.

Link to comment
Share on other sites

Thank you for the response. The shading looks like it's working well in the preview, but when placed near a light source I can see the where the lighting is being divided.



I tried both generating normals and not generating normals and got the same result.

Hate to ask this, but is it possible for you or anyone else to take a quick look at the Blender file, test it out, and figure out what I've done wrong? I'd be forever thankful.

 

https://dl.dropboxusercontent.com/u/82491530/Room%20West%20Walls.rar

This the raw model, before any modifications.

Link to comment
Share on other sites

Do you have Advanced Light Model turned off? Very low poly surfaces are poorly lit under the forward renderer. It's per vertex lighting. It's the reason why prims are subdivided.

With Advanced Light Model turned on, you enable the deferred renderer which has per pixel lighting, which works much better on low poly geo.

  • Like 1
Link to comment
Share on other sites

I took some time to examine some mesh homes in the market and noticed how the lighting on the meshes divide/split as well. Just wanted to make sure the lighting looked fine with the Advanced Lighting Module disabled, since not everyone can have it enabled without a huge performance hit.

Guess it's unavoidable. Apologies to everyone.

Link to comment
Share on other sites

I'm jumping in late into this discussion but did you remember to make sure the wall is absolutely flat? Even the most minute displacement of a vertice or two can have an effect similar to what you show here.

  • Like 1
Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 2327 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...