Jump to content

How can i import my textures along with my mesh.


SpookyYuki
 Share

You are about to reply to a thread that has been inactive for 2054 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

The Second Life importer does not allow to import textures for rigged meshes. This problem exists almost since day one of mesh so i suspect this is kind of a "feature not a bug" thing.

For static meshes (not rigged) the import of meshes combined with textures works at least for the default SL Viewer. What 3D tool do you use?

Link to comment
Share on other sites

I simply open blender and create the model that i want from there i mark the seams and unwrap it i export the UV layout into photoshop and begin adding the textures once i have done that i add the texture layout to the model in blender i then export the model as .dae making sure i have use textures checked from there i import the model to second life via "upload mesh"

Link to comment
Share on other sites


SpookyYuki wrote:

I simply open blender and create the model that i want from there i mark the seams and unwrap it i export the UV layout into photoshop and begin adding the textures once i have done that i add the texture layout to the model in blender

So lets continue guessing blind folded :matte-motes-sunglasses-3:

So i assume now your textures are in Blender and you have assigned them as Face textures to your model. You can see the textures on your model in blender when you have set the viewport to Texture mode.


SpookyYuki wrote:

then export the model as .dae making sure i have use textures checked

Do you use the Preset "SL + Open Sim Static" ? You might want to do that to ensure the other settings are correct as well.

 


SpookyYuki wrote:

from there i import the model to second life via "upload mesh"

Have you set "include textures" in the options panel?

 

Link to comment
Share on other sites

I did not use any nodes for this i marked seams along the model and UV unwrapped the textures onto it i export the model as .dae making sure to tick include materials and textures but the textures refuse to show up when i try to upload the model via build/upload/upload mesh

Link to comment
Share on other sites

I still don't know how you have put the texture onto the mesh in Blender. If you haven't, then that is your answer. Blender doesn't automatically know that you made a texture in photoshop(or whatever). You have to tell it to use the texture. The easiest way is: Choose "Blender Render" rendering engine in the dropdown in the middle of the top toolbar. select the whole mesh in edit mode - you will see the UV map in the UV editor panel. Select all in the UV editor too. Now use the menu there to open the texture image file. It should appear under the UV map. Finally, make sure you have the "solid" display method selected and check the "Textured solid" option in the "Shading" section of the Properties sidebar of the 3D viewport (displayed from view menu, or by typing "N"). You should then see the texture on the mesh in the 2D view. Now export the mesh, using the "SL and Opensin static" option under the Operator presets - you need the "Include UV Textures" checked, which it should be with this preset*. Now you should see the textures in the uploader preview when you check "Inclde textures" on the "Upload Options" tab, and on the uploaded mesh when you rez it.

You can also apply texture using materials instead of the UV editor, so that they appear in rendered views. I that case you need to check the alternate "Include material textures" instead of the UV texture option.

I should add that I never upload textures with the mesh. I always upload them separately and appply them inworld, which is easier than uploading them with the mesh. There are other good reasons for this, including having to pay the upload fee for the texture every time you upload an altered mesh, and the mesh fee every time you upload it with an altered texture. More importantly, the same texture will be given a new UUID every time it's uploaded. Not only does that waste asset server space, but it means everyone looking at your stuff has to download the same texture again for each object you upload it with. Re-use of textures is a very effective way of minimising lad, but it doesn't work if you upload them with the meshes you use them on. Finally, you will end up with a proliferation of (possibly identical) texture files hidden in non-obvious places in your inventory.

* It will also check the "Copy" option, which ma,es a copy of your texture file in the same directory as the exported dae file - the uploader needs it there to find the file. If it's alreadsy there, then it's not necessary to copy it.

  • Like 2
Link to comment
Share on other sites

  • 11 months later...

I have the same problem. In Blender I see the picure on my mesh object. But in Second life there is no picture.

I looked at several Tutorials like this one: 

I did excactly what they showed and before exporting I also checked "Include UV texture" and "Include Material Texture"

But when I import the Mesh, it has only a grey color and no texture

Link to comment
Share on other sites

  • 6 months later...
On ‎28‎.‎11‎.‎2016 at 5:22 PM, Christhiana said:

Upload the textures seperate from your mesh for the reasons Drongle already mentioned in the previous post.

This solved my problems. Thanks for hint, Christhiana and Drongle McMahon.

 

Simple explanation for newbies like me:
1. Paint the texture in Blender as you do normally

2. In UV-view save image (png for example)

3. Do  the model export+import as dae normally. Forget textures. Only care about physics.

4. Upload the image separately (and pay 10L :-)

5. Apply the texture. It will be automatically aligned as it was in Blended. Magic!!

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 2054 days.

Please take a moment to consider if this thread is worth bumping.

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...