Jump to content

NeoBokrug Elytis

Resident
  • Content Count

    132
  • Joined

  • Last visited

Posts posted by NeoBokrug Elytis

  1. 6 hours ago, M Peccable said:

    I don't think it is restarts -- the regions are crashing. In the last 30 minutes I have had 2 of them crash immediately after entering them in a boat. The logout message says "the region is going down", but since they come back up within 2 or 3 minutes that means they didn't go down, they crashed.

    Hmm, I don't know.  Most of the logs I have show regions going from Up to Stopping, which means a graceful shutdown usually.

  2. You're not wrong @animats, but I think that's not the correct answer.

    When you pull up the Top Scripts floater for the region, it lists all scripted content in the region as well as all their script times -- including the idle scripted content.  And that still adds up to much less than the statistics pane.  When you pull up the Statistics floater and that reports Script Time ms that's far greater than Top scripts -- as in a magnitude of 4 or greater.

    At the most recent server meeting I asked about this very issue, and @Mazidox Linden had mentioned that it's possibly pulling the numbers from two different places in the simulator code. 

    It would be nice to get this fixed so we know what's being bad, and what's not.  Right now I kind of go by script memory and script time, because usually more script memory == more scripts.

     

  3. Seems to be the same based on my observations.  Hopefully this is a work in progress.

    Script time on the Statistics floater still does not match script time on the Top Scripts Floater.  Top Scripts will report ~6ms of time, while Statistics will show 20ms (probably capped by the region)

    • Thanks 1
  4. I like to think that it is an actual fix even though I have no evidence of it yet; because it was a sudden change in performance.

    Like the initial bug report, there was just a day where script performance drastically changed.  I have a 10 region estate that hosts rather complex MMO-like games (for SL).  Initially some of the systems behind the game started complaining as I didn't have failover checks for REALLY old components.  Then when trying to host events where there's a lot of avatars in the region and a simple rez intensive process going on, it really hit home to how bad things had gotten.  All of my regions had about 99% in most stats before the initial bug, but after that day is when I saw scripts run taking a huge dump.

    I have been trying to develop a way to benchmark this invisible script lag, without any proper way to pull the "Scripts Run" stat.  I've found a single way to at least detect poor script performance, but not get consistent results with the results I'm getting.  I'll definitely be re-benchmarking things once this hits main channel and provide some feedback.

  5. 1 hour ago, Miller Thor said:

    Can you finally agree on a correct time? In the grid status, the rolling restart was announced at 3am and here 4 hours later at 7am. Now what the hell is the actual execution time? So in any case, it's just confusing the paying customers who are waiting for their region to go through the rolling restart. It can't go on like this, please. As a paying customer, such actions make you feel more than just kidding.

    Chill your entitlement down there, buddy.  It's easier to coax out answers when you're not acting as you are now.

    • Like 1
    • Thanks 1
    • Sad 1
  6. Use the attach event.  If the key returned by the event isn't null key, it's freshly attached, and null key means it's detached.  I know of no instances where on_rez prevents the attach event from being triggered.

    Using on_rez for the purposes you've stated above is a waste of events being triggered and more of a burden on the region than doing it properly with just attach

     

        attach(key av) {
    		if (av) {
    			//	Something is attached
    		} else {
    			//	Something was detached
    		}
    	}

     

    • Like 1
  7. 10 hours ago, Rider Linden said:

    The amount of time allowed per frame to execute scripts is capped.

    I have a technical question.

    Do upgraded private regions with an extra 10k prims also get 30% more allowed time per frame -- or is it just the extra LI?

    If not, would LL consider boosting the extra 30% allowed script time to go with the extra content on the region?

    • Like 1
  8. So this discussion of chat distances being changed is getting a little pear shaped and spreading FUD.

    IIRC -- it's only changeable by ESTATE OWNERS and only for channel zero.  There ARE use cases where having region wide, or multi-region wide chat is a benefit such as large events or venues.

    I, personally won't be changing these values but I understand the need for them.

  9. I can confirm this is also happening on version Second Life Server 2020-02-26T20:56:18.537423

    I operate a grid scope experience powered game, that's ironically just in my personal regions.  It temp attached player HUDs.  These particular HUD dispensers do not work (as well as everything else relying on object_rez in the region): 
    http://maps.secondlife.com/secondlife/The Great Fissure/141/112/69
    http://maps.secondlife.com/secondlife/The Wastelands/43/159/75

    I also use on_rez and object_rez.  object_rez is not being triggered.  I am using methods to make sure the objects are rezzed before communicating with them.  They are being rezzed, but the parent object isn't triggering the object_rez event.

    I am on a private estate and I am technically supposed to be off RC region rolls.  Perhaps the issue isn't with the region itself?

     

    p.s. Poor breedables folks...

×
×
  • Create New...