Jump to content
  • 0
Sign in to follow this  
Guest

SLURL no longer works in Firefox

Question

  • 0

I've had this happen once before. Check your options in Firefox, the Applications tab. Scroll down to secondlife in the Content Type column and change the Action column to point to your client. This is usually in C:\Program Files\ but may be elsewhere if you chose to install your viewer in a different location.

Share this post


Link to post
Share on other sites

10 answers to this question

Recommended Posts

  • 0

I've had this happen once before. Check your options in Firefox, the Applications tab. Scroll down to secondlife in the Content Type column and change the Action column to point to your client. This is usually in C:\Program Files\ but may be elsewhere if you chose to install your viewer in a different location.

Share this post


Link to post
Share on other sites
  • 0

Thanks Meiling - Your answer may have found my problem (Secondlife is not listed under applications), but does not solve it, since I can't follow your suggestion. Now that I think about it, I wonder if installing the Standard SL viewer sets this up under the covers... On this new computer, I only installed the Emerald viewer, since that is what I use all the time...

Hmmmm

Share this post


Link to post
Share on other sites
  • 0

That's what it is. I just tried it and it wasn't set in Applications either because I don't use it. And the list of applications to open the secondlife content with only included my LL client app, not my other viewers.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Yeah, and Firefox has no way to add associations, that I know of. It's dumb to have to install a viewer you don't use just to get that association to work. Maybe someone more saavy than me knows how to change this. Or maybe the Firefox site has help on this?

Share this post


Link to post
Share on other sites
  • 0

Make sure you have the newest version of Firefox installed. I know when I hit the slurl for some of the hunts I have been doing a windo popped up asking what app I wanted to use. I was able to add the Emerald since it came up with the SL viewer in it..Hope that helps.

Share this post


Link to post
Share on other sites
  • 0

Thanks to everyone for replying. Indeed, I installed the SL viewer, started it, tried a TP from an SLURL, and Bingo, I was asked what application to run. Told it Secondlife, since that ws what I was running. then started the Emerald viewer, got that option again, and this time I said to use Emerald and Remember the choice.  Back in SLURL business

Share this post


Link to post
Share on other sites
  • 0

This reply will be a bit late but I'm sure that other people will have the same problem and will want to fix it without having to install the regular client (like me!)

Go to this page and follow the instructions:

http://support.mozilla.com/en-US/kb/The+protocol+is+not+associated+with+any+program

 

The modified code that you'll need to paste into the URL bar for the Emerald viewer is:

javascript:navigator.registerProtocolHandler('secondlife','http://support.mozilla.com/value=%s','Emerald');

This code must be pasted into the URL bar while you're still on the above support page

 

Once you've done that, try opening a slurl and you'll be asked to find the Emerald exe, check the box to remember your settings and you're done!

Share this post


Link to post
Share on other sites
  • 0

Yes!!!

that code pasted in URL bar has worked for me. I have it the same problem and is solved now without installing sl viewer, and changed from applications browsing to program files/emerald viewer/emerald.exe!

Thanks! good resolve

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...