Reply
Resident
Founded
Posts: 2

Game is running unbelievably slow?!

Hey everyone. I recently downloaded and installed Second Life. The only problem is, when i started it up, it was running beyond slow. I couldn't even complete the tutorial because of how laggy it was. Can someone please help me with this?

My computer specs are:

AMD Phenom(tm) II X4 840 Processor 3.20 GHz

8.2 GB (RAM)

ATI Radeon HD 4770

MSI MS-7641

It's custom built, and I have no problems running any other game. I can even run multiple games on the maximum graphics at the same time such as Skyrim and The Witcher 2. Yet, I can not run Second Life on minimum graphics. Well, not efficiently at least. (3-5 FPS) Any help would be much appreciated!

Contributor
Theresa Tennyson
Posts: 2,235

Re: Game is running unbelievably slow?!

Reply to Founded - view message

Second Life viewers use OpenGL rather than DirectX which is more common on Windows games. The OpenGL calls were recently re-written in the viewer so that it would use the latest standard of OpenGL to keep it current - previously it was behaving very badly with recent Nvidia cards and drivers. The re-writing is causing problems with ATI cards now though. Make sure you're running the latest Catalyst version and go into "Preferences - Graphics - Hardware" and turn off OpenGL VBO. If you have a choice between running "Compatibility Profile Context" or not with your OpenGL, DON'T run Compatibility. The re-writing was largely done to make the viewer not need compatibility mode.

Helper
Knowl Paine
Posts: 3,560

Re: Game is running unbelievably slow?!

Reply to Founded - view message

Have you recently updated the drivers for your computer's Graphics Card?

For some Radeon cards, other Residents in the Answers category of the Forum have suggested that Shaders and v.o.d. or v.o.b.(?) be turned off. Ctrl-P will open the Preferences menu (windows) or you may find it in the Advanced menu on the top tool bar.

You have stated that you are already at the Lowest Graphics settings. I'm not familar enough with your specs to make any quality suggestions.

Turn off voice if it is on, turn off play streaming media if it is on. If any other programs are running at the same time, stop those processes. Find an empty Region , Voice Echo Canyon is usually near empty.

In the development of Viewers, many functions are renamed, moved, ect. You have a Statistics Page that will give you information about what your pc is doing, or not doing. It's in the advanced menu somewhere. (they keep moving it)

My knowledge is limited for Pc's, other Residents here have a lot more knowledge than I, maybe they will chime in, or already have because I'm a slow typer. :smileyhappy:

Orca Flotta
Posts: 1,372
Topics: 25
Blog Posts: 0
Registered: ‎12-10-2009

Re: Game is running unbelievably slow?!

Reply to Founded - view message

That famous Statistics bar: just press ctrl - (the key above it, that one to make caps) - 1 all at the same time.

Also conduct a speed test and see if your line is capable of handling SL.

Plug your PC into the modem/router, don't go wireless.

Update your Radeon driver. There are tutorials available for how to tune your card for the best results. I don't have any URL hand ynow, just google it.

I don't know tne games you mentioned (not a gamer) but I guess they are obviously installed on your machine or runing of a DVD or such. They are optimized to give you low lag and top notch graphics. SL is different; 99% of content is made by the residents. And as it so happens most of us are amateurs and not professional game developers or graphic artists.

Basically you gottta differentiate between server side lag and client side lag. Most complaints about lag in SL are in fact just complaints about the own weakish hardware of the complainants. LOL

Orca's World is now the SLuffington Post:
http://orcasl.blogspot.com/
Resident
Founded
Posts: 2

Re: Game is running unbelievably slow?!

Reply to Founded - view message

Okay I tried all your suggestions. I turned off OpenGL and it helped a bit. I'm now running at 10-13FPS but it's still waaayy too slow. I highly doubt it's my hardware because I just installed a bunch of new parts and they work absolutely perfect for any other game. It could be compatibility issues or something, but any more tips would be nice!

Posts: 3,014
Registered: ‎03-26-2009

Re: Game is running unbelievably slow?!

Reply to Founded - view message

Look in Help->About and copy paste the information with any post where you are asking a technical question.

To see what speeds people are getting see the thread in this forum: How Fast is Your Viewer? - Second Life

Add your information if you would.

Duel core CPU's tend to lag a bit right now. You can download CPU-Z and GPU-Z to see if your computer is bottlenecked at the CPU or the graphics card.

On Win7/Vista you can open the performance monitor and look in the Memory accordan to see if your Page Faults/Hard Faults are reasonable. If you are seeing high numbers in Page Faults you generally need more memory. But, if you have too many other tasks running you can get high numbers too. Anything above 0 is slowing you down. 

Also, make sure you have multi-threading turned on. In Debug Settings enable CurlUseMultipleThreads and RunMultipleThreads. With some systems you have to turn multi-threading off. With some card there is a multi-thread setting in the card's control panel.

Lots of work is going on in the SL Viewer. To quickly see if it is the viewer, get the latest Snowstorm Developement version 3.2.6 and run it. Starting with build 246889 I've seen better performance. WARNING! Developement viewers are buggy. Don't expect them to work all that well. They do mostly work, if not tomorrow's verion probably will.


Resident
Izzy Ludlow
Posts: 1

Re: Game is running unbelievably slow?!

Reply to Founded - view message

Second Life itself is having issues,it's not you... Try Pheonix Veiwer, but u will still rez n lag UNTIL they fix the problems...My game is goin slow , i'm having issues rezzing,n once i rez my game crashes...

Honored Resident
Annaleen Serenity
Posts: 4

Re: Game is running unbelievably slow?!

Reply to Founded - view message

Second Life 3.2.6 (247277) Jan 6 2012 07:16:36 (Second Life Development)
CPU: AMD Phenom(tm) II X6 1090T Processor (3500 MHz)
Memory: 16384 MB
OS Version: Microsoft Windows 7 64-bit Service Pack 1 (Build 7601)
Graphics Card: ATI Radeon HD 5850 (Overclocked)
Motherboard: MSI MS-7578 with NF750-G55 chipset.


My specs are a little better than yours and I get about 12 FPS standing still on all graphics settings on low with VBO disabled, Anisotrophic Filtering off, and Antialaising off. I have a default SL character model loaded. I have tried to turn multi-threading on and off with the Debug Settings enable CurlUseMultipleThreads and RunMultipleThreads. Texture Memory at 512 MB.

I have tried all kinds of SL Viewers and different versions of them. I can get over 70 FPS in SL viewer 1.6 and nearly 24 FPS in Viewers based on the SL Viewer 2. I have tried the latest versions of SL Developmental Viewer, normal SL Viewer 3.x, Firestorm, Exodus.

I updated all graphics and motherboard drivers. I then switched out the ATI Radeon 5850 with an Nvidia GTX 260 and got a few FPS slower. This motherboard has an onboard Nvidia 8200 video card but have that disabled in the bios. I set SL to use only 1 then 2 processors instead of all 6. I have uninstall the Catalyst driver and just installed the video driver only. Nothing seems to budge the FPS from going higher on SL viewer 3s.

I find all this low FPS hard to believe when I go upstairs and watch my sister play SL with her Intel i7-920 processor, 12 MB memory, and Nvidia GTX 560 at 50 FPS with all the graphics on Ultra setting.

I am next going to try loading up some older Catalyst and plain drivers that came out about the time the ATI Radeon 5850 was released to see if there is something wrong with the newer video drivers.

Honored Resident
Annaleen Serenity
Posts: 4

Re: Game is running unbelievably slow?!

[ Edited ]

Reply to Founded - view message

Thanks for the info Drager Sutter posted on this thread helped me improve my fps. http://community.secondlife.com/t5/Second-Life-Viewer/AMD-ATI-Lag-Issues-WIth-Viewer-3-FIX/m-p/11074...

I was not able to get over 12 fps on low settings and 5 fps on high settings with my PhenomII x6, ATI Radeon HD5850, 16gb memory. I installed the 11.8 beta drivers with the OpenGL4.2 http://support.amd.com/us/kbarticles/Pages/AMDCatalystOpenGL42BetaWin.aspx and started using the Firestorm 3.2.1 which came out before SL did some change to fix Nvidia cards. I can now get 30 fps on low settings and 20 fps on high settings. I also learned that my computer likes AA turned on so I set that at 8x, also got a few more fps by turning on Anistropic Filtering, and since this version is before SL's Nvidia loving I was able to turn on Enable VBO which improves my fps as well (10 fps with this disabled).

 

As a test I did go back and install the Catalyst 11.12 drivers and the fps went to crap again so i restalled the 11.8 beta OpenGL4.2 drivers and fps went back up.

With SL workign better I went to my sister's computer where she has an i7-920, Nvidia GTX 560, 12gb memory, logging in with the same character at the same location with the Firestorm 3.2.2 and was geting 60 fps on low, med, and high, and 55 fps on ultra settings. Her computer makes me jealous.

Member 16
Member
16
Posts: 2,853

Re: Game is running unbelievably slow?!

Reply to Annaleen Serenity - view message


Annaleen Serenity wrote:

With SL workign better I went to my sister's computer where she has an i7-920, Nvidia GTX 560, 12gb memory, logging in with the same character at the same location with the Firestorm 3.2.2 and was geting 60 fps on low, med, and high, and 55 fps on ultra settings. Her computer makes me jealous.


im green. i hate ur sisters computer and i havent even met it (:

i would die happy for 55 fps on ultra