Jump to content

What i'm doing wrong? (blender q)


Barbiegirl Priestly
 Share

You are about to reply to a thread that has been inactive for 4041 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

Are few days now, and more than 40 hours  since i try to rigg my model. I tryed diffrent programs i've succede in c4d but was useless since is not compatible with collada requirments.

 

Now i'm trying in Blender and i'm stuck for days now @ the part whne you select the skeleton and the mesh model holding shift key, then hold down ctrl +p to armature menu to show up. Well the menu never showd up . i've wached  few tutorials trying to figure out what i'm doing wrong...over and over again.

I'm loosing my minds here!

Any help will be much apreciated!

Link to comment
Share on other sites

The dae exporter for Blender 2.58 doesn't export rigged mesh for SL properly. Try the latest Blender version (2.61) with the dae fix (SL Collada-1.4.py) from this page: http://blenderartists.org/forum/showthread.php?189696-One-mesh-won-t-render-%28noob-issue-%29-...-%28

Or, you could use the old Blender version 2.49. (Beware: This one uses an old UI that many find hard to use.)

  • Like 1
Link to comment
Share on other sites

Thank you very much for sugestion!

I installed 2.61, also the 1,4 collada addon, exported and in second life is still looking like a static sculptie!

I tried with avatar-workbench.blend (2.60 version) who was alredy rigged and check the layers to see how they look..and they look the same as i did...the model is moving with the bones, but no matter what i do is still not look rigged in second life.

At this time i think i need a miracle!

Link to comment
Share on other sites

Hi.

Let me sketch a possible way how to get over your problem:

 

  • Avatar workbench 2.60 does not need the SL Collada addon. The workbech uses a modified rig which should work just fine with the normal collada exporter. However if you export with the "sl collada exporter", then make shure that you have DISABLED the "rot z-90" option in the export menu (on the lower left side).
  • I guess that you are not using joints offsets (if you do not know what they are, then you do not use them probably). So you would only need to export the mesh. In that case you only need to export the mesh. However IF you use joints offsets, then you have to also export the armature together with the mesh.
  • When you import your mesh, you can enable weights at two locations: On the startpage of the importer you can enable "display" weights. This will show you how your mesh will look alike when you wear it. If this works for you, then your collada file is correct. But you still need to do something more to actually get the weights into Second Life:
  • You have to go to the Options tab of the Importer. there you can enable "With weights". And ONLY if you enable it here, then you will actually get the weights into Second Life. This has driven me wild several times. But it was always this detail that i missed to enable. I guess that i simply could reduce my upload costs by 50% if this option would be moved from the Options tab to the first tab of the importer :matte-motes-impatient:

 

 

  • Like 1
Link to comment
Share on other sites

Thank you! This will keep me occupied in the next few days..

Seems alot hard than i expected..i can't seem to find the Options tab of the Importer. Are you talking about blender user preferences?

Is very possibil to be a weight check problem since when i upload preview the model in second life with skin weights and joints looks oke but when i wear it is not rigged!


Link to comment
Share on other sites

OMG OMG OMG i did' it!

Thank you Gaia, thank you so much for the tutorial, i finaly figure out in 10 min what i was doing wrong all this time.....I didn't checked the skin weight and joint position that i missunderstood in ellie advice, i thought i have to check something on blender options,  i feel such retard rofl but thanks to your tutorial i've finaly rigged my mesh!

Million thanks!

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 4041 days.

Please take a moment to consider if this thread is worth bumping.

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...