Jump to content

Textures baking black


Persephone Bolero
 Share

You are about to reply to a thread that has been inactive for 772 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

You are not giving very much information so this is just a guess :)

 

If the wall has its face normals inverted  then it will bake out black.

One way you can check for the direction of the normals is : In the 3D workspace open the Viewport Overlays drop-down and enable the Face Orientation option.

Faces with their normals facing outwards will appear blue and faces with their normals facing inwards will show appear red.

Example of one face with incorrect normals:

1-min(2).thumb.png.7c7618be30f505460f4b3db82cce9974.png

 

2-min.thumb.png.7d0620d427a3e57c4fa6f2af335cbe2d.png

 

If necessary, to correct the normals: in edit mode select All then Mesh > Normals > Recalculate Outside,  (or simply Ctrl N ) .

 

 

Edited by Aquila Kytori
  • Like 1
Link to comment
Share on other sites

Thanks for the suggestion. Sorry that my information was so brief.

I had been checking face orientation. I didn't know it would cause materials to bake black. I just knew it caused all kinds of problems if it's not done. So I have been doing that, and all the normals are oriented properly.

I'll add some screenshots below. If anyone spots any problems, please let me know. I'm at a loss.

Here's my bake settings:

Black1.thumb.png.458644d1b0a2ee513b4029a0add007f2.png

And this is the shading view. I'm trying to bake textures for that front wall, and I'm using only one material. Originally it was two, but I simplified it to try and isolate the problem. The wall is built with an array modifier for the bottom two logs, and a boolean for the doors and windows. The only setting in the nodes I've found that made any difference is the emissions in the Principled BSDF. If I make that white, I get a milky color to the wood textures. But no other settings seem to make a difference.

Black2.thumb.png.0375dce8eae321c0b8700efd8bee5be6.png

Here's the wall by itself, with all else hidden, including the lighting.

Black3.thumb.png.8414ceb14d5d807a573b8f87237579c7.png

And here's the bake I get:

FrontWallBake2.thumb.png.b0e03266021f32b84e6ba5b02e770a54.png

Edited by Persephone Bolero
Link to comment
Share on other sites

Its not a completely black bake ........... what happens if you disable all the other objects in the scene, little camera icon in the outliner and then bake ?

If you don't see the camera icon in the outliner you will find that option in the filters drop-down.

3.thumb.png.6b97ce78548a23b4b2e9066fbeef450c.png

Link to comment
Share on other sites

 

14 minutes ago, Persephone Bolero said:

Why do the other objects make this front wall bake black?

The roof of the front porch preventing the front wall from receiving enough light from your lamps ?

Try the "Disable in Render" only for the roof object.

Or add more lamps so that the front wall gets lit.

Edited by Aquila Kytori
  • Like 1
Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 772 days.

Please take a moment to consider if this thread is worth bumping.

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...