Jump to content
  • 0

Group Chats Not Logged

You are about to reply to a thread that has been inactive for 121 days.

Please take a moment to consider if this thread is worth bumping.


My group chats are no longer being logged in the directory specified at "Avatar => Preferences => Network & Files (side tab) => Directories (top tab)".

At:  "Avatar => Preferences => Privacy (side tab) => Logs & Transcripts (top tab)" the "Save" selection box has "Log and transcripts" selected.

I thought at first it might be a directory write permissions issue. But changing the directory to full R/W permissions for user, group, and everyone, recursively did not make a difference.

System Information:

CPU: AMD FX(tm)-4350 Quad-Core Processor (1827.76 MHz)
Memory: 32135 MB
OS Version: Linux 4.15.0-128-lowlatency #131-Ubuntu SMP PREEMPT Wed Dec 9 08:07:00 UTC 2020 x86_64
Graphics Card Vendor: NVIDIA Corporation
Graphics Card: GeForce GTX 1080 Ti/PCIe/SSE2
Graphics Card Memory: 11264 MB



Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

I realize you are on Linux. I'm not running Linux so you will have to translate.

I can't find a setting that would disable only group chats. There are some that may in Debug Settings. Use your browser's FIND feature to search the web page on Chat and later on Group. To avoid brain damage, just make sure these settings are set to the viewer's default setting. There is a button for that in the viewer's Debug Settings panel. Press Ctrl-ALT-D to open or close the top menu's ADVANCED item. Advanced->Show Debug Settings. Look at each of the possible settings to make sure they are set to the default. This is tedious. You could delete the viewer's settings file which forces the viewer to create a new settings file with all settings set to default at the next launch. Much faster but then you have to redo all the personal preferences you previously chose.

For trouble shooting, rename the settings file and restart the viewer. If your group chat is fixed... then it is one of the settings that was the problem. If not, delete the new settings file and restore the renamed file.


For another try I suggest you copy your conversation logs to a backup folder. Actually everything in C:\Users\[Windows_ID]\AppData\Roaming\Firestorm_x64\[avatar_ID]. In Preferences->Network & Files->Directories (tab) you can see where your chat files are. But, you probably know that.

When you are in the folder, look at the file names. Group chat files will be named [something]_(group).txt. Check the dates. This will tell you if the system is recording group chat or the last time it did.

Delete the [avatar_ID] folder then create a new folder and give it the same name. I saw you fiddled with the permissions. I just had a  L  O   N  G  fight with a printer/scanner that would not write scans to a workstation's scan folder. I did everything I know to do and no luck. I called the printer's tech people and they fought it for hours. Finally they just deleted the folder, created a new one, set all the shares and permissions, and that solved problem. So... while this may be a Windows peculiarity forcing the system to redo a folder may be a better idea than trying to redo it manually. 

If you have PRESETS, copy that "presets" folder back in. Launch the viewer and see if group chat is logging. If so, consider copying all you files back in. But, it is the end of the year. A time in which I zip up all my chat files and archive them. I do this to improve viewer and chat performance.

As each group chat is in a separate file, it is unlikely a file corruption problem. But, removing them all will allow you to test whether that is the problem and replacing the folder eliminates any folder settings issues.


Next I would consider a clean install. There are a lot of 'how to' posts and videos with various considerations on how and what to do in the process. They only mater if you have been using the viewer for awhile.


There are some Linux people around in SL. Search groups and find them. The Lab also has a Linux users email list. Dig through the wiki for it or attend a Linden lead user group meeting and ask. I don't know if it is still active. Been awhile since I followed it.

Link to post
Share on other sites
  • 0

This problem is solved.

I changed the name of the .firestorm_x64 directory. I then logged into SL, and saw that the group chat was now being logged. I then logged out and copied the user_settings from the directory I renamed, into the new .firestorm_x64 directory Firestorm created. Firestorm continued to log group chat, and I had all my settings.

It had to be a corrupted file in the .firestorm_x64 directory.

  • Thanks 1
Link to post
Share on other sites
You are about to reply to a thread that has been inactive for 121 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...