Jump to content

Can't open the viewer, graphics driver update keeps failing

Recommended Posts

Good day everyone.

I can't open the Firestorm viewer after I had a pc reformat 3 days ago.

No changes were made to my laptop, except the said reformat. 

I'm using a laptop, with the following specs:

          Windows 7 Ultimate
          Copyright 2009 Microsoft Corporation
          Service Pack 1

          Manufacturer:                      Hewlett-Packard
          Processor:                            Intel(R) Core(TM)2 Duo CPU T6400 @2.00GHz 2.00GHz

          Display Adapter:                  Mobile Intel(R) 45 Express Chipset Family (Microsoft Corporation - WDDM 1.1)
          Installed Memory (RAM):   3.00GB
          System Type:                        64-bit Operating System


I have tried the following:

          1.   Intel graphics card update https://www.intel.com/content/www/us/en/support/detect.html


          2.   Fix instructions in the Firestorm (and carefully followed everything): http://wiki.phoenixviewer.com/fs_intel_fix_32bit 

          3.   I even tried this https://www.intel.com/content/www/us/en/support/articles/000005474/graphics-drivers.html

          4.   All crazy things that I could think of, but no success, so far


All I keep getting is white error message boxes, either 'update needed' or 'not meeting requirements'.

It doesn't make sense because I was on Second Life just days ago. 

I obviously need better ideas. Please help me, I miss my Second Life :-(

Thank you in advance. 



Edited by Shamonne

Share this post

Link to post
Share on other sites

A PC reformat is a pretty significant change. 

I could ask you a lot of questions, which would be the same ones I'd ask if you submitted a support ticket on the Firestorm JIRA.  Would you mind doing that please? Use this link as your guide Submit a Support Ticket to Firestorm JIRA

Are you able to run the official Second Life Viewer? You can download that here Second Life Viewer  This would be helpful to get your full system info for your support ticket. 

As an aside, the "Intel Fix" is geared towards Windows 10 and specific legacy graphics cards, and doesn't apply to Windows 7. 

Share this post

Link to post
Share on other sites

Thanks, Willow.

I have downloaded the official Second Life viewer, but I got the same error message.

I'd be happy to submit a support ticket, and will be doing it right now.


Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...