Jump to content
Sign in to follow this  
Jonna Korhonen

avatar imposters and not using them

Recommended Posts

My computer is fast enough that I don't need avatar imposters inabled. Disabling the feature causes any avatars at a distance to move and dance like they are on speed. Is there anything that can be done? I prefer to have imposters disabled cause they look terrible to me.

Share this post


Link to post
Share on other sites

in addition to disabling that feature you may need to set the number of avatars you can see (to a nice high number like 40+) and set the debug option "renderUnloadeAvatar (I think that's what it's called) to get the full correct behavior.

Share this post


Link to post
Share on other sites

The max number of avatars slider controls how many full avatars can be in viewer when imposters are enabled, no need to play with it when imposters are disabled.

RenderUnloadedAvatars just controls whether you see clouds or gray ruths. I wouldn't call either one the full and correct behavior. And they really have nothing to do with avatar imposters.

And the OP was asking about rendering glitches with imposters disabled, which I don't see on my machine. Sounds like a bug to me, you should create an issue in jira for it.

Share this post


Link to post
Share on other sites

Voids assessment is correct, at least for some (not entirely sure if all) viewers. If render unloaded is false and # of avis is low, some distant avis disappear. That behavior is a bug, and it only occurs with very specific graphics settings. The same bug triggers the OPs bug where far-off avis animate improperly.

Most people will never see that bug as it only triggers when the shadow code (deferred et al) is active.

Share this post


Link to post
Share on other sites

I'll have to play with the settings and see what happens. Thanks for the input.

FWIW, I am using a GTX260 with graphics on ultra. All options checked except avatar imposters, terrain detail on high. Anisotropic filtering enabled, antialiasing is handled by the drivers (disabled in the viewer), VBO enabled.

I guess I prolly just live with the keystone cops dancing in the distance as I like detail and turning on imposters makes the distant avatars look like pixelated cardboard.

Share this post


Link to post
Share on other sites

After some quick testing at Ahern I can now see the high speed animation bug, But neither the max # of imposters slider or RenderUnloadedAvatar effect it in anyway. And I still can't see the distant avatars disappearing bug.

Do you have a link to the jira issue?

Share this post


Link to post
Share on other sites

I'm now watching this JIRA issue and will try reproducing asap. I'm pretty sure that I experienced this bug and that it had something to do with Avatar Impostors but I can't remember the exact details now.

Share this post


Link to post
Share on other sites

You could change the value of renderAvatarMaxVisible in the Debug Settings to something higher.  That option contros how many of the closest avatars are not rendered as impostors.  Moving impostors further into the background will probably make them less noticable while giving you a slight performance boost not having to try to paint everything in detail on something that's only a few pixels in the distance anyway.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...