Jump to content

Deploys for the week of 2014-04-14


Maestro Linden
 Share

You are about to reply to a thread that has been inactive for 3650 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

  • Lindens

Second Life Server (main channel)

No rolls are scheduled for the main channel this week.

 

Second Life RC BlueSteel and RC LeTigre:

No rolls are scheduled for RC BlueSteel or RC LeTigre this week.  Both channels will remain on the inventory update project.  This project enables support for a new version of the inventory service, AISv3.  To make use of this new feature, login with the Sunshine RC Viewer.

 

Second Life RC Magnum:

Magnum is moving to a new maintenance project. This project includes a few bug fixes.

Scheduled Wednesday 2014-04-16 07:00-10:30 PDT

https://wiki.secondlife.com/wiki/Release_Notes/Second_Life_RC_Magnum/14#14.04.11.288970

 

We will be monitoring this thread as the code gets released, so feel free to note any observations you have about the server updates.  If you have a specific bug you'd like to report, please file a Jira

Link to comment
Share on other sites

This is a new wierd bug that's cropped up in the Magnum region I call home, following today's restart.

llGetAgentInfo is no longer consistently returning AGENT_MOUSELOOK information when called from objects attached to the avatar. Eg. in vehicles, or worn objects.

This is a killer for driving vehicles in mouselook, because the right-left keys that turn you left and right function completely differently in mouselook.

I have boats that drive the same whether you are in mouselook or not, AWSD keys or arrow-keys, by monitoring if the driver is in mouselook and swapping the functions of those calls.

Now they no longer work right in mouselook. They continue to work fine in non-mouselook mode, and they work fine in the neighboring non-Magnum region. 

I've looked at the release notes and there's nothing in there that mentions mouselook, but I'm wondering if it's something to do with being attached (worn or sat upon)? Perhaps whatever was done to fix the bug mentioned in the release notes, has broken the llGetAgentInfo / mouselook function.

What it seems to do exactly is sometimes (randomly, inconsistently) it indicates the agent is not in mouselook, even if they are. Again this only happens if the script containing the object is attached (worn or sat upon).

I'm still testing but this will kill my boats and probably other vehicles / wearables too if it stays like this.

Cheers

 Edited to add: Still testing, it might be dependant on llGetAgentInfo being called inside a control event. I'm trying to narrow it down.

Link to comment
Share on other sites

  • Lindens

Hi Atashi, I'm checking this out now in the "Magnum Sandbox" regions (which are all on the Magnum RC channel).  So far I've just been wearing this script as a HUD, to see if llGetAgentInfo() flags are working properly:

 

default{    state_entry()    {        llSetScale(<0.2, 0.2, 0.2>);        llSetTimerEvent(0.5);    }    timer()    {            integer agentinfo = llGetAgentInfo(llGetOwner());            list info_list = ["llGetAgentInfo() for owner"];            if(agentinfo & AGENT_AWAY) info_list += "_AWAY";            if(agentinfo & AGENT_BUSY) info_list += "_BUSY";            if(agentinfo & AGENT_SITTING) info_list += "_SITTING";            if(agentinfo & AGENT_ON_OBJECT) info_list += "_ON_OBJECT";            if(agentinfo & AGENT_ALWAYS_RUN) info_list += "_ALWAYS_RUN";            if(agentinfo & AGENT_FLYING) info_list += "_FLYING";            if(agentinfo & AGENT_WALKING) info_list += "_WALKING";            if(agentinfo & AGENT_MOUSELOOK) info_list += "_MOUSELOOK";            if(agentinfo & AGENT_TYPING) info_list += "_TYPING";            if(agentinfo & AGENT_ATTACHMENTS) info_list += "_ATTACHMENTS";            if(agentinfo & AGENT_AUTOPILOT) info_list += "_AUTOPILOT";            if(agentinfo & AGENT_CROUCHING) info_list += "_CROUCHING";            if(agentinfo & AGENT_IN_AIR) info_list += "_IN_AIR";            if(agentinfo & AGENT_SCRIPTED) info_list += "_SCRIPTED";            info_list += "at " + llGetTimestamp();            llSetText(llDumpList2String(info_list, "\n"), <0,1,0>, 1.0);    }}

So far, it appears to be detecting my avatar's mouselook state appropriately.  I've tried the following things to see if mouselook detection gets messed up:

  • Detaching and reattaching to HUD (while not in mouselook), then entering mouselook
  • Crossing a region border (while walking or flying) when in mouselook or not in mouselook
  • Crossing a region border on a vehicle when in mouselook or not in mouselook
  • Teleporting via world map (when not in mouselook)

Is some other behavior required to cause AGENT_MOUSELOOK to be incorrect?

Some Jiras have been filed reporting script breakage with combat systems, which sounds very similar to what you're seeing.  Right now, I'm looking for more details about what's broken:

https://jira.secondlife.com/browse/BUG-5758

https://jira.secondlife.com/browse/BUG-5759

Link to comment
Share on other sites

Thanks for the quick answer Maestro,

I have a similar result to your test script. I had made one myself and it worked fine both rezed on the ground or worn as a hud (or worn on my hand).

I don't know yet what the exact combination is that is causing the failure. The vehicles I have tested are calling llGetAgentInfo from inside a control event, and the weapons I have tested call it inside a timer event.

The vehicles have a changed event, so do the weapons.

I have tried recompiling scripts in the vehicles and it has not solved the problem.

I'll keep playing around with it as time permits.

I didn't file a JIRA yet because I haven't been able to come up with a solid repro or testcase. The two you linked to do sound to be exactly what I am seeing - the scripts in question simply aren't reliably detecting that the agent is in mouselook. 

Edited to add: for a demonstration, I have two boat rezzers here: http://slurl.com/secondlife/Thorklin/53/138/21 Swamp boats and Jetskis. They are in Thorklin, a Magnum RC region. Due west is Frumatay, which is on the normal SL server.

If you hop on a boat and use mouselook, it does not steer well any more in Thorklin, but if you go west into Frumatay it steers fine in mouselook. It works in both regions when you are not in mouselook.

The tell is there is a hovertext on the boat which displays health. When you are in mouselook, the text moves to the bow; in normal view the hovertext is at the stern. Only now, the hovertext flickers back and forth in mouselook as the script can no longer detect consistently that the driver is in mouselook. 

Link to comment
Share on other sites

  • Lindens

After further investigation, I found that the AGENT_MOUSELOOK flag is flakey when llGetAgentInfo() is called within a control() event.  I've filed this bug:

https://jira.secondlife.com/browse/BUG-5763

This seems like it covers the issues you've described, but please let us know if you see broken behavior outside of the scope of this report.

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 3650 days.

Please take a moment to consider if this thread is worth bumping.

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...