Jump to content

Mouselook help wanted (using objects)


You are about to reply to a thread that has been inactive for 4032 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts


Does anyone know if there is a way I can click on objects while in mouselook so I can use them ?


I've searched for this, but every reply I find says I have to use either ALT or ALT+Shift and then click with the mouse,

however this only gives me a hand-cursor which does nothing when I click with it.


To make it more clear what I mean, here is an example:


I have a cleaning bucket which is on the floor.

What I want to be able to do is click on it while in mouselook

so I get the pie menu,

select sit,

and then start scrubbing.


There must be a way to do this right ?

It be pretty weird if you can't do that just because you're in first person view.


I am using Phoenix Firestorm (latest version) in Phoenix mode.



Link to comment
Share on other sites

I ran into this issue some time ago.

I think it's a bug with llTakeControls(some control, FALSE,TRUE), which a lot of scripted items, such as AOs and collars, call in order to keep running in no script areas.   This has the unfortunate side-effect that it makes items untouchable while you're in mouselook.

See https://jira.secondlife.com/browse/SVC-7532 for more details.

The only work-round, I think, is to identify the attachment that's causing the trouble and not wear it, or find a substitute that calls llTakeControls(some control, TRUE,TRUE) instead (and maybe draw the attention of whoever scripted the other object to that jira).   It's a really obscure and nasty bug.  I've been scripting for 5 years and didn't know about until recently.

Link to comment
Share on other sites

Hm, I tried it out on another char (Conaletta has things on she can't remove herself), and removing everything

like clothes, HUDs, etc. didfn't seem to help much.

However I was able to get the menu by way of some combination of ...I actually don't

know what happened.


I tried to click with alt, nothing,

then I just click somewhere in the screen

and my char stretches out her hand,

and then left and righ clicking

untill suddenly the menu pops up.

Really don't know what I did,

but seemingly that works.


Link to comment
Share on other sites

Hm, I figured out what works for my other char.


It is:

Shift+alt (or maybe just Alt)

Then she stretches out her hand.

I left click.

Hold left click and then right while holding left pressed.

Then I get the menu and can use the object.

Left click again to remove the cursor.


For Conaletta however this doesn't seem to work,

so guess it might still be something she's wearing.


Hm, Conaletta is wearing:


An abaya from House of Alisha Couture, but I don't think there's the problem.

Cuffs from OpenCollar, but so was my other char and I tested with on and off.

A Dari House collar, guess there may lie the problem.

Actually I forgot to ask my Master to take that collar off which I wanted since it also

keeps giving collision errors.

(Besides it has a tag indicating it is a pet collar, not a slave collar, but ofcourse

thats a more personal thing.  :womanlol: )


Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 4032 days.

Please take a moment to consider if this thread is worth bumping.

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now

  • Create New...