Jump to content
  • 0

SL thinks I'm using German Keyboard - can't change it to English


Kimmiley
 Share

You are about to reply to a thread that has been inactive for 3246 days.

Please take a moment to consider if this thread is worth bumping.

Question

  • 0

When you change the language using CTRL+P, you must exit Second Life then restart it for it to change so strange it's changing when actually logged inworld but there are certainly other documented instances of the language changing like this. Perhaps some keyboard hot keys are doing it. There was a JIRA about the viewer suddenly changing language some years ago but I can't access it anymore. It was to do with keyboard remapping taking place after an edi but that was three years ago in 2009.

Keyboard is remapped after performing an edit
http://jira.secondlife.com/browse/VWR-10175

I did read a tip on changing languages and that was to be in Advanced mode (CTRL+ALT+D) when changing so try that.

Link to comment
Share on other sites

3 answers to this question

Recommended Posts

  • 0

When you change the language using CTRL+P, you must exit Second Life then restart it for it to change so strange it's changing when actually logged inworld but there are certainly other documented instances of the language changing like this. Perhaps some keyboard hot keys are doing it. There was a JIRA about the viewer suddenly changing language some years ago but I can't access it anymore. It was to do with keyboard remapping taking place after an edi but that was three years ago in 2009.

Keyboard is remapped after performing an edit
http://jira.secondlife.com/browse/VWR-10175

I did read a tip on changing languages and that was to be in Advanced mode (CTRL+ALT+D) when changing so try that.

Link to comment
Share on other sites

  • 0

More thoughts. You could remove the other language settings so only en-us is installed and see what happens.

http://wiki.secondlife.com/wiki/Skinning_HowTo/Basics

 

XUI folder

XUI (pronounced zoo-e) stands for XML User Interface. XUI consists of a custom XML data format for describing Second Life's user interface, and the code which processes that data and integrates it with the Second Life viewer. The XUI folder is \SecondLife\skins\[sKIN]\xui\.

Language folders

When you select a language in the Viewer (Preferences > General > Language), then the files in the appropriate [lang] folder are loaded hierarchically on top of the en-us version, starting the next time the viewer is run. The language folder is \SecondLife\skins\[sKIN]\xui\[lang], where [lang] is the locale code, such as:

Tier one languages:

  • de - German
  • fr - French
  • ja - Japanese

Additional languages, for example:

  • es - Spanish
  • zh - Simplified Chinese - not officially supported nor updated regularly

If an element (or entire file) is missing in the [lang] version, then the Viewer falls back to the value specified in the en-us version.

The \[lang] version of floater or panel contains only the minimum values desired to override from the en-us version. Generally this includes only the matching name= property and the translated string/label=. However in some cases a separate per-language width may be specified, to adjust the size of a particular widget for that language only.

The en-us folder

This folder is where the size of floaters, panels, and widgets are defined, as well the text strings in English the Viewer uses.

IMPORTANT NOTE: Do not ever change any name= parameters from the existing (English) name. The name= parameter is used to identify each node as expected when called in the Viewer code, and to match it to other translations of the same node.

  • Like 1
Link to comment
Share on other sites

  • 0

It might be because you have multiple languages installed on your computer.  (A Windows issue, not an SL one)  Here is a relevant comment from the JIRA...

On XP (I don't know about Vista, but likely to be the same):

  • The default keyboard shortcuts for "Switch input languages" and "Switch keyboard layouts" are Ctrl-Shift and LeftAlt-Shift, both of which are very easy to press when using SL.
  • The shortcuts can be disabled, in Regional and Language Options, Languages, Details, Key Settings, Change Key Sequence

 

  • Like 1
Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 3246 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...