Jump to content

blender 2.79 baked texture don't match to SL


Recommended Posts

Greetings,

after about 6 years I no longer remember some passages. I have built some Japanese temples in the past and with the help of valuable tutorials I always managed to work without problems. Now I'm trying to do some tests with a simple wooden floor with a simple cube on top to create a shadow.

I'll explain in more detail, I created the simple floor made of strips on Blender (version 2.79, I know, it's an old version, but it's the one I want to continue using).

Then I scaled the object (ctrl + A) and selected "compositing", unwrapping with "smart UV project" and thus creating the layout to fill.

In "world" I selected "ambient occlusion", as I used to; "gather" with "samples: 30".

In "render", the icon with the camera, I selected "bake" using in "bake mode" with "ambient occlusion" and thus I obtained the image with the shadow of the cube I spoke about.

https://i.gyazo.com/2a71b4a88c9acf041ac2270fc18da961.png

https://i.gyazo.com/7166c035f9d7f3ddf799fe367c5b883c.png

https://i.gyazo.com/233f387896135566c1d8e2b6dbd33599.png

Then I opened Gimp and alpha-colored the image to make it transparent. Once I exported the .png image I applied it to the wood texture in Photoshop. This way I got the texture ready to upload to Second Life.

I also loaded on SL the .DAE file of the floor, but once I apply the texture I get this result.

https://i.gyazo.com/7e3da1a432ab3e3bc5122898dd03167e.png

Could someone tell me what I forget to do?

I would also like to point out that on SL I can only use Convex Hull or None. I can't choose Prim because there's not (I use last version of Firestorm).

Thanks in advance.

 

 

P.S. I had already opened this topic in Bakes on Mesh forum, but Rowan Amore tell me that probably want this topic in the Building and Texturing forum. If so, I apologize.

Edited by Namuri
Link to comment
Share on other sites

Hi :)

If the texture looks OK in Blender but different when applied to the object in-world then usually it is because the object has more then 1 UV map linked to it in Blender.

Check to see if this is the case, Properties panel > Object Data tab > UV Maps. If more then 1 UV map either delete the one that you are not using or before exporting, select the correct UV map then in the Collada export panel use the SL+Open Sim Static presets which should automatically checks the Only Selected UV Map option.

1-min.thumb.png.f56ab05b56b6bd77775f845a745faf08.png

 

2-min.thumb.png.721c5c8dc476774a961c2c28e2645769.png

 

5 hours ago, Namuri said:

I would also like to point out that on SL I can only use Convex Hull or None. I can't choose Prim because there's not (I use last version of Firestorm)

If you don't see the Prim option it is because in the SL mesh exporter > Physics panel you did not specify a Physics model to use.

You can create your own custom physics model in Blender and choose to use that in the Physics panel > Step1: Pick a physics model (From file option) or simple choose the Cube option from this drop-down menu. This Cube will be stretched X Y and Z to fit your visual models bounding box.

The in Step2: Convert to Hulls hit the Analyze button.

 

3-min(1).thumb.png.f8ebf9e0e8c74cb6287f4523a553bf3b.png

Edited by Aquila Kytori
  • Like 1
Link to comment
Share on other sites

4 hours ago, Aquila Kytori said:

Hi :)

If the texture looks OK in Blender but different when applied to the object in-world then usually it is because the object has more then 1 UV map linked to it in Blender.

Check to see if this is the case, Properties panel > Object Data tab > UV Maps. If more then 1 UV map either delete the one that you are not using or before exporting, select the correct UV map then in the Collada export panel use the SL+Open Sim Static presets which should automatically checks the Only Selected UV Map option.

1-min.thumb.png.f56ab05b56b6bd77775f845a745faf08.png

 

2-min.thumb.png.721c5c8dc476774a961c2c28e2645769.png

 

If you don't see the Prim option it is because in the SL mesh exporter > Physics panel you did not specify a Physics model to use.

You can create your own custom physics model in Blender and choose to use that in the Physics panel > Step1: Pick a physics model (From file option) or simple choose the Cube option from this drop-down menu. This Cube will be stretched X Y and Z to fit your visual models bounding box.

The in Step2: Convert to Hulls hit the Analyze button.

 

3-min(1).thumb.png.f8ebf9e0e8c74cb6287f4523a553bf3b.png

 

AHAHHH Aquila Kytori YOU MADE MY DAY, thank you so much!!!

I totally forgot the steps you adviced me, in the meanwhile is changed something?

Anyway, thanks again, you was very kind 🙂

 

  • Like 1
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...