Jump to content

Multiple tattoo layers causing avatar rebake failure.


You are about to reply to a thread that has been inactive for 3607 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

I have searched to see if it has been reported before, but haven't found anything.

I think I've found a bug in the viewer where wearing multiple tattoo layers may cause the avatar to not rebake properly when items are worn and/or removed. I haven't quite figured out the sequence for forcing the bug, If I attach several tatto layers,  take off or replace one or more tatto layers the rebake will eventually fail.

When this happens the avatar will stay a cloud when relogging.

Two reasons I post it here. First; to find out if anybody else can verify the issue since lately I have encountered 'bugs' that no one else have seen. :) Second; if this is a real bug, it may help some of the people asking questions about being a cloud. 

I created a jira, perhaps prematurely, where I added a slightly more detailed (but not any more well written) explanation. 

[EDIT] Correcting my own silly mistake in the text. Was not thinking straight when I wrote it.... :(

- Luc -

Link to comment
Share on other sites

you're saying that it's when they relog that the avatar baking stage fails? I'd actually suspect this might be caused by layer being applied out of order from what is received from inventory (basically trying to apply the layer before it's sent).

that may be down to the order they are fetched from inventory which might be hard to test for.

Link to comment
Share on other sites

The baking fails at the time more tattoo layers are worn at the same time. The avatar stays visible but not properly updated. It's kind of funny to see when the failure happens; if you change skins, half the body is the newly attached skin and half is the old. It looks really wierd. After relogging you become a cloud. At least this is what happened to me.

When I was playing around with this, I could wear the layers one by one without issues. The assets were definitely received and downloaded, if that's what you're thinking of. The issue only appeared when I wore several layers at the same time.

- Luc -

Link to comment
Share on other sites

yeah, my thought is that it's a sorting issue, since they sort of snuck sorting code into multiple layers.... but if it's happening before a relog it may be easier to test for, but a slightly different cause than I was thinking...

it should be able to reproduce with something like 2 or three items... apply A then B, remove A, then reapply... or extend the same idea out to thre layers, causing a previously baked and sorted layer to change positions, or a new layer to be applied after an earlier layer is removed from the stack (just not the last one applied)..... throw in actual clothing layers for added testing, but it should give you an idea for where to start for getting a reproduction that others can test.

Link to comment
Share on other sites


Void Singer wrote:

yeah, my thought is that it's a sorting issue, since they sort of snuck sorting code into multiple layers.... but if it's happening before a relog it may be easier to test for, but a slightly different cause than I was thinking...

it should be able to reproduce with something like 2 or three items... apply A then B, remove A, then reapply... or extend the same idea out to thre layers, causing a previously baked and sorted layer to change positions, or a new layer to be applied after an earlier layer is removed from the stack (just not the last one applied)..... throw in actual clothing layers for added testing, but it should give you an idea for where to start for getting a reproduction that others can test.

OMG have I been sayin it? Have I been sayin it? Oh YA! I been sayin it! I been sayin it for three weeks and got my own JIRA complaint out about it! I can't believe he said nobody's been sayin it it cause I've been sayin it!!

/me radiates with joy. Free! Free! I wasn't targeted by failure! It hunts us all!!!!!! :smileyvery-happy:

Link to comment
Share on other sites


Luc Starsider wrote:

I'm sorry, Kascha!!!!! I searched for a jira, and on the forums, before posting. Couldn't find anything... Promise!!!
:)

Post a link to your jira, and I'll add my findings to it and set  mine as duplicate.

- Luc -

So...you want me to like - discover it? Like track it down and say where it is, or something? Like in the JIRA? Heh - I'll...ya I got that link right over here...

/me runs, making random and sudden direction changes

No okay okay! I'll try to find it! All this pressure, how am I to even breathe long enough to-

I've had the issues for a while now. Since I went to V2 viewers. It's been suggested that it could be all sorts of things, from packet dropping and line quality to other stuff I can't remember, but the problem with inventory loading and texture load failures goes away immediately as soon as I switch to a 1.x viewer like Ascent. Each and every time.

This is through the latest version of the official viewer, latest Kirstens, latest Firestorm. Any V2 viewer. Multiple tattoo layers, such as hairbase, lipstick, eyelashes, and full body tattoo (which is what I have mine on) and sooner or later trying to swap hairbases will not work. Rebake fix = false, Relog fix = false, Clear Cache fix = false. And the same goes for changing pants for me. Eventually I will be stuck wearing the ones I have, despite them going bold = off and the replacement pair going bold = on. And I was being stuck in a cloud for in excess of 10 minutes easy every time - long after surrounding textures had loaded.

I rolled back to 2.6.1 official and deleted all other viewers except Ascent, and I am now at a point where I appear something closer to 1.x speed and, at least for the first 10-20 minutes, I can change clothing. But that always breaks down at some point. I was also having a problem with character testing my way out of the cloud only to find that the glitch pants that are part of the Girl next Door outfit had replaced my lower skin and could not be removed.

Oh and, as with you, since I stopped using outfits to dress, things have improved. Did that around the same time as the viewer rollback.

Just an FYI. I'll look for that JIRA link! :womanvery-happy:

 

Link to comment
Share on other sites

Here Luc - here's the JIRA I responded to:


JIRA SVC-6766 --> https://jira.secondlife.com/browse/SVC-6766?


Don't know what's wrong with hyperlinking (oh Steve Jobs just called and said I'm linking it wrong :womanwink:)

This JIRA was actually about UUID problems where the server was unable to retrieve and send said UUIDs for attached assets.

I referred also to the related SVC-6769 where detached stuff turns up attached again or otherwise refuses to come off, making clothing/jewelry/shoe changing impossible.

 

(Edited to say as usual, Steve doesn't know what he's talking about. The link actually did activate once posted!)

Link to comment
Share on other sites

OK, Kascha. Are you sitting down? Are you breathing? I don't want you to hyperventilate or anything... :D

I misunderstood; I thought you had filed a jira of your own for the same issue I'm talking about here.

I went to look at both the jiras you list. Both of them are, as far as I can tell, different than the tattoo layer business, but I'm not entirely sure.

I did, however, add a comment to SVC-6769. Perhaps you could see if you recognize any of what I said there.

I remember your posts, and all the suggestions I made that didn't actually help much. At the time I didn't know that several tattoo layers - and also alpha layers, I guess - could cause this kind of issue. I only learned this a few days ago. I'm sorry I didn't remember to check if there was issues - like yours - I've replied to that could be helped by this. :(

Oh, and Steve is not always right. :D

- Luc -

Link to comment
Share on other sites

  • 1 year later...

Yep! I just found this exact bug. In the Firestorm Viewers. The most recent one and the one precdeing it. I became a cloud  after the steps you outlined and nothing was fixing it. After installing the latest FS release I did another Google search for the rebake fail. Found your post here. Removed a tatoo I was wearing and immediately, there I was. Thank you. 

Link to comment
Share on other sites

  • 2 weeks later...

Hi, its actually still happening, I was a cloud for days before I did the avi test. Then I wore my clothing and had to remove everything the newbie avi was wearing then it seemed fine. Except now, nothing will rez at all below the neck, so any rebaking is from the neck up.. Very strange.. Hope it gets solved and thanks for the post.

Link to comment
Share on other sites

  • 4 weeks later...

Yes, me too. I need to remove a 'tattoo layer' to appear (mostly my torso ink, while wearing make-up). My torso ink can be worn as pants or underwear, which can be good but if I 'wear' instead of 'add', it can be embarressing...  Currently following Project Shining blog to see if it will be resolved.

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 3607 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...