Jump to content

Why avatar jumps when changing textures


MisakiMatsumoto
 Share

You are about to reply to a thread that has been inactive for 2615 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

 

Created an avatar, upload from Blender using Avastar, the object starts acting weird when superimposed texture. He begins to jump when changing texture. Help please, what options of import and export need to be set in Avastar and in the Second life client

I have a human avatar standard sizes, only the location of the joints is a little different, so I think apple armature scale is not necessary to put when you export. It might be impossible to export several parts of the avatar at the same time, not combining them, which is probably why my head's avatar rides because I have a few parts of the avatar are not exported separately but simultaneously, I didn't United, in Second life I in the standard way via the menu edit shared object, legs, body and head separately and then put the texture, and has such a pleasant effect. What do you think , what could be the reason in your opinion?



Link to comment
Share on other sites

 

 made as written, this is the result)

I downloaded with the recommended settings the entire avatar, and then separated the legs arms and head in since I already have them separated in blender. But this head starts acting weird

If this occurs when I upload in Second life put a tick to save the position of the joints. If this is not done then the avatar becomes deformed because the bones of the skeleton differs from the standard



Link to comment
Share on other sites

You could ask in the chat group "blender avastar" or create a support ticket on our site http://blog.machinimatrix.org/tickets

But please note that we want to inspect the blend file, because there are so many possible reasons why things could go wrong. It could be due to the combination of used modifiers, because of shape keys, scaling and rotation issues, child parent relationship, and of course there is always the chance that you have found a bug either in Blender or in Avastar or in the SL Importer.

We can not give any answer without knowing what you have done. And our answers take some time. The best you can do is to prepare your question so that we can easily reproduce your issue.

i hope this is convincing :)

Link to comment
Share on other sites

The option "Apply Armature Scale" is only good for the situation when you have scaled your Armature in Object mode AND when you have created animaitons for your scaled object.

So Instead of first applying the scale to the armature, you can use this option to avoid applying the scale in Blender.

Why you might want to avoid applying the scale to the Armature in blender

The problem is that when you have created some animations for your model while the armature was scaled in object mode, then applying the scale to the armature would partially destroy your animations (all keyframes that contain location keys will result in odd distortions of the animation in that case. If you want to understand this in more depth, then please take a look at http://blog.machinimatrix.org/sparkles/animation-scale-tool/

  • Like 1
Link to comment
Share on other sites

You only need to enable "Include joint positions" in the Options tab of the SL Viewer's Collada Importer.

You might want to try applying rotation & scale of your objects before you export from Blender. Maybe there is a bug with the automatic apply of the Scale&rotation during export.

  • Like 1
Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 2615 days.

Please take a moment to consider if this thread is worth bumping.

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...