Jump to content

Oculus SL Viewer doesn't see my GeForce GTX 980 card - refuses to start the HMD display


RogueAssassin
 Share

You are about to reply to a thread that has been inactive for 2659 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

I'm trying to view SL with my Oculus Rift headset, but the newest SL Project Oculus Rift viewer does not recognize my video card when I try to switch the view to the headset with Ctrl+Shift+D.

I get the error message: 

"Cannot enter HMD mode because your graphics card does not support the minimum requirements.  Vetext Shaders and Vertex Buffer Objects are required for proper rendering in HMD mode."

 

Well gee, if my GeForce GTX 980 card (one of the fastest video cards) can't run it, what can?  :P

I'm running on an ASUS X99 Delux motherboard.  There is no built-in video card on the mobo.

 

Has anyone had this problem, and is there a workaround...?

Thanks!

Link to comment
Share on other sites


RogueAssassin wrote:

I'm trying to view SL with my Oculus Rift headset, but the newest
does not recognize my video card when I try to switch the view to the headset with Ctrl+Shift+D.

I get the error message: 

"Cannot enter HMD mode because your graphics card does not support the minimum requirements.  Vetext Shaders and Vertex Buffer Objects are required for proper rendering in HMD mode."

 

Well gee, if my GeForce GTX 980 card (one of the fastest video cards) can't run it, what can? 
:P

I'm running on an ASUS X99 Delux motherboard.  There is no built-in video card on the mobo.

 

Has anyone had this problem, and is there a workaround...?

Thanks!

The SL Oculus viewer uses an older card-detection system that requires the card to be listed in a lookup table. There are other threads in this forum and on the Lab's JIRA bug-reporting page that describe how to add new cards to it manually. From the looks of things there may be a new release of the project viewer soon that may fix this though.

You might also try using the CtrlAltStudio viewer - it's a third-party viewer for the Rift that's been updated more actively lately so they may have already added newer cards to the lookup table. http://ctrlaltstudio.com/

Link to comment
Share on other sites

The rift viewer still uses the old gpu table, which is no longer maintained and does not have the most recent graphics cards added to it.

If you follow the instructions on https://jira.secondlife.com/browse/BUG-8771 to replace the gpu table with the one attached to that JIRA issue, you should be able to enable Advanced Lighting Model in graphics preferences, which will enable you to use HMD mode.

Be aware that the Rift viewer will not work with the latest Oculus runtime though:

https://jira.secondlife.com/browse/RIFT-184 - Doesn't work with Oculus Rift Runtime 0.7x

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 2659 days.

Please take a moment to consider if this thread is worth bumping.

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...