Jump to content

Connection dropping with Second Life.


You are about to reply to a thread that has been inactive for 3620 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

Hello! I have a question to a problem I've been having ever since I moved back to my old home (haven't really played SL much before then, but never seemed to have this problem before).

I can log into the game perfectly fine, and have no problems whatsoever while at my SL home. But every time I go to a place with a lot of objects, or a medium to heavily populated area in SL (ie, any place with a decent amount of things to rez) my internet drops, and reconnects after about 30-60 seconds or so. I wouldn't really mind, but it's terribly annoying when I'm talking to my bf on Skype, and I'm flopping around somewhere and end up dropping the call because of it.

As for relevent personal info, I'm using Firestorm viewer on Vista 64-bit, a Belkin router (can't recall more specifically off the top of my head right now) I'm hardwired into with about 28 Mbps download / 1 Mbps upload speed. Feel free to ask if I left something else out that may help. o3o

Link to comment
Share on other sites

If you are alright at your home and your Internet connection drops when you teleport somewhere new, it's because your home textures are already cached on your hard drive and it's only when trying to load too many new textures to your cache that the problem develops. Did your internet drop initially when accessing your SL home for the first time from your old RL home or is your SL home fairly light on textures? I suspect your router is crashing and then resetting, the cause being HTTP Textures. Try disabling HTTP Textures in the Develop Menu (CTRL+ALT+Q) or access the Develop Menu from the Advanced Menu (CTRL+ALT+D). Untick HTTP Textures to disable it.

Link to comment
Share on other sites

sounds like the Belkin router. some of them do that. like if they getting flooded with http requests then they shut down and reset

can try turn off HTTP textures and HTTP Inventory on Develop menu (Ctrl+Alt+Q) and see if that helps. this the most common fix for this problem

+

edit: what Nyll said :)

 

 

Link to comment
Share on other sites

I wouldn't quite call my home the lightest on textures and objects to rez, but it's certainly nowhere near as intensive as some of the places I flop around to (thinking of more popular places like.. London, for example). But anyways, I tried disabling both HTTP Textures and HTTP Inventory, but neither seem to have helped any, as my connection still drops. :<

Link to comment
Share on other sites

dunno what is your Belkin model. but this a problem for Belkins on all kinds of internet games. not just SL

it have to do with MTU which determine the size of packets that the router uses

linden use a max target packet size of 1200 for content plus some overhead that vary depend on content. what Andrew Linden said is that most SL packets are quite tiny. like way under 1200 except for textures. which are packed

if a packet size exceed 1500 which is the protocol MTU max. then the viewer logs a warning but the server sends it anyway

when your router is set to say only MTU 500 then if get sent a 1500 packet then get 3 packets. bc is heaps textures and heaps packets in SL then can flood the router and get heaps packet loss and end up crasho the Belkin

is not just SL does this. lots of other internet games crash the Belkin the same way

+

on my Belkin MTU is set to 1454. is the manufacturer default. however lots of gamers report that it goes better on 1400

to change this then have to login to the router setup. address 192.168.2.1   then if your ISP allow PPPoA then change to this from PPPoE. the whole internet goes better on PPPoA when upload speed is 1.0 or less

so in the setup then Internet WAN > Connection Type > PPPoA

change the MTU on this page

+

if 1400 not make any difference then try 1478. that the other magic number gamers use

 

+

edit: just make a note of the current MTU number before you start changing it. so can restore it if the other numbers don't work (:

 

Link to comment
Share on other sites

happened to me several times yesterday. Turned out I had 2 internet connections running at the same time (wifi and wired). I GUESS for whatever reason my viewer tried to switch connections every few minutes, causing it to disconnect (both connections were constantly internet enabled, but of course had separate internal IP addresses).

Turned off wifi and rock steady since.

Link to comment
Share on other sites

Meep! Sorry for the late response, work's been eating up almost all of my free time lately. But I think I may have solved the issue a couple minutes ago. *Crosses her claws, hoping not to have jynxed it.*

So I never had anything setup with my ISP for PPPoE; at least I don't think. Granted, I didn't see if I could try it out without contacting them. >.>

I did, however, find something off of Nyll's link to change my MTU. At first I tried it at the 'optimal' setting which set it to 1500, and it seemed to work fairly well for the most part. But I was still encountering the issue. I then tried the custom setting, and changed the MTU to 1400 like 16 suggested, and I tried flopping around some of the places my router would explode on, and haven't gotten disconnected yet.

To anyone else having the issue, I found a link to this TCP Optimizer download: http://www.speedguide.net/downloads.php/ - off of the first comment on the link Nyll gave, which seems to have worked, at least right now.

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 3620 days.

Please take a moment to consider if this thread is worth bumping.

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...