Jump to content
  • 0

I need help with sl viewer


You are about to reply to a thread that has been inactive for 4065 days.

Please take a moment to consider if this thread is worth bumping.


Hi.  I am having trouble with my sl viewer.  I download the setup.exe thing from the website and that went find and I ran it on my computer after it finished downloading and when I click on the sl viewer , it asks me which language I want which is fine.

except when I click on the viewer or try to run it.  a sign that says second life crash logger shows up.  why is this happening?


I would just like to play second life.

I have windows vista. I own the computer. It is not ten years old,It is fairly recent. I am new to second life. It should meet the requirements. I have enough space. I uninstalled it and restarted the computer and redownloaded it. i also followed the instructions on wiki crash logger. it didnt work i still get the same thing.:( please help.

I did a speed test. I don't know if this will help. Let me know if you need anymore information.

my ping is 50ms the download 1.22 .the upload is 0.08. 

Link to comment
Share on other sites

1 answer to this question

Recommended Posts

  • 0


please make sure you have the latest version of the viewer from https://secondlife.com/support/downloads?lang=en-US


I can't give any specific help without knowing what Operating System you have.

Can you please click the Options menu at the top right of the page, click 'Edit' and tell us your OS version.


Make sure you have the latest graphics driver version from your graphics adapter's manufacturer.

If you're on Windows make sure you have the latest service pack from http://www.microsoftupdate.com/

And make sure your computer meets the minimum specs from this page: http://secondlife.com/support/system-requirements/

You cannot run the viewer on a 10 year old laptop, there are other third-party viewers that support these older hardware-types, try: http://radegast.org/wiki/Radegast_Download

Make sure that the viewer and all plugins (SLVoice.exe and SLplugin.exe), and UDP and TCP connection types and ports are whitelisted in your antivirus and firewall software and on your modem/router configuration page. See also here for the exact port numbers ( there are alot! ) : http://community.secondlife.com/t5/Technical/How-can-I-configure-my-hardware-firewall-such-as-a-router/qaq-p/696298 (or also http://suezannecbaskerville.wordpress.com/second-life-firewalls-routers-ports-udp-tcp/ )

Also check your graphics card software (NVidia Control panel, CCC or something like this) if it's set to using the correct graphics adapter for Second Life.

Are you on a public place (library, school...) where specific connection types and applications are being blocked?

See also this question and the links to one of the helpers' collection of troubleshooting-tips:



If that doesn't help, try a complete "clean install" (uninstall and re-install) of the viewer, and restart your computer before you install it again. Here is a step-by-step guide: http://wiki.secondlife.com/wiki/Clean_Install

If none of the above helps,

please go to http://support.secondlife.com/contact-support and contact support about your issues.


Other links and resources:



Here is a nice guide from the Firestorm team: http://wiki.phoenixviewer.com/fs_install_crash

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 4065 days.

Please take a moment to consider if this thread is worth bumping.

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now

  • Create New...